Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-30-2011, 08:44 AM   #1
Veteran Member
soppy's Avatar

Join Date: Apr 2007
Location: Gainesville
Posts: 348
LCD Fades to White?

I had this happen last night, I took a 30 sec exposure, clicked play, and was showing someone the photo, then out of nowhere the LCD just starts fading to be all white. It had some vertical grey lines at first, then they faded to horizontal grey, but they were very faint. I turned off the camera and right back on and was fine the rest of the night. Has anyone had this issue?

09-30-2011, 09:43 AM   #2
Veteran Member
SlickYamaha's Avatar

Join Date: Nov 2010
Location: Bel Air MD
Photos: Gallery | Albums
Posts: 840
QuoteOriginally posted by soppy Quote
I had this happen last night, I took a 30 sec exposure, clicked play, and was showing someone the photo, then out of nowhere the LCD just starts fading to be all white. It had some vertical grey lines at first, then they faded to horizontal grey, but they were very faint. I turned off the camera and right back on and was fine the rest of the night. Has anyone had this issue?
Is this in addition to your other thread about the stains? Or a whole new problem?
09-30-2011, 09:44 AM   #3
Veteran Member
soppy's Avatar

Join Date: Apr 2007
Location: Gainesville
Posts: 348
Original Poster
I'm pretty confidant this is a seperate issue. I'm just wondering if there's something else I need to let Pentax know about and have fixed when I do get around to sending it in.
09-30-2011, 10:51 AM   #4
Pentaxian




Join Date: Feb 2011
Location: Hoek van Holland
Photos: Gallery | Albums
Posts: 1,252
I have had a similar rpoblem with my DV camera, they had to replace the LCD screen as the problem lay there. Yours could be something different, but it sounds the same what I had

10-02-2011, 02:59 PM   #5
Senior Member




Join Date: Apr 2011
Location: Lake Saint Louis
Posts: 126
I had it happen right after I got it back from CRIS for mirror flops and dust under LCD cover. It was like looking through milk. The image recorded to the card was fine and turning it off and on again cleared it up. It has not done it since.

Wayne
10-02-2011, 08:19 PM   #6
Senior Member




Join Date: Mar 2011
Location: Bristol, NY - Finger Lakes Region
Posts: 131
Had this happen 1 time on power up and I rebooted camera and haven't seen it since.Tough sell to Service unless it happens with some higher frequency on your camera.

Last edited by jcp5; 10-03-2011 at 06:24 AM.
10-03-2011, 02:28 PM   #7
Veteran Member
mysterick's Avatar

Join Date: Oct 2006
Location: 44266
Photos: Gallery | Albums
Posts: 428
I too...

have had this happen a couple times. On/off corrects the problem as well. I just wonder if it will lead to greater problems with time.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, k-5, k-5 ii, k-5 iis, k5, lcd, night, pentax k-5
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
LCD in Black & White possible? nickmeertens Pentax K-5 5 05-08-2012 06:07 AM
Paint fades on AF button coolguy1004 Pentax DSLR Discussion 6 03-16-2011 01:08 PM
My 67 II Top LCD fades/operation stops Sig M9 Pentax Medium Format 1 12-17-2010 10:22 AM
On-camera LCD vs Computer LCD Andi Lo Pentax DSLR Discussion 6 02-07-2009 01:59 AM
K10 LCD vs K20 LCD wildboar Pentax DSLR Discussion 2 10-07-2008 01:56 PM



All times are GMT -7. The time now is 06:27 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top