Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-05-2011, 03:08 PM   #1
Senior Member
veato's Avatar

Join Date: Oct 2011
Location: Nottingham
Posts: 152
Oh no, K5 is broken!

Well I discovered today the lens release button on the K5 has fallen off. It hasn't been dropped or anything, I just pulled the camera out of the bag and it was minus the button. If I reattach it it just falls off again.

Looking on the net it seems it's a bit of a common fault. I've only had the camera 6 months.

I'd normally go back to the store in the UK and let them take care of it but I bought it off Simply Electronics and I have zero faith in them. Time to dig out the receipt and contact Pentax!

Has anyone else:

a) Had this fault?
b) Had it repaired under warranty by Pentax?
c) Not had the fault return?

10-05-2011, 03:21 PM   #2
Senior Moderator
Loyal Site Supporter
Parallax's Avatar

Join Date: Apr 2008
Location: South Dakota
Photos: Gallery
Posts: 15,387
https://www.pentaxforums.com/forums/pentax-k-5-forum/147149-lens-release-butt...-my-k-5-a.html
10-05-2011, 03:36 PM   #3
Pentaxian
twitch's Avatar

Join Date: Nov 2009
Posts: 4,571
Ouch, sorry to hear that, this is becoming an epidemic.
10-05-2011, 03:44 PM   #4
Pentaxian
Wheatfield's Avatar

Join Date: Apr 2008
Location: The wheatfields of Canada
Posts: 10,065
Must not say anything lest I get squirrels flinging poo directed my way.

10-05-2011, 03:48 PM   #5
Ash
Community Manager
Loyal Site Supporter
Ash's Avatar

Join Date: Mar 2007
Location: Toowoomba, Queensland
Photos: Gallery | Albums
Posts: 22,683
Sorry to hear.
Never experienced with my own copy, but clearly you're not the first case, and you probably won't be the last. All the best in having it repaired.
10-05-2011, 03:50 PM   #6
Senior Member
veato's Avatar

Join Date: Oct 2011
Location: Nottingham
Posts: 152
Original Poster
I'm thinking I should check for sensor stains before I send it off too
10-05-2011, 03:59 PM   #7
Senior Moderator
Loyal Site Supporter
Parallax's Avatar

Join Date: Apr 2008
Location: South Dakota
Photos: Gallery
Posts: 15,387
QuoteOriginally posted by Wheatfield Quote
Must not say anything lest I get squirrels flinging poo directed my way.
10-05-2011, 04:25 PM   #8
Site Supporter
Ex Finn.'s Avatar

Join Date: Nov 2007
Location: Southern Maryland.
Photos: Gallery | Albums
Posts: 6,144
QuoteOriginally posted by Wheatfield Quote
Must not say anything lest I get squirrels flinging poo directed my way.
Damn.

10-05-2011, 05:58 PM   #9
Veteran Member
mickey's Avatar

Join Date: Oct 2008
Location: Japan
Photos: Gallery | Albums
Posts: 1,073
The SR switch broke off my K10d a long while ago, which was quite common back then on some batches.

Like you experienced, it wasn't through misuse, I hardly ever switched it off, only when I used my tripod which wasn't very often.

Took it to Pentax and they seemed to be familiar with this problem.
It was fixed and returned within in a week or so.

I'd say get it sent off quickly and you should be good to go.
10-05-2011, 07:24 PM   #10
Veteran Member
Smeggypants's Avatar

Join Date: Sep 2010
Posts: 1,536
QuoteOriginally posted by Wheatfield Quote
Must not say anything lest I get squirrels flinging poo directed my way.
it would abort.
10-05-2011, 08:43 PM   #11
Senior Member




Join Date: Aug 2011
Location: NC
Posts: 206
Sorry to hear this. I would check for stains as it'll need a repair trip regardless.

Would you mind posting your SN and mfgr date (can get this via exif data), just in the chances this may eventually turn out to be limited to a range of cameras (or it may also indicate otherwise/all cameras with enough people reporting).
10-08-2011, 07:19 AM   #12
New Member




Join Date: Feb 2009
Location: Connecticut
Photos: Gallery | Albums
Posts: 20
Sorry to here this as I would like to upgrade my K20 but my feeling with the brand after reading all these defects prevents me from moving forward. My view of the brand is.
If one believes as I do the Ricoh management was in place 12 months pervious to the Oct 1st transfer on the books as it would be typical for an operation of this nature. The QC of the brand my not improve as it has already been established.
10-08-2011, 08:36 AM   #13
Loyal Site Supporter
Tom S.'s Avatar

Join Date: May 2008
Location: S.E. Michigan
Photos: Albums
Posts: 4,238
QuoteOriginally posted by Wheatfield Quote
Must not say anything lest I get squirrels flinging poo directed my way.
Nonsense! I heard the poo works very well for reattaching the button.
10-08-2011, 07:23 PM   #14
Veteran Member




Join Date: Jun 2007
Location: Buffalo/Rochester, NY
Photos: Albums
Posts: 1,133
QuoteOriginally posted by Tom S. Quote
Nonsense! I heard the poo works very well for reattaching the button.
Only if the squirrel gives up his nuts and sticks to a high-fiber diet...
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
button, camera, dslr, fault, k-5, k-5 ii, k-5 iis, k5, pentax, pentax k-5
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Broken ME, want to take apart Capslock118 Pentax Film SLR Discussion 12 11-12-2010 05:19 AM
Lens is broken: broken mount nemo9439 Pentax SLR Lens Discussion 4 08-27-2010 09:52 AM
IS broken? sealisthenewbeaver Pentax DSLR Discussion 16 08-17-2010 07:00 AM
Broken dreams, broken camera brkl Post Your Photos! 3 03-10-2009 05:08 PM



All times are GMT -7. The time now is 07:00 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top