Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-09-2011, 02:45 PM   #1
New Member




Join Date: Oct 2011
Location: Montreal region
Posts: 4
K-5 AF Frame - Is this mold ?

Hi there people,

I browsed a bit and searched a bit before posting but I'm not finding other people having the same issue I am. I have my K-5 since the month of June and everything was fine until the 1st of October. Today (the 9th), I took a couple of pictures and, behold, I have a spot (it kind of looks like mold) on the AF frame. I took a couple of pictures and that spot doesn't appear on the pictures. It's just there in the viewfinder. I changed lenses and nothing, it's still there. I'm including a pic (I know, it's not the sharpest of things, but it gives an idea of what I'm seeing), it's on the right side, just before the "]".

I was wondering if anybody had experienced this issue and what you did.

Many thanks and happy shootings

Attached Images
 
10-09-2011, 02:53 PM   #2
Veteran Member
ihasa's Avatar

Join Date: Jul 2009
Location: West Midlands
Photos: Gallery
Posts: 2,054
Could it just be dust? You could try blowing it out with a rocket blower. Hopefully not depositing it onto the sensor in the process
10-09-2011, 02:54 PM   #3
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 43,226
Mold isn't really an issue with focusing screens- you should try brushing it off.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

10-09-2011, 02:58 PM   #4
New Member




Join Date: Oct 2011
Location: Montreal region
Posts: 4
Original Poster
Hi there ihasa,

I'm such a newb :| I actually didn't think that it was dust because I had the dust reduction system on and it was there whether or not I turned the camera on... but I just followed your recommendation and it did the trick. It did move though so I definitely have a dust issue and I guess I can just take it to a store and get it cleaned.

Thank you ihasa

10-09-2011, 03:02 PM   #5
Veteran Member
alohadave's Avatar

Join Date: Jan 2008
Location: Quincy, MA
Photos: Gallery | Albums
Posts: 2,024
QuoteOriginally posted by RainStorm75 Quote
Hi there ihasa,

I'm such a newb :| I actually didn't think that it was dust because I had the dust reduction system on and it was there whether or not I turned the camera on... but I just followed your recommendation and it did the trick. It did move though so I definitely have a dust issue and I guess I can just take it to a store and get it cleaned.

Thank you ihasa
Dust reduction is for the sensor, not the focusing screen. They are in totally different places.
10-09-2011, 03:09 PM   #6
New Member




Join Date: Oct 2011
Location: Montreal region
Posts: 4
Original Poster
I guess I'm at the right place to learn.

Thank you alohadave.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
bit, camera, couple, dslr, frame, k-5, k-5 ii, k-5 iis, k5, mold, pentax k-5, people, pictures
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Are Lens Mold Problems That Common? stills999 Pentax SLR Lens Discussion 9 09-19-2011 01:44 PM
6x7 mirror mechanism - what is this - mold? gus_the_mouse Pentax Medium Format 6 08-08-2011 12:34 PM
Mold? MIKESDEALS Troubleshooting and Beginner Help 4 02-02-2011 11:30 AM
Is this Mold? GregK8 Pentax SLR Lens Discussion 6 04-03-2010 09:47 PM
Went to wipe my 50/1.4 and no luck. Mold :-( How to clear? Unsinkable II Pentax SLR Lens Discussion 13 04-01-2010 01:07 PM



All times are GMT -7. The time now is 10:32 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top