Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-18-2011, 07:48 AM   #16
Junior Member
mrdfred's Avatar

Join Date: Nov 2009
Location: Eugene, OR
Posts: 45
Original Poster
Info from PENTAX

Randall S: Thank you for contacting Pentax chat support David, how may I help you?

David : I have a Vivitar DF-383-PEN flash that works perfect on my K20d, but will not work on my K-5

Randall S: I don't have any support information on Vivitar flashes. Have you tried contacting them?

David : Is there a known problem with this flash?

Randall S: I don't know because we don't test our camera's with other manufacturer's flashes.

David : Yes, they think it is a camera issue, I have also searched the Pentax Forum and have found other K-5 owners having the same issue

Randall S: we don't guarantee compatibility of our cameras with third-party flashes.

David : Has there been a change in the flash config on the K-5?

Randall S: no, the flash function is the same. however, the firmware for the K-5 is different than the K20D. That may be the issue.

David : I understand "no Guarantee", I just want to know if there is a diff?

David : I have updated the firmware to 1.11

Randall S: I don't know of any difference in the K-5 that would account for this problem.

David : If many K-5 owners are having this problem, will Pentax issue a firmware update to address this?

Randall S: maybe some of those users you mentioned on the forums have found a workaround but we wouldn't have any way to assist you with that flash.

Randall S: no, PENTAX does not upgrade firmware to accommodate third-party accessory compatibility.

David : I'm looking for info and letting you know that I and others are having this problem.

Randall S: I'm sorry, we don't have any information relating to a Vivitar flash.

Randall S: have you tried a PENTAX flash on the camera?

David : Any suggestions, nobody on the forum has found a workaround

Randall S: no, sorry, I don't have any suggestions.

David : No, I don't own a pentax flash

Your session has ended. You may now close this window.

10-24-2011, 12:18 PM   #17
Junior Member
mrdfred's Avatar

Join Date: Nov 2009
Location: Eugene, OR
Posts: 45
Original Poster
I called B&H photo and explained the Vivitar DF-383-PEN flash - K-5 problem. They looked into their data base of reasons for K-5s being returned and found nobody had returned one for this problem. They agreed with the Vivitar representative I spoke with, that it was a problem was with the K-5. They told me to return it for a replacement, which I did today. I must say, B&H were cheerful, helpful and very pleasant to deal with, I am glad I bought the K-5 from them.
10-24-2011, 12:53 PM   #18
Veteran Member
sterretje's Avatar

Join Date: Dec 2008
Location: Roodepoort, South Africa
Photos: Gallery | Albums
Posts: 3,534
Please let us know if it solves the problem. It can be useful for others as well.

By the way, either yesterday or today somebody posted a reply fro Vivitar which indicated that one should update to the latest camera firmware (1.11 if I'm not mistaken); you can do a search. I'm a little sceptical, but it might do the trick if your replacement camera still shows the behaviour.
10-24-2011, 01:12 PM   #19
Junior Member
mrdfred's Avatar

Join Date: Nov 2009
Location: Eugene, OR
Posts: 45
Original Poster
QuoteOriginally posted by sterretje Quote
Please let us know if it solves the problem. It can be useful for others as well.

By the way, either yesterday or today somebody posted a reply fro Vivitar which indicated that one should update to the latest camera firmware (1.11 if I'm not mistaken); you can do a search. I'm a little sceptical, but it might do the trick if your replacement camera still shows the behaviour.
The first thing I did when I got the K-5 was to update it to firmware 1.11, so that wasn't a 'fix'. I'll update this when I get the replacement K-5. I'm skeptical that the replacement K-5 will act any differently. I have looked at a lot of places on the web, and now know more than I ever wanted to know about how third party flashes are made to work with cameras. Apparently only Metz has collaborated with Pentax to make sure that their flash works with all Pentax cameras. They also provide firmware updates based on the model of camera you own. Vivitar 383 has a port, but it isn't identified and there is no firmware update posted on their website. I wish I knew what I know now about third party flashes when I bought the Vivitar 383. To it's credit, it worked perfect with the K20d. I wonder if the Vivitar 383s that are currently being sold have any different firmware than the one I bought, to make them work with the K-5.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, cycle, dslr, flash, function, k-5, k-5 ii, k-5 iis, k5, pentax k-5, pulse
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Shutter only fires sometimes with manual lens - sears 50mm f1.7 jptruesdale Troubleshooting and Beginner Help 4 10-11-2011 08:16 AM
k-x turned k-r mom2mny Troubleshooting and Beginner Help 12 05-04-2011 10:08 AM
K5 - NR and DFS - can it be turned off Mortox Pentax K-5 2 11-02-2010 07:56 PM
Landscape Bay of fires Yaro Post Your Photos! 5 09-20-2010 12:49 AM
Fires in the ice... clarenceclose Post Your Photos! 9 12-28-2006 06:49 AM



All times are GMT -7. The time now is 12:55 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top