Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-19-2011, 03:44 AM   #1
Pentaxian
Mike.P's Avatar

Join Date: Mar 2008
Location: South Coast .. UK
Photos: Gallery
Posts: 1,756
K-5 shutter button problem ?

Ok, this is my third K-5 (first 2 had stains and a dodgy wheel) and it has been fine since I got it 6 months ago.

I am now having some problems with the shutter button, when I press it the camera quite often takes 2 pictures. I have made sure I am only set to single shot mode and have started pressing quite firmly just to make sure I am not twitching on the button so as to cause the double shot but this makes no difference.

Just wondering if anyone else has come across this before?

TIA.

10-19-2011, 04:18 AM   #2
Junior Member




Join Date: Aug 2009
Location: Melbourne
Posts: 25
Yeah, mine does it. I also noticed the second half button press is soft and does not offer any real resistance or "click" feel. This is quite different to my K7.

It's done it from new, although new was a replacement for a stained sensor. It seemed quite well worn in (by all buttons' feel - particularly the on/off switch) when I got it but apart from the double exposures it works well. If it wasn't new then the shutter count had been reset.
10-19-2011, 04:49 AM   #3
Loyal Site Supporter
imtheguy's Avatar

Join Date: Mar 2009
Location: Virginia Beach
Photos: Gallery | Albums
Posts: 2,950
Me too as of a couple months ago. I can ensure a single shot by pressing the shutter harder and letting go quicker. Kind of goes against the grain when gently squeezing off a shot to prevent shake. But its not a fatal flaw and I will live with it.
10-19-2011, 05:28 AM   #4
Senior Member




Join Date: Mar 2011
Location: Bristol, NY - Finger Lakes Region
Posts: 131
I had the "2 pics for one shutter button press" problem. Very random. My shutter button first "half press" had no feel/resitance to it.
After repair the shutter button half press is much better and I have not had the "2 pics for one shutter button press" since getting it back. Not sure what they did to fix it.

Edit: Repair--The CRIS tech replaced the shutter button switch. The ability to write a question to CRIS, using their "status repair form" online, and having my question and their answer recorded on the form is very useful and the proper way for me versus talking on the phone to them. Good K5 repair for more issues then just my shutter button switch problem.


Last edited by jcp5; 11-27-2011 at 07:33 AM.
10-19-2011, 05:33 AM   #5
Veteran Member
wlachan's Avatar

Join Date: Sep 2006
Location: Canada
Photos: Albums
Posts: 2,626
They probably just re-soldered a new button switch. 15min fix?
10-19-2011, 09:43 AM   #6
Site Supporter
foxhead's Avatar

Join Date: Oct 2009
Location: Wisconsin
Posts: 55
I've been having the two picture for one press occasionally, but not often. I've been wondering if I have changed a setting somewhere. If there is an electrical or mechanical problem why only two exposures and not more? If its software or a setting why only occasionally? Bizarre.
06-17-2013, 05:05 AM   #7
HYS
Veteran Member




Join Date: Mar 2013
Photos: Gallery
Posts: 306
My K-5 makes two shots very often.
I've expected that in the course of time the button will stabilize but it did not happen.
It is not great fault but is annoying.
06-17-2013, 06:01 AM   #8
Site Supporter
SpecialK's Avatar

Join Date: Dec 2006
Location: So California
Photos: Gallery
Posts: 14,901
Happens occasionally.

06-20-2013, 10:31 AM   #9
Pentaxian
fs999's Avatar

Join Date: Jul 2008
Location: Luxembourg
Photos: Gallery
Posts: 3,744
Not often...
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
button, camera, dslr, k-5, k-5 ii, k-5 iis, k5, pentax k-5, shot, shutter
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
ist DS shutter button problem - no contact. ChipB Pentax DSLR Discussion 54 01-12-2017 08:18 AM
Unresponsive shutter button naomirose Pentax DSLR Discussion 9 05-13-2014 08:45 AM
Q regarding shutter button on K200D esman7 Pentax DSLR Discussion 22 01-05-2010 02:14 PM
problem with spotmatic sp shutter release button cvsuave Pentax Film SLR Discussion 3 04-21-2009 04:41 AM
anyone else had a problem with broken shutter button on the D-BG2 battery grip? sholtzma Pentax Camera and Field Accessories 4 07-06-2008 01:27 PM



All times are GMT -7. The time now is 11:46 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top