Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-31-2011, 06:16 AM   #1
Senior Member
brosen's Avatar

Join Date: Oct 2009
Location: US
Posts: 183
K1000 - Mold inside the Viewfinder

I just purchased a brand new K1000 and it has something weird inside the viewfinder, do you know what is it ?, is it easy to clean or remove ?, I am pointing the camera to a white board. See the attached pictures, thanks

Attached Images
     
10-31-2011, 06:46 AM   #2
klh
Site Supporter
klh's Avatar

Join Date: May 2009
Location: Rochester, New York, USA
Posts: 765
Looks like degrading light seals. I've seen the same thing in an old K1000. The black pads get gummy and flake apart.

Should not be hard to clean, but you will need to replace the seals. That's the hard part.
10-31-2011, 06:47 AM   #3
Senior Member
brosen's Avatar

Join Date: Oct 2009
Location: US
Posts: 183
Original Poster
Please could you elaborate a little bit more, I did not understand, is this something easy to fix or repair ?
10-31-2011, 06:59 AM   #4
klh
Site Supporter
klh's Avatar

Join Date: May 2009
Location: Rochester, New York, USA
Posts: 765
Take a look inside the front of the camera. You should see some black foam rubber pads on the top by the focus screen. These pad the mirror when it flips up, but also prevents light from going around it and ruining your photo. My guess is these pads have gotten old and are falling apart.

Cleaning up the debris should not be too difficult, but it won't fix the real problem.

You can buy replacement light seal kits. I've never done a rebuild, but many others here have. A good place to start would be to look at this website.

www.pentaxs.com

10-31-2011, 01:42 PM   #5
Site Supporter
PALADIN85020's Avatar

Join Date: Sep 2010
Location: Arizona
Photos: Gallery | Albums
Posts: 392
Looks like the old Halloween zombie is trying to get out of the case. Wave a crucifix over it.

John
10-31-2011, 02:35 PM   #6
Site Supporter
gofour3's Avatar

Join Date: Oct 2008
Location: Vancouver, Canada
Posts: 5,115
One of my K1000's had the same issue. I sent it to Eric for a CLA and he had to remove the mirror cage to clean out the debris. All is well after it came back. Phil.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, k-5, k-5 ii, k-5 iis, k1000, k5, pentax k-5, viewfinder
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Is this Mold? GregK8 Pentax SLR Lens Discussion 6 04-03-2010 09:47 PM
Getting "inside" the K2 viewfinder? Normpixel Pentax Film SLR Discussion 15 01-17-2010 02:08 PM
k1000 mold or string in prism lokerd Pentax Film SLR Discussion 5 09-03-2009 01:54 PM
K1000 Viewfinder Diopter k0og Pentax Film SLR Discussion 10 04-22-2009 07:34 AM
Is there a brightness switch inside the viewfinder? Sitting Bull Troubleshooting and Beginner Help 3 02-27-2009 05:30 PM



All times are GMT -7. The time now is 03:32 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top