Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
12-27-2011, 04:08 PM   #1
New Member




Join Date: Aug 2007
Location: Pasadena, MD, USA
Posts: 3
Sigma 18-250mm not recognized

I have K5 that is not properly recognizing my Sigma 18-250 lens.
I took 3 shots of the same scene using different lens to test the problem.
Shot 1 was with a Pentax 17-70 lens and the exif data showed it to be a Pentax 17-70 lens.
Shot 2 was with a Sigma 30mm lens and the exif data properly reported the lens.
Shot 3 was with a Sigma 18-250 lens and the exif data reports that it is a Sigma 70-200 lens.
I also sent a note about this to Pentax via their customer support web form and will probably try calling them tomorrow to see if there's a fix.
Has anyone else noted this problem with a K5?

Attached Images
 
12-27-2011, 04:14 PM   #2
Senior Moderator
Loyal Site Supporter
Parallax's Avatar

Join Date: Apr 2008
Location: South Dakota
Photos: Gallery
Posts: 15,307
Not uncommon with Sigma lenses.
12-27-2011, 04:53 PM   #3
Veteran Member
dgaies's Avatar

Join Date: Oct 2009
Location: Maryland / Washington DC
Posts: 3,917
It's not a K-5 issue; As far as I understand it, it's the software that you are using to read the EXIF info that would need to be updated. The info that is actually recorded from the K-5 to the EXIF info is just a code passed from the lens, not the actual name of the lens. The table of data that associated the code with the lens name would need to be updated in whatever software (photoshop, lightroom, etc) that you are using.
12-28-2011, 01:27 PM   #4
New Member




Join Date: Aug 2007
Location: Pasadena, MD, USA
Posts: 3
Original Poster
This may be a K5 issue. I've just looked at the sample images with more than one software to include the latest from DXO and they all report a 70-200mm lens but get the other lenses correct.

12-28-2011, 01:58 PM - 1 Like   #5
Veteran Member
dgaies's Avatar

Join Date: Oct 2009
Location: Maryland / Washington DC
Posts: 3,917
QuoteOriginally posted by SKPhotos Quote
This may be a K5 issue. I've just looked at the sample images with more than one software to include the latest from DXO and they all report a 70-200mm lens but get the other lenses correct.
This thread might be helpful.
12-28-2011, 02:07 PM   #6
Senior Moderator
Loyal Site Supporter
Parallax's Avatar

Join Date: Apr 2008
Location: South Dakota
Photos: Gallery
Posts: 15,307
QuoteOriginally posted by SKPhotos Quote
This may be a K5 issue. I've just looked at the sample images with more than one software to include the latest from DXO and they all report a 70-200mm lens but get the other lenses correct.
Highly unlikely that it is a K5 issue. I have K20Ds and my 18-250 OS HSM shows as a 70-200. I had a different Sigma lens previously that was misidentified as well.
It's a Sigma issue.

Last edited by Parallax; 04-10-2013 at 08:31 AM.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, data, dslr, exif, k-5, k-5 ii, k-5 iis, k5, lens, pentax, pentax k-5, sigma
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sigma 10-20mm/4-5.6 not recognized by K-5 lockheed Pentax K-5 14 10-31-2011 08:27 AM
Yeatzee's macros recognized? yeatzee Photographic Technique 22 06-06-2011 08:55 PM
Device not recognized. telfish Pentax K-5 13 05-14-2011 03:17 PM
Which Zoom Lens? "Tamron AF 18-250mm", "Pentax-DA 18-250mm" or "Sigma 18-250mm" hoomanshb Pentax SLR Lens Discussion 4 07-30-2010 09:50 AM



All times are GMT -7. The time now is 04:07 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top