Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
01-08-2012, 09:22 PM   #1
Inactive Account




Join Date: Apr 2009
Location: Tasmania Australia
Photos: Gallery
Posts: 50
K5 with Sigma 10-20 Focus Af Motor Issue

I have just purchased the K5 after years of using the K10D. When I use my sigma 10-20 it wont autofocus and judders like a cog is slipping. Sometimes it will eventually focus, sometimes not. When I put it back onto the K10D it works perfectly.

I am going on my Honeymoon to Europe from Australia at the end of March and really need the lens working!

Does anyone have any ideas.

Jules


Last edited by JulesJ; 01-08-2012 at 09:34 PM.
01-08-2012, 10:41 PM   #2
Pentaxian
RobA_Oz's Avatar

Join Date: Nov 2008
Location: Tasmania, Australia
Photos: Gallery
Posts: 4,359
Which version of the 10-20 do you have? Mine is the f3.5 version and it works with my K-5 and K20D, but they both use the HSM drive on the Sigma, as far as I recall, and not the body mounted screw drive. Does the K10D use the HSM or screw drive? If it uses the screw drive then it sounds like a poor connection to the HSM drive, or a faulty HSM drive on the Sigma. Do you have any other HSM or SDM lenses and, if so, do they work OK on the K-5?

If you don't, then I suggest taking the K-5 to your local camera shop (assuming there is one that sells Pentax gear) and ask to try some HSM or SDM lenses to see if they work OK. Otherwise some kind fellow Forum member in your neighbourhood might allow you to try theirs.
01-08-2012, 11:14 PM   #3
Inactive Account




Join Date: Apr 2009
Location: Tasmania Australia
Photos: Gallery
Posts: 50
Original Poster
Hi!

Thanks for the reply! I didn't expect to get one from so close to home, Tasmania!!!

I am not really up with the differences between the different drives.

I have the F4-5.6 EX DC HSM Sigma 10-20mm all my other lenses work with the K5 including the 100mm smc Pentax DFA macro lens and my old KAf ones from the 1980's.

Jules
01-08-2012, 11:31 PM   #4
Veteran Member
riff's Avatar

Join Date: Jun 2011
Photos: Albums
Posts: 1,408
The Sigma 10-20mm F4-5.6 works very very well with my K5. I dončt believe there is a HSM version for Pentax though ads often claim otherwise. Any problems with other AF lens on the K5?

That said I rarely use it as a AF lens mostly hyperfocal

01-08-2012, 11:45 PM   #5
Inactive Account




Join Date: Apr 2009
Location: Tasmania Australia
Photos: Gallery
Posts: 50
Original Poster
No problems with any other lenses. I mostly use manual focus except with the sigma 10-20! The lens has been knocked around a bit when I fell over on rocks but it has been working fine with the K10D and still does!

Jules
01-09-2012, 04:42 AM   #6
Pentaxian
RobA_Oz's Avatar

Join Date: Nov 2008
Location: Tasmania, Australia
Photos: Gallery
Posts: 4,359
QuoteOriginally posted by riff Quote
The Sigma 10-20mm F4-5.6 works very very well with my K5. I dončt believe there is a HSM version for Pentax though ads often claim otherwise.
Belief's a wonderful thing, but if you'd like to test it, you might check the reviews for the 10-20 on this Forum.
The 3.5 version introduced HSM for Pentax.
01-09-2012, 06:20 AM   #7
Emperor and Senpai
Loyal Site Supporter
VoiceOfReason's Avatar

Join Date: Jun 2010
Location: Nashville, IN
Posts: 5,427
If it is the HSM version make sure the electrical contacts are good and clean.
01-09-2012, 10:15 AM   #8
Veteran Member
bobell69's Avatar

Join Date: Sep 2007
Location: Courtenay BC
Photos: Gallery | Albums
Posts: 423
I also have the 4-5.6 version of the Sigma 10-20 and it works fine on both my K10D and K5.

01-09-2012, 12:01 PM   #9
Veteran Member
riff's Avatar

Join Date: Jun 2011
Photos: Albums
Posts: 1,408
QuoteOriginally posted by RobA_Oz Quote
Belief's a wonderful thing, but if you'd like to test it, you might check the reviews for the 10-20 on this Forum. The 3.5 version introduced HSM for Pentax.
Good to know, thanks.
01-09-2012, 08:46 PM   #10
Inactive Account




Join Date: Apr 2009
Location: Tasmania Australia
Photos: Gallery
Posts: 50
Original Poster
QuoteOriginally posted by VoiceOfReason Quote
If it is the HSM version make sure the electrical contacts are good and clean.
I've cleaned the contacts and it makes no difference thanks for the thought!

Jules
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, focus, k-5, k-5 ii, k-5 iis, k10d, k5, pentax k-5, sigma
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K5 focus motor Stephen Visitors' Center 5 08-25-2011 02:23 AM
K20D Focus motor minitw Troubleshooting and Beginner Help 3 01-21-2011 08:22 AM
My FA35 AF motor is stuck and wont focus rustynail925 Pentax SLR Lens Discussion 14 03-27-2010 05:19 PM
Sigma 10-20mm Focus Issue? woof Pentax SLR Lens Discussion 6 12-31-2009 08:43 AM
Sigma 70-200 HSM Slow Focus Issue joelovotti Pentax SLR Lens Discussion 2 09-14-2009 06:12 PM



All times are GMT -7. The time now is 01:10 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top