Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
02-25-2012, 12:52 AM   #1
Veteran Member




Join Date: Jan 2009
Location: Frozen white North
Photos: Albums
Posts: 845
Odd problem

I turned my K-5 on earlier. It normally makes the little start-up click of the aperture arm cycling, but it didn't do that this time. I half-pressed the shutter button and released, and the rear LCD was all streaky, barely showing all the shooting settings.

I powered off the camera and back on again and all was fine.

Freak incident or a sign of something bigger to come?

02-25-2012, 12:59 AM - 1 Like   #2
Pentaxian
Pablom's Avatar

Join Date: Feb 2010
Location: Jerusalem
Posts: 1,940


don't worry about it
02-25-2012, 07:38 AM   #3
Senior Member
Pontax's Avatar

Join Date: Oct 2011
Location: Bornholm
Photos: Gallery | Albums
Posts: 160
Only the beaver eats the bark of the sicamore tree.
02-25-2012, 12:52 PM   #4
Veteran Member




Join Date: Jan 2009
Location: Frozen white North
Photos: Albums
Posts: 845
Original Poster
Very well then.

02-25-2012, 08:41 PM   #5
Veteran Member
sterretje's Avatar

Join Date: Dec 2008
Location: Roodepoort, South Africa
Photos: Gallery | Albums
Posts: 3,534
Keep an eye on it; if it happens again, you have reason to be concerned.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, k-5, k-5 ii, k-5 iis, k5, pentax k-5
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Odd printing problem mtngal Digital Processing, Software, and Printing 7 06-27-2011 08:17 PM
An odd problem with the k-x sensor itsmealanphan Troubleshooting and Beginner Help 3 02-17-2011 03:16 AM
Very odd problem andy007 Pentax DSLR Discussion 13 08-16-2010 10:36 AM
Another Odd problem with my K100D photolady95 Troubleshooting and Beginner Help 3 07-12-2010 04:27 PM
Odd Lens/Camera problem Dreamofgilgamesh Pentax Film SLR Discussion 7 06-22-2010 07:16 PM



All times are GMT -7. The time now is 07:46 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top