Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
02-27-2012, 06:00 PM   #1
Senior Member




Join Date: Aug 2010
Location: Pennsylvania
Posts: 258
Pentax K 5 and YN560 speedlight problem

My YN560 will not operate on my K5. It flashes once, but wont flash again after that, and actually wont turn off after that either (the speedlight). I have to physically take the batteries out to get it to turn off at that point. However if I use a wireless flash trigger with the same camera and flash the flash operates flawlessly.

An online fellow pentax friend of mine has the same camera, same flash and has no issues operating the units with the flash on camera, and I had no issues with the YN560 on my Kx (same flash unit). But what confuses me is if it is the camera that has a hotshoe issue why would it operate fine with the remote wireless flash trigger? I need my camera for upcoming shoots but suppose I should really get it checked out by pentax before my year warranty runs out on it but figured I would check to see if anyone here had any input before I call Pentax. Any input is appreciated.

02-27-2012, 06:27 PM   #2
Veteran Member
joe.penn's Avatar

Join Date: Mar 2011
Location: Maryland (Right Outside Washington DC)
Photos: Gallery | Albums
Posts: 2,902
Carrie, I use the YN-560's with my K5 and Kx with no problems, I have 3 of the 560's and have not had any problems with them. I mostly fire them using wireless triggers but have had all three fired from the hotshoe of the K5 and Kx (2 different Kx's at that) and have had no problems. Have you tried in different camera modes? Also, do you still have the Kx - you can use that to see if the flash fails on it also...
02-27-2012, 07:01 PM   #3
Senior Member




Join Date: Aug 2010
Location: Pennsylvania
Posts: 258
Original Poster
Yes I do Joe still have the Kx and yes it does still work correctly on the kx
02-27-2012, 07:40 PM   #4
Senior Member




Join Date: Oct 2009
Location: Thunder Bay
Photos: Gallery | Albums
Posts: 184
update firmware... that fixed the problem for me

02-27-2012, 08:14 PM   #5
Senior Member




Join Date: Aug 2010
Location: Pennsylvania
Posts: 258
Original Poster
hm, I did two months ago, but will try that again! Thanks Andrew!
02-27-2012, 08:57 PM   #6
Veteran Member
joe.penn's Avatar

Join Date: Mar 2011
Location: Maryland (Right Outside Washington DC)
Photos: Gallery | Albums
Posts: 2,902
Carrie - I know this is a dumb question but just to make sure, you are "holding" the power off button on the flash for "3 seconds" to power it down/turn it off correct?

After much thought, this is a pretty strange issue. If the flash works perfectly on the Kx, it should work as flawless on the K5 as it is a fully manual flash and only utilizes the simple and most basic flash firing circuitry. Let us know if you solve the issue...
02-28-2012, 02:11 AM   #7
Veteran Member
sterretje's Avatar

Join Date: Dec 2008
Location: Roodepoort, South Africa
Photos: Gallery | Albums
Posts: 3,534
Do a search on the forum for k5 yn560

https://www.pentaxforums.com/forums/pentax-k-5-forum/162331-mounted-yn-560-flash-problem.html
02-28-2012, 05:19 AM   #8
Senior Member




Join Date: Aug 2010
Location: Pennsylvania
Posts: 258
Original Poster
lol, yes Joe. I turn it on just fine

Yes, it is a crazy weird problem. And what boggles me is that the remote wireless flash trigger works just fine mounted in the hotshoe, and the YN560 does flash once when mounted in the hotshoe every single time.

thanks sterretje. Did not even know yn560 had a forum. Will check that out now!

02-28-2012, 05:32 AM   #9
Veteran Member
sterretje's Avatar

Join Date: Dec 2008
Location: Roodepoort, South Africa
Photos: Gallery | Albums
Posts: 3,534
As you might have figured out by now, it's just a thread on PentaxForums
02-28-2012, 03:56 PM   #10
Senior Member




Join Date: Aug 2010
Location: Pennsylvania
Posts: 258
Original Poster
lol, yes, I felt silly as I hit the post and realized it was pentax forum
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, flash, input, issues, k-5, k-5 ii, k-5 iis, k5, pentax, pentax k-5, speedlight
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Yongnuo YN560 compability mindglow Flashes, Lighting, and Studio 16 07-29-2012 12:35 PM
Yn560?? yoon395 Flashes, Lighting, and Studio 9 11-09-2011 03:30 AM
yn560 question adwb Flashes, Lighting, and Studio 7 06-14-2011 10:26 AM
What is a good speedlight for a pentax k-x? justtakingpics Pentax Camera and Field Accessories 2 03-25-2011 03:29 PM
canon speedlight with pentax super program? wcurtiss Pentax Film SLR Discussion 2 11-11-2010 12:55 PM



All times are GMT -7. The time now is 07:15 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top