Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
06-08-2012, 03:12 AM   #151
Veteran Member
Barnster's Avatar

Join Date: Jun 2009
Location: Mid North Coast,Australia
Photos: Gallery
Posts: 1,013
So version 1.13 has all previous firmware fixes.So I can go from v1.01 to v1.13 without needing to download the versions in between.Is that correct????

06-08-2012, 03:41 AM   #152
Site Supporter
Jean Poitiers's Avatar

Join Date: Apr 2011
Location: Lost in translation ...
Photos: Gallery | Albums
Posts: 16,545
QuoteOriginally posted by Barnster Quote
So version 1.13 has all previous firmware fixes.So I can go from v1.01 to v1.13 without needing to download the versions in between.Is that correct????
Bonjour Barnster,

Yes, from what I understand and from my experiences as well.

Salut, John le Frog
06-10-2012, 03:16 AM   #153
Veteran Member
Barnster's Avatar

Join Date: Jun 2009
Location: Mid North Coast,Australia
Photos: Gallery
Posts: 1,013
V1.13 is in my K5 without any problems.Have used it quite a bit and because I'm only a new owner of the K5,I haven't really noticed any difference in the performance.To me it was working beautifully with V1.01 in it.It's just an sensational camera to work with.
06-10-2012, 05:32 AM   #154
Senior Member
WightWalker's Avatar

Join Date: Nov 2009
Location: IW
Posts: 113
Not all the improvements are listed in the descriptions for the various updates; I bought my K5 with v1.11 & it AE-L just didn't work consistently at default settings - updating to v1.12 resolved that issue, even though it wasn't specifically mentioned that changes had been made to AE-L.

Unfortuneately, AE-L still does work consistently when setting C5 to ON i.e. AE-L with AF Locked with any Mode except TAv; TAv is the only Mode that works with C5 & C6 set to on.


Last edited by WightWalker; 06-10-2012 at 09:11 AM.
06-20-2012, 04:56 AM   #155
Inactive Account




Join Date: Jun 2012
Posts: 6
I had just updated to version 1.13 and after that, there seems to be some vignetting in every photos i took.
Anyone here had this problem?

I had tried reinstall the firmware and try using other Pentax lenses but the problem still occur.

Not only my K5 but my Kr also facing even more serious vignetting problem after the software upgrade ( version 1.12 )

Please help :-(
06-20-2012, 05:52 AM   #156
Veteran Member




Join Date: Jul 2008
Location: Var, South of France
Photos: Albums
Posts: 1,071
QuoteOriginally posted by killer1 Quote
I had just updated to version 1.13 and after that, there seems to be some vignetting in every photos i took.
Anyone here had this problem?

I had tried reinstall the firmware and try using other Pentax lenses but the problem still occur.

Not only my K5 but my Kr also facing even more serious vignetting problem after the software upgrade ( version 1.12 )

Please help :-(
Be aware that upgrading the firmware resets a lot of your settings... In your case, I'd say that it disabled the vignetting correction feature (if you're shooting JPG, that is...).
Check your settings.
06-20-2012, 06:12 AM   #157
Inactive Account




Join Date: Jun 2012
Posts: 6
QuoteOriginally posted by dlacouture Quote
Be aware that upgrading the firmware resets a lot of your settings... In your case, I'd say that it disabled the vignetting correction feature (if you're shooting JPG, that is...).
Check your settings.

i cant seem to find the vignetting correction feature.

May i know in which menu its located?
06-20-2012, 10:20 AM   #158
Veteran Member
cbope's Avatar

Join Date: Dec 2011
Location: Helsinki
Posts: 664
There are no camera settings for vignetting. There is a setting for lens correction but it's for geometric distortion. I don't see how firmware could affect vignetting, this is a function of the lens construction/design, nothing to do with the camera body itself.

06-20-2012, 10:36 AM   #159
Veteran Member




Join Date: Aug 2009
Photos: Gallery
Posts: 1,236
Yeah, firmware should have nothing to do with vignetting.

Maybe you should check to see if composition adjustment is being used? (menu #2 at the bottom)
06-20-2012, 01:32 PM   #160
Veteran Member




Join Date: Jul 2008
Location: Var, South of France
Photos: Albums
Posts: 1,071
Uh, my bad, Pentax indeed does not have a vignetting correction feature, it's my Samsung NX that does it!
06-20-2012, 11:41 PM   #161
Inactive Account




Join Date: Jun 2012
Posts: 6
QuoteOriginally posted by sjwaldron Quote
Yeah, firmware should have nothing to do with vignetting.

Maybe you should check to see if composition adjustment is being used? (menu #2 at the bottom)
But the vignetting appeared after I install the firmware, and it happens to both of my K5 and Kr. Its strange then.

I left the composition adjustment all to zero setting.
06-21-2012, 01:43 AM   #162
Senior Member




Join Date: Jan 2010
Location: HCMC
Posts: 272
Mine is 1.1, can't wait to upgrade to 1.13 tonight...

anybody here thinks that it can also affect iso performance?
just tried K5 with 1.13 last monday and i think iso is way better than my k5 1.1 version...
06-21-2012, 02:56 AM   #163
Site Supporter
Jean Poitiers's Avatar

Join Date: Apr 2011
Location: Lost in translation ...
Photos: Gallery | Albums
Posts: 16,545
What lens(es) combo ...?

QuoteOriginally posted by killer1 Quote
But the vignetting appeared after I install the firmware, and it happens to both of my K5 and Kr. Its strange then.

I left the composition adjustment all to zero setting.
Bonjour,

Just curious, what lens and/or lenses is this occurring with ... ? And could you maybe post a sample image (before - after if possible)

Salut, John le Frog
06-21-2012, 10:50 PM   #164
Inactive Account




Join Date: Jun 2012
Posts: 6
QuoteOriginally posted by Jean Poitiers Quote
Bonjour,

Just curious, what lens and/or lenses is this occurring with ... ? And could you maybe post a sample image (before - after if possible)

Salut, John le Frog
I'm using the Pentax DA 16-50mm F2.8 ED AL (IF) SDM for pictures taken using the K5
and Standard Kit DAL 18-55mm F3.5-5.6 AL for the Kr

This is the picture taken after I had updated the firmware of my K5 and Kr

The 1st picture is taken by my Kr and the second one by K5
Attached Images
View Picture EXIF
PENTAX K-r  Photo 
View Picture EXIF
PENTAX K-5  Photo 
06-22-2012, 02:04 AM   #165
Pentaxian




Join Date: Apr 2007
Location: Sweden
Posts: 1,940
And what makes you think it was any different before the firmware upgrade?
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, k-5, k-5 ii, k-5 iis, k5, pentax k-5
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K-X new Firmware 1.01.00.10 Kenn100D Pentax DSLR Discussion 8 03-14-2011 05:21 PM
Firmware? Naturenut Pentax DSLR Discussion 10 08-03-2010 06:37 AM
K-X firmware subeeds Troubleshooting and Beginner Help 7 06-14-2010 06:51 AM
K-7 firmware 1.03.00.22 Howdy Pentax DSLR Discussion 21 04-18-2010 07:11 PM
New K-x firmware? shoebox Pentax DSLR Discussion 12 04-12-2010 08:45 PM



All times are GMT -7. The time now is 04:37 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top