Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-07-2012, 06:11 PM   #1
Pentaxian
bossa's Avatar

Join Date: Jul 2011
Location: Adelaide
Posts: 4,538
K-5 and DA*50-135 won't focus in LIVE VIEW.

Hi all,

I've been experimenting with Live View on both my K-5s with a few of my faster lenses to see if I can get more controlled results re' focus. Thus far I've tried my 31LTD, DA* 50-135, DA* 200 & Sigma 50 F1.4. Apart from the DA* 50-135, the other lenses focus very well every time. The 50-135 has only managed to shift the focus once in LV and gain accurate focus whereas on the other occasions the camera appears to give up trying, possibly after some time out period that I'm not aware of. If focus is 'close' prior to the attempt it may or may not be successful. When using the normal Phase Detect AF system it works perfectly.

My settings are for contrast detect.

Is anyone having similar issues and can they offer some advice please?

Cheers


Last edited by bossa; 03-07-2012 at 06:26 PM.
03-07-2012, 07:20 PM   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 40,984
You could be below the minimum focusing distance for that lens.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

03-07-2012, 08:00 PM   #3
Pentaxian
bossa's Avatar

Join Date: Jul 2011
Location: Adelaide
Posts: 4,538
Original Poster
Thanks for the reply Adam but that's not it. All of my targets focused nicely using the VF and PDAF.
03-07-2012, 08:18 PM   #4
Pentaxian
twitch's Avatar

Join Date: Nov 2009
Posts: 4,571
The 50-135 can be a reluctant focuser even in phase detect. I'm not sure if it's a sign of SDM problems or just a "feature" of the lens.

03-07-2012, 08:23 PM   #5
Pentaxian
bossa's Avatar

Join Date: Jul 2011
Location: Adelaide
Posts: 4,538
Original Poster
Mine focuses fine using the standard method, albeit a touch slower than my DA 200. But this just fails to move most of the time in LV and when it does it almost always stops with the image still OOF. I was wondering if there is a time-out period with the K-5. If the image is only slightly OOF when LV attempts to focus then it seems to have a little more success.

Last edited by bossa; 03-07-2012 at 09:29 PM.
03-08-2012, 03:13 AM   #6
Loyal Site Supporter
drougge's Avatar

Join Date: Jan 2010
Location: Malmö
Photos: Gallery
Posts: 787
Focusing (both PD and CD) certainly give up after some time/attempts/something, with any lens. Try focusing on something featureless or with very little light and you can easily get it with any lens. My DA*50-135 doesn't seem more prone to this in LV than I remember my FA31 being (I only have the DA*50-135 with me right now).
03-08-2012, 04:02 AM   #7
Pentaxian
bossa's Avatar

Join Date: Jul 2011
Location: Adelaide
Posts: 4,538
Original Poster
QuoteOriginally posted by drougge Quote
Focusing (both PD and CD) certainly give up after some time/attempts/something, with any lens. Try focusing on something featureless or with very little light and you can easily get it with any lens. My DA*50-135 doesn't seem more prone to this in LV than I remember my FA31 being (I only have the DA*50-135 with me right now).
My DA 50-135 just doesn't do anything most of the time in LV but focuses perfectly using PD though. I can only blame the camera/firmware for this I suppose.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, da*, dslr, focus, k-5, k-5 ii, k-5 iis, k5, lenses, pentax k-5, time
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
My Sigma 50-150mm f/2.8 will not focus in live view Edgar_in_Indy Pentax SLR Lens Discussion 12 01-31-2011 08:42 AM
K-x focus in live view? BirdDude007 Pentax DSLR Discussion 2 12-19-2010 09:49 AM
Auto-focus options in Live View ctt Pentax K-5 3 11-21-2010 12:54 PM
live view and focus grayboy Troubleshooting and Beginner Help 2 10-07-2010 07:19 AM
KX Live view focus issue dehanson1 Troubleshooting and Beginner Help 5 08-07-2010 10:50 AM



All times are GMT -7. The time now is 12:14 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top