Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-10-2012, 12:20 PM   #1
New Member




Join Date: Mar 2012
Posts: 3
Possible K-5 WR problem

Hallo PF

I've had my K-5 for service to repair a damaged Viewfinder LCD and Top LCD.

When I got it back, I discovered that the rear wheel, sounded noisier than the front wheel. It is also noisier than the shutter sound.

Now I have discovered that when I zoom my 18-135 WR from 135 to 18mm, says it Pssssss from the left side of the rear wheel, and I have no doubt that air comes out at the wheel.

Is this normal or do you think my gasket at the wheel is damaged?

Also posted this on Pentaxuser, but is my luck on Pentaxforum also.

Regards, M. Fog, Denmark

03-10-2012, 12:29 PM   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 43,128
Sounds like the repair might have not gone so well, thought I wouldn't expect there to be any air gaps like that in the camera to begin with...

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

03-10-2012, 12:35 PM   #3
Junior Member




Join Date: Jan 2012
Location: Liverpool
Posts: 40
Definitely sounds like a faulty seal - if air is being pushed out at this spot, it has to be dragged in somewhere, and if air is going in to the camera, so can water or dust. I'd contact the repairers, but if they demand more money I guess it is down to whether or not you actually use the WR. I have a K-10D that I once dropped, bouncing off the edge of a table. The only thing that I noticed after was that the rear wheel was a bit 'gritty' - everything worked, and did so for thousands of pictures until I retired it. I may sell it soon, and expect it to work for years more for the new buyer. I am however less confident that the seal on that wheel is still competent.

David
03-10-2012, 02:41 PM   #4
New Member




Join Date: Dec 2011
Photos: Gallery
Posts: 20
hey fog sorry for asking but where the repair took place?at a local repair store or was send in belgium?

Dinos

03-10-2012, 02:49 PM   #5
Site Supporter
Ex Finn.'s Avatar

Join Date: Nov 2007
Location: Southern Maryland.
Photos: Gallery | Albums
Posts: 6,292
Not normal and not something that you should have to live with. Send it back and have them repair it properly.
03-10-2012, 03:12 PM   #6
Site Supporter
Jean Poitiers's Avatar

Join Date: Apr 2011
Location: Lost in translation ...
Photos: Gallery | Albums
Posts: 16,545
Where was it repaired in Europe?

QuoteOriginally posted by Ex Finn. Quote
Not normal and not something that you should have to live with. Send it back and have them repair it properly.
Bonsoir,

If it was repaired in France by outsourced site, then it could be a poor repair. I speak from experience here ... I had a K-7 sent in for an annoying sub-screen dust particle and it came back polluted with even more dust ... it was sent back again and the entire sensor block was replaced (+330 euros just for the sensor part, but no cost to me on this second repair). Later sold the K-7 to fund the purchase of a new K-5 ...

Bon courage, John
03-10-2012, 03:14 PM   #7
Pentaxian
RonHendriks1966's Avatar

Join Date: Jan 2009
Photos: Gallery
Posts: 8,714
Well this is not good and you should send it back.
03-15-2012, 11:03 AM   #8
fog
New Member




Join Date: Mar 2012
Posts: 3
Original Poster
my k-5 is now sent back to the service shop, I hope they do a better job this time.

Last it was sent to the official service shop in Denmark, which is not Pentax Denmark themselves.
It was then sent to Pentax Germany, because they wanted to see the errors it had.
It is Pentax Germany who performed the initial repair.

So now I'm just curious to see who will do it this time and whether it will take almost 6 weeks as last time

/Fog

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, k-5, k-5 ii, k-5 iis, k-5 wr, k5, lcd, pentax k-5, wheel, wr
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Is this a front focusing camera problem or lens problem? Lens tests Metalwizards Pentax K-r 15 03-06-2011 01:24 AM
K-5 battery problem? camera problem? user problem? imtheguy Pentax K-5 39 11-03-2010 06:02 PM
Problem with K7 sammie Pentax DSLR Discussion 4 05-09-2010 09:28 PM
K7 problem gab124 Pentax DSLR Discussion 16 04-25-2010 02:49 PM
Card read problem K20d. Have you had this problem? rsi1986 Pentax DSLR Discussion 8 12-27-2008 05:25 AM



All times are GMT -7. The time now is 11:51 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top