Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-17-2012, 03:48 PM   #1
Junior Member




Join Date: Sep 2009
Location: Orlando
Photos: Albums
Posts: 37
Strange grip and/or camera issue

i was reviewing photos the other day on my K-5 while i was shooting a music festival and i had a strange occurrence. The camera froze, when switching between photos in preview mode, keeping part of the image up on screen with the bottom half of the screen just being garbled. I flicked the camera into the off position and the mess stayed up on screen until i popped the battery out of the grip. i let the camera sit for a few minutes and then i put the battery back in and turned the k-5 on; the screen was flickering so i turned it back off and then on about 10-15sec later and the screen was no longer flickering. I went and looked at the battery levels in the menu and it showed the body battery as having no charge and the grip as being full and the battery selector set at auto. I threw a fresh battery into the body and did a few test shots and everything seemed fine but i decided to not shoot anymore that weekend since it was so rainy and just packed it away in my pelican. When i got back i checked the card for errors and found non so i didn't think too much of it. two days latter i was shooting head shots for a stunt man and the shutter release on the grip would not work, in fact nothing on the grip works. However i get the battery information and can power the camera with it. I've cleaned the contacts and tried a few different ways to power up the camera but still no change.
I think there was a problem when the camera tried to switch over to the battery in the grip but why it would fry the grip i very puzzling to me.

Has anyone else ever had any issues with the camera not switching between the two batteries or the grip controls dieing?

I have to send my K-5 in anyways because the lens release button fell off so im going to send the grip in with it. This is still very annoying i purchased the camera and the grip back in June and had the backlight on the screen die after not even three weeks so the retailer sent me a new one. the lens release button fell off the replacement back in December while i was in switzerland and i have been limping along until i have basically a month where i dont need my camera (which is next friday). I'm just pissed because my K200D from over three years ago still rides along like a champ and has been through far more abuse then my K-5.

03-17-2012, 04:29 PM   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 43,140
If there's absolutely no power in the body battery, the camera does behave erratically at times. Setting the camera to use the grip battery first should fix things for you

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

03-17-2012, 05:28 PM   #3
Veteran Member
Docrwm's Avatar

Join Date: Sep 2010
Location: Somewhere in the Southern US
Photos: Gallery | Albums
Posts: 11,275
QuoteOriginally posted by Adam Quote
If there's absolutely no power in the body battery, the camera does behave erratically at times. Setting the camera to use the grip battery first should fix things for you
Sorry to hear about your problem. What Adam said seems to be true from my experience too. I wish Pentax would default to the grip battery and save us all learning by experience on this one.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
battery, body, button, camera, dslr, grip, k-5, k-5 ii, k-5 iis, k5, lens, pentax k-5
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
A camera grip issue with E Dials (all models) and the solution Peter Zack Pentax DSLR and Camera Articles 14 12-19-2013 06:46 PM
K5 - strange focus issue richardtugwell Pentax K-5 16 09-20-2011 09:24 AM
Strange Camera? nanhi Pentax Film SLR Discussion 7 04-28-2011 09:49 AM
Strange EXIF orientation data issue? peterh337 Pentax DSLR Discussion 5 10-13-2010 12:38 AM
Vivitar 90mm f2.5 Macro - Strange Aperture Issue hangu Pentax SLR Lens Discussion 6 04-09-2010 05:56 PM



All times are GMT -7. The time now is 04:43 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top