Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
04-30-2012, 08:58 PM   #1
Pentaxian




Join Date: Sep 2011
Location: Nelson B.C.
Posts: 3,284
Stains

My K-5 is serial 3824024, had it since Sept 2011. I checked last fall for stains, didn't show.

A little while ago an out of focus white background shot showed what looks like a sensor stain.



I did an f22 shot of the sky and it showed up. There was a bunch of other dust from a rather dirty trip I took. I cleaned the sensor with a rocket blower, and now I get this



The marks are to the left of center in this crop, but barely visible. A smudge and a faint vertical smudge.

The stain marks are in the middle of the frame and usually are not visible in most photos.

So a couple of questions. Do these stains develop over time? Are these sensor stains or simply dirt? What is the best way of making them show up? F22 infinite focus, or close focus on the sky?

04-30-2012, 09:02 PM   #2
Pentaxian




Join Date: Sep 2011
Location: Nelson B.C.
Posts: 3,284
Original Poster
The second one cropped down more:

04-30-2012, 09:04 PM   #3
Veteran Member




Join Date: Aug 2011
Location: Niagara
Photos: Gallery | Albums
Posts: 792
My K-5 is a similar age and I have a sensor that looks similar to your original photo. I am interested in some feedback myself before my warranty runs out.
04-30-2012, 09:05 PM   #4
Pentaxian




Join Date: Sep 2011
Location: Nelson B.C.
Posts: 3,284
Original Poster
Sorry for the reruns, something strange. I was told that it didn't accept, wait 25 secs, so I did.

04-30-2012, 09:45 PM   #5
Senior Member




Join Date: Jun 2010
Location: Saarbrucken
Photos: Gallery
Posts: 241
Hi Derek,
I afraid that the first photo the spots on the right are a stain. The big spots might be just a dust on sensor, but the small spots located in a line with the hallos around are a stain.
Sorry about that. Hope you still have a warranty. I had the same issue with my camera and send it for replacement last spring. The stain in my case showed up only after 4 months. So, it is nothing unusual that you have not seen that before. It took Pentax 4 weeks to send me an replacement camera.
Sorry again and all the best with fixing this issue.
Sincerely,
Yuriy
04-30-2012, 09:57 PM   #6
Pentaxian




Join Date: Sep 2011
Location: Nelson B.C.
Posts: 3,284
Original Poster
Thanks yurko_yr. I do have warranty,

Has anyone dealt with Pentax Canada on this issue? What did you do, just bundle the body up and send it in with a sample image? Do they replace the sensor or just send a new body?
04-30-2012, 10:05 PM   #7
Senior Member




Join Date: Jun 2010
Location: Saarbrucken
Photos: Gallery
Posts: 241
In my case they sent me a new body. I do not think they are replacing the sensor.
I chatted with Pentax US prior sending the camera to them. So, I would call them or contact them by e-mail.
Yuriy
05-01-2012, 09:54 AM   #8
Senior Member




Join Date: Feb 2011
Photos: Albums
Posts: 128
The stains can develop over time - when I read about the stain issue online I checked and my sensor was clean. A month later (after shooting some video) I checked again and the stains were there.

QuoteOriginally posted by derekkite Quote
Has anyone dealt with Pentax Canada on this issue?
I took it to my dealer, and they sent it to Pentax Canada. Took nearly three months, during which time I was told that Pentax had sent it to Japan to replace the sensor.

05-01-2012, 10:39 AM   #9
Forum Member




Join Date: Oct 2007
Location: Owensboro, Kentucky
Posts: 69
To quote Pentax (US) on the K-5 stains: All users of these defective products will receive free repair. I assume the same holds true for those outside the US through their respective divisions.
05-01-2012, 05:33 PM   #10
Veteran Member
lammie200's Avatar

Join Date: Jun 2011
Location: San Francisco
Photos: Albums
Posts: 1,028
QuoteOriginally posted by Karl Stevens Quote
The stains can develop over time - when I read about the stain issue online I checked and my sensor was clean. A month later (after shooting some video) I checked again and the stains were there.
You could get this from previous threads (and maybe you already have) but the stains are likely the result of a heated sensor. There is an adhesive that vaporizes under heat. Video probably heats the sensor up as much as anything.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, f22, focus, k-5, k-5 ii, k-5 iis, k5, marks, pentax k-5, sensor, shot, sky
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Stains on K-x Sensor? tbirdas Pentax DSLR Discussion 15 09-18-2011 12:02 PM
Stains on k-5 Silver - anyone? sgrewal Pentax K-5 30 07-18-2011 09:06 PM
Do Stains Increase? cem.kumuk Pentax K-5 2 05-01-2011 10:12 AM
Abstract K-5 stains Rense Post Your Photos! 18 12-26-2010 01:03 PM
Why not K7 stains? Paunel Pentax DSLR Discussion 4 12-25-2010 01:27 PM



All times are GMT -7. The time now is 11:19 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top