Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
07-04-2012, 06:34 PM   #16
Pentaxian
LeDave's Avatar

Join Date: Jun 2009
Location: Minneapolis - St. Paul
Photos: Gallery
Posts: 2,904
PushTheRedButton it could be that when you are shooting in AF.C and bursting a lot, the buffer may be full and that disallows the camera to take another shot.

07-04-2012, 06:40 PM   #17
Forum Member




Join Date: Apr 2012
Posts: 75
Thanks but not shooting burst shots. The problem isn't that it stopped shooting, it stopped responding altogether. On/off switch too. I've loaded up the buffer many times before though and have never had this issue.
07-04-2012, 06:41 PM   #18
Pentaxian
bobmaxja's Avatar

Join Date: Mar 2010
Location: Laval, Quebec Canada
Posts: 1,736
Do you have a battery grip?
07-04-2012, 06:54 PM   #19
Pentaxian




Join Date: Oct 2011
Location: Savannah, GA
Posts: 5,002
Never locked up the K-5, but rarely use AF.C...

07-05-2012, 01:30 AM   #20
Forum Member
CuriousEye's Avatar

Join Date: Apr 2011
Location: Upper Austria
Photos: Gallery
Posts: 77
this lock up issue happened to me 3-4 times but only when shooting AF.C in continuous mode, e.g. during the Paris Air Show.
After 10k shutter actuations i send the cam in for "check up service"( 1 check-up service is free) to Pentax Hamburg/Germany (although i had no problems!) and it cam back with the comment: Sensor cleaned, AF sensor adjusted, electronic tested - no issues at all!
At the moment shutter shows 13,5k actuations and there was no further lock up.

Greetings form Austria,
Sascha
07-05-2012, 02:43 AM   #21
Site Supporter




Join Date: Aug 2007
Location: Melbourne, Australia
Photos: Albums
Posts: 126
New body locking

Thought I'd better add my experience.
My April 2012 manufactured, approximately 1000 exposure, latest firmware K-5 locked up during AF-C shooting yesterday. Pentax battery was not full, but well charged - no grip. Buffer nowhere near full - few exposures. Rear orange led constantly lit. No response to anything other than battery removal.
First of my Pentax digitals to do this. The others - *istD, K10D, K-x, K-7 - never did or do this, although the only other body I've really pumped is the K-7, so the others probably don't count - other than they've never locked up, any time. Seems to be directly related to the constant focussing, wouldn't you think?

Cheers

Mutters
07-06-2012, 09:21 AM   #22
Site Supporter
Kameko's Avatar

Join Date: May 2012
Location: White Rock
Photos: Albums
Posts: 431
I've been having this problem as well. I've upgraded the firmware to 1.12 and have around 6000 actuations. The first time was about 3 months ago, battery was less than 50%, popped it out and back in, was fine for another month. Second time the battery was around 50%. 2 weeks ago it was on a full charge, I'd actually just turned it on and noticed it was locked up from the get go. I popped the battery out and was fine shooting in MF for a few minutes before it locked up again; I'm not sure the theory of it occurring in AF.C is accurate. Either that or I suck the life out of electronics
07-06-2012, 09:22 AM   #23
Pentaxian
LeDave's Avatar

Join Date: Jun 2009
Location: Minneapolis - St. Paul
Photos: Gallery
Posts: 2,904
For those with problems, what are your guys' serial numbers?

07-06-2012, 09:28 AM   #24
Pentaxian




Join Date: Oct 2011
Location: Savannah, GA
Posts: 5,002
QuoteOriginally posted by Grete_J Quote
I've been having this problem as well. I've upgraded the firmware to 1.12 and have around 6000 actuations. The first time was about 3 months ago, battery was less than 50%, popped it out and back in, was fine for another month. Second time the battery was around 50%. 2 weeks ago it was on a full charge, I'd actually just turned it on and noticed it was locked up from the get go. I popped the battery out and was fine shooting in MF for a few minutes before it locked up again; I'm not sure the theory of it occurring in AF.C is accurate. Either that or I suck the life out of electronics
There is a newer firmware update -- please don't say "it didn't have any changes that applied to me, so I skipped it".
07-13-2012, 12:40 AM   #25
Site Supporter




Join Date: Aug 2007
Location: Melbourne, Australia
Photos: Albums
Posts: 126
QuoteOriginally posted by Mutters Quote
Seems to be directly related to the constant focussing, wouldn't you think?

Cheers

Mutters
Further investigation is pointing towards the SD card. I have changed to a "normal" variety from an EyeFi card and don't seem to be having the problem - so far - during AF-C shooting.
I'll be pushing it harder next week and see what develops.
07-13-2012, 08:56 AM   #26
Pentaxian




Join Date: Oct 2011
Location: Savannah, GA
Posts: 5,002
QuoteOriginally posted by Mutters Quote
Further investigation is pointing towards the SD card. I have changed to a "normal" variety from an EyeFi card and don't seem to be having the problem - so far - during AF-C shooting.
I'll be pushing it harder next week and see what develops.
Maybe you are on to something there -- maybe it is not AF-C per se but the combination of AF-C & writing to the card during continuous shooting, i.e. the camera is trying to do too many things at once and locks up -- multi-tasking is a tricky business and often where glitches occur in programming in general, especially once you add the wrinkle of physical/mechanical components as part of the system. And so a faster card, or a non-EyeFi card that isn't *doing* whatever it does, may help.
07-15-2012, 09:34 PM   #27
Veteran Member
sterretje's Avatar

Join Date: Dec 2008
Location: Roodepoort, South Africa
Photos: Gallery | Albums
Posts: 3,534
QuoteOriginally posted by vonBaloney Quote
Maybe you are on to something there -- maybe it is not AF-C per se but the combination of AF-C & writing to the card during continuous shooting,
Doubt it; mine locked up (as described earlier in this thread) in AFc and 'single shot mode'; (original) battery plenty full (50 shots or so after charge). Just can't remember if I was using TAv at that moment.
07-15-2012, 11:18 PM   #28
Forum Member




Join Date: Apr 2012
Posts: 75
QuoteOriginally posted by vonBaloney Quote
Maybe you are on to something there -- maybe it is not AF-C per se but the combination of AF-C & writing to the card during continuous shooting, i.e. the camera is trying to do too many things at once and locks up -- multi-tasking is a tricky business and often where glitches occur in programming in general, especially once you add the wrinkle of physical/mechanical components as part of the system. And so a faster card, or a non-EyeFi card that isn't *doing* whatever it does, may help.
Mine locked up twice again the other day shooting manual focus. I'll be sending this to pentax shortly.
07-16-2012, 07:51 AM   #29
Pentaxian




Join Date: Oct 2011
Location: Savannah, GA
Posts: 5,002
QuoteOriginally posted by PushTheRedButton Quote
Mine locked up twice again the other day shooting manual focus. I'll be sending this to pentax shortly.
Really? What were you doing right when it locked up? LV on?

For those with lockups, did you try other SD cards?
07-17-2012, 02:08 PM   #30
New Member




Join Date: Feb 2012
Posts: 2
my k5 has locked in all modes battery full to half charge and i allways carry a spare just in case. i also get mirror double click not in live view as
i hardly ever use it sometimes mirror sounds like its falling off not good . as for auto focus well in low light with 2.8 100mm macro it can saw
back and forth to the point i think its going to screw the end off . my walk about lens 18/135 needs shutter speeds of 500 sec to bag a sharp image of a running dog if running towards me alto focus not precise at all ok on landscapes sent back to pentax uk today for repair god knows when it will be back
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, k-5, k-5 ii, k-5 iis, k5, light, pentax k-5, pictures, settings, time
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Shutter button locking bjake Troubleshooting and Beginner Help 6 02-04-2012 10:45 PM
Autofocus not locking in Jool Pentax K-5 10 08-29-2011 11:12 AM
K-5 locking up yesterday, now... melvis2 Pentax K-5 21 07-16-2011 03:26 AM
locking the mode dial any tips? adwb Pentax K-r 5 07-01-2011 01:14 AM
K10D AF not locking Geekybiker Troubleshooting and Beginner Help 3 06-02-2011 01:57 PM



All times are GMT -7. The time now is 05:53 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top