Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
06-03-2012, 07:11 PM   #1
Pentaxian




Join Date: Nov 2007
Location: Western Canada
Posts: 3,833
K-5 froze....why ?

I've had my K-5 since Nov. 2011.

Up to now it's worked great without a hitch.

Today...I pressed the shutter button and the camera froze. It was on, the upper window was on....but the camera didn't function...wouldn't respond to the shutter button...just froze. I couldn't turn it off.

I had taken a number of photos today and was in the process of taking another one...when it stopped working.

After about 10 minutes I decided to take the battery out...as that was the only way I could figure to turn it off.

The camera turned off...after I popped the battery completely out.

I then put the battery into the camera...and voila...the camera...once again worked perfectly.

What could the problem be ?

Will it happen again ?

06-03-2012, 07:23 PM   #2
Veteran Member
lammie200's Avatar

Join Date: Jun 2011
Location: San Francisco
Photos: Albums
Posts: 1,028
Firmware version?

QuoteOriginally posted by lesmore49 Quote
...What could the problem be ?

Will it happen again ?
Firmware version?
06-03-2012, 07:23 PM   #3
Site Supporter
jpzk's Avatar

Join Date: Jan 2009
Location: Québec
Photos: Gallery | Albums
Posts: 6,980
QuoteOriginally posted by lesmore49 Quote
I've had my K-5 since Nov. 2011.

Up to now it's worked great without a hitch.

Today...I pressed the shutter button and the camera froze. It was on, the upper window was on....but the camera didn't function...wouldn't respond to the shutter button...just froze. I couldn't turn it off.

I had taken a number of photos today and was in the process of taking another one...when it stopped working.

After about 10 minutes I decided to take the battery out...as that was the only way I could figure to turn it off.

The camera turned off...after I popped the battery completely out.

I then put the battery into the camera...and voila...the camera...once again worked perfectly.

What could the problem be ?

Will it happen again ?
Read those:

Always a good idea to do a little serching before posting a question ...

https://www.pentaxforums.com/forums/pentax-k-5/163726-k-5-freezing-up-no-bigg...-annoying.html

https://www.pentaxforums.com/forums/general-technical-troubleshooting/170784-...e-upgrade.html

https://www.pentaxforums.com/forums/pentax-k-5/154738-my-k-5-freezing-issues.html

https://www.pentaxforums.com/forums/pentax-k-5/138275-replaced-k5-tested-freezing.html
06-03-2012, 07:41 PM   #4
Loyal Site Supporter
imtheguy's Avatar

Join Date: Mar 2009
Location: Virginia Beach
Photos: Gallery | Albums
Posts: 2,950
I'll just add that I am happy that you had a solid 6 months shooting before the first freeze. Either send it in for "repair" or get faster at popping the battery out. But seriously, changing batteries before they get too low may cure it for you. If it was a fresh battery, go back to sentence #2. ...and good luck!

06-04-2012, 01:05 AM   #5
Site Supporter




Join Date: Oct 2009
Location: North
Photos: Gallery
Posts: 3,775
Probably the logics in the firmware got screwed with multiple commands/loops during usage.
It can happen again, but rarely so (for me)
Anyway, I just take the battery out and pop it back in.
I've never run into or known of anyone who had this issue continuously such that it became impossible to shoot, so don't worry too much.

Hey! My latest and greatest Samsung Galaxy Note using the OS that was designed by the best paid and brainiest that Google and afford hangs up too (more often )

On a almost 1yr 9mths K5.
06-04-2012, 09:32 AM   #6
Pentaxian




Join Date: Nov 2007
Location: Western Canada
Posts: 3,833
Original Poster
I've sent it in to Pentax for a check over. Thanks for the suggestions, much appreciated.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
battery, camera, dslr, froze, k-5, k-5 ii, k-5 iis, k5, pentax k-5, shutter
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K-7 froze in video mode, now messed up dedmozaj Troubleshooting and Beginner Help 4 05-18-2011 04:26 PM
Nature "It is a thorn." and "Water froze in time." Danny Delcambre Post Your Photos! 1 04-15-2011 09:00 AM
K-X made clunking, vibrating noise then froze up Olypentax Pentax DSLR Discussion 3 03-11-2010 11:43 AM



All times are GMT -7. The time now is 02:27 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top