Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
07-01-2012, 01:23 PM   #1
Senior Member




Join Date: May 2010
Location: long island
Posts: 135
shutter fires twice in single shot mode???

hi all!

just wondering if this is a problem that I can fix myself... or I have to send it for repair.

In single shot mode, the k-5 takes 2 pictures almost every time I press the shutter. So basically one press of the shutter button makes the shutter fire twice and take 2 pics.

To me that's a really annoying problem. So if you ever had the same experience and had a way to solve it, please share.

Thanks a lot in advance!

07-01-2012, 01:28 PM   #2
Pentaxian
LeDave's Avatar

Join Date: Jun 2009
Location: Minneapolis - St. Paul
Photos: Gallery
Posts: 2,904
It's a defect, I saw it on youtube the other day, you'll have to send it in for repairs.
07-01-2012, 01:30 PM   #3
Pentaxian
RonHendriks1966's Avatar

Join Date: Jan 2009
Photos: Gallery
Posts: 8,714
unless you set it to some bracketingmode.
07-01-2012, 02:23 PM   #4
Pentaxian
aleonx3's Avatar

Join Date: Jul 2007
Location: Brampton, Ontario
Photos: Gallery | Albums
Posts: 3,888
Sounds like you have set the camera at continuous shooting mode..

07-01-2012, 02:25 PM   #5
Loyal Site Supporter
imtheguy's Avatar

Join Date: Mar 2009
Location: Virginia Beach
Photos: Gallery | Albums
Posts: 2,950
My K-5 does that if I press the shutter button very lightly, as if its a de-bounce issue in the switch. When I press and follow through firmly, I get only the one shot. So I live with it rather than another trip to CRIS.
07-01-2012, 03:20 PM   #6
Site Supporter
AussieTrev's Avatar

Join Date: Jul 2010
Location: Queensland
Photos: Gallery | Albums
Posts: 3,270
There is the two shot bracketing mode that I would check first.
07-02-2012, 08:13 PM   #7
Senior Member




Join Date: May 2010
Location: long island
Posts: 135
Original Poster
thanks guys. very helpful! will send to repair... fortunately my credit card covers the camera for 1 more year:-)
07-02-2012, 11:26 PM   #8
Senior Member




Join Date: Jan 2010
Location: HCMC
Posts: 272
Hey, can you just try the shooting mode first.. i think we have the same issue (had it before).

choose on the bracketing... there is a selection for 2, 3 and 5 shots. select 2 then go back to single mode (there might be a problem on this thing/switch) mine's performing well now...

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, k-5, k-5 ii, k-5 iis, k5, pentax k-5, press, shot, shutter, shutter fires
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Flash fires twice in Trailing curtain sync mode manuido Flashes, Lighting, and Studio 12 06-06-2012 07:39 AM
Original Pentax 645 only fires once in S mode then needs reboot Steinback Pentax Medium Format 3 01-22-2012 01:51 AM
I want to use autofocus single mode but with everything else automatic. K-x Dairylander Troubleshooting and Beginner Help 6 12-12-2011 10:29 AM
Shutter only fires sometimes with manual lens - sears 50mm f1.7 jptruesdale Troubleshooting and Beginner Help 4 10-11-2011 08:16 AM
Single Frame Shooting Vs Continuous Drive Mode Verglace Troubleshooting and Beginner Help 5 03-05-2011 08:19 AM



All times are GMT -7. The time now is 03:00 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top