Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
07-30-2012, 04:57 PM   #1
Loyal Site Supporter




Join Date: Sep 2006
Location: Bronx NY
Photos: Gallery | Albums
Posts: 5,599
Camera back!

Just got my camera back from CRIS. Pop-up flash had stopped working and also had the "freezies". Camera would freeze, all buttons, e-dials, shutter, etc would not work, sometimes back lcd would go blank, tho top lcd was always on (but frozen...no change when camera pointed towards bright or dim light) Several other people have had this problem. Interestingly enough unlike others I did not have to remove the battery to get camera to turn off, just waited an average of 3-6 seconds (sometimes more but never more than about 15 seconds). Condition started in early June and got steadily worse. Waited until after a music festival and sent it into CRIS on 7/6. They got it on the 9th (I checked), repaired it and shipped it back on the 23rd. CRIS replaced the pop-up flash assembly, and the main pcb/fpc, updated firmware, reset all parameters to default and "cleaned and checked to manufacturers specifications". Hopefully the "freezies" are fixed, I will give it a good workout this weekend to see. I've been shooting with my K20D and I will say that the K-5 spoiled me mightily. Much much much better camera than the K20.

NaCl(so far I'm a happy camper)H2O

07-30-2012, 05:14 PM   #2
Veteran Member
Docrwm's Avatar

Join Date: Sep 2010
Location: Somewhere in the Southern US
Photos: Gallery | Albums
Posts: 11,275
Glad your camera is back and hope it keeps working for you. How long was it between shipping it to them and getting notified that they had received it?
07-30-2012, 05:53 PM   #3
Senior Member
usmcxm35's Avatar

Join Date: Jun 2010
Location: New York, USA
Photos: Gallery | Albums
Posts: 215
That's great to hear Peter. Good luck, I'm going to cross my fingers for you in hopes that everything was resolved with the PCB replacement.
07-31-2012, 04:03 AM   #4
Loyal Site Supporter




Join Date: Sep 2006
Location: Bronx NY
Photos: Gallery | Albums
Posts: 5,599
Original Poster
QuoteOriginally posted by Docrwm Quote
Glad your camera is back and hope it keeps working for you. How long was it between shipping it to them and getting notified that they had received it?
They never notified me they received it. I shipped it priority mail with tracking. Mailed it on a Friday (AM) and checked the tracking # on Monday afternoon and they had received it. I got no notification from them at all. Camera just showed up yesterday. From info found here on the forums, I was expecting it to take about a month, it took a little less than that.

NaCl(CRIS communication skills are 'less than optimal' to say the least)H2O

07-31-2012, 04:09 AM   #5
Loyal Site Supporter




Join Date: Sep 2006
Location: Bronx NY
Photos: Gallery | Albums
Posts: 5,599
Original Poster
QuoteOriginally posted by usmcxm35 Quote
That's great to hear Peter. Good luck, I'm going to cross my fingers for you in hopes that everything was resolved with the PCB replacement.
Thanks Danny, I hope so too! From what I've read here from others, that seems to be the case most of the time. I'll put it thru some heavy useage on Saturday and see. At least the flash works, that was easily checked. As you well know intermittent electronic problems can be tough to diagnose, hopefully they didn't just throw a part at it and hope.

NaCl(techs have been known to do that a time or two )H2O
07-31-2012, 06:29 AM   #6
Veteran Member
Docrwm's Avatar

Join Date: Sep 2010
Location: Somewhere in the Southern US
Photos: Gallery | Albums
Posts: 11,275
QuoteOriginally posted by NaClH2O Quote
They never notified me they received it. I shipped it priority mail with tracking. Mailed it on a Friday (AM) and checked the tracking # on Monday afternoon and they had received it. I got no notification from them at all. Camera just showed up yesterday. From info found here on the forums, I was expecting it to take about a month, it took a little less than that.

NaCl(CRIS communication skills are 'less than optimal' to say the least)H2O
Thanks. I emailed them inquiring as its been 10 days since I mailed my battery grip into them.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, cris, dslr, flash, k-5, k-5 ii, k-5 iis, k5, lcd, pentax k-5, pop-up
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Putting back photo into camera + digital filter skexxx Troubleshooting and Beginner Help 2 09-04-2011 02:45 AM
Can't open the back of the camera ColdEye Pentax Film SLR Discussion 9 07-20-2011 01:56 AM
Got my converted IR camera back today Fl_Gulfer Pentax DSLR Discussion 2 01-07-2011 08:47 PM
Pictures lost after turning camera off and back on! (K7) Help! Arrvon Pentax DSLR Discussion 3 10-18-2010 06:13 PM



All times are GMT -7. The time now is 03:15 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top