Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
08-06-2012, 01:38 PM   #1
New Member




Join Date: Jun 2012
Posts: 11
Pentax K-5 hangs when doing digital preview with AF-360 flash

I'm experiencing an odd problem with my Pentax K-5, firmware 1.13.

When I do a digital preview with my AF-360 FGZ flash mounted and active, the camera sort of hangs. The digital preview flashes on the screen for just a fraction of a second then the screen goes black with just an hourglass in the center. The shutter release and exposure controls still work but the info / menu / OK and most of the other buttons on the back do nothing. The camera will stay in this state indefinitely as far as I can tell if I don't do anything.

If I take a picture or power cycle the camera it recovers.

I rarely use a hotshoe flash, but I know my K-5 didn't used to behave this way. I think it may be related to the 1.13 firmware.

Digital preview works fine if the flash is powered off or not attached.

It's a bit of a hassle when trying to match flash with ambient light.

Has anyone else experienced this?

08-06-2012, 06:14 PM   #2
Riv
Senior Member




Join Date: Jan 2012
Location: Michigan
Photos: Albums
Posts: 142
Hi,

Just tested it here, takes just as long either way (relatively quick). I do have 1.13 loaded.

I can't see it making a difference, but is it doing it in all exp/drive modes?
08-06-2012, 06:24 PM   #3
New Member




Join Date: Jun 2012
Posts: 11
Original Poster
I was just testing this and found some more interesting details.

FWIW, I've been testing with the camera body set to X and M with various shutter speeds under 180. Single shot drive mode. Flash is set to the default leading curtain sync.

What I've found out is it only happens when the flash is in P-TTL or M mode, not when it's in A mode.

It also only happens when the camera is set to an ISO under 800. Everything works perfectly at ISO 800 or higher.

Now I'm really curious if it's just me or everyone.
08-06-2012, 06:37 PM   #4
Riv
Senior Member




Join Date: Jan 2012
Location: Michigan
Photos: Albums
Posts: 142
Sorry.. I've tried serveral modes in addition to the ones you just mentioned, tried a good 15 to 20 tests. Everytime it worked fine.

Have you tried setting the camera back to defaults(reset) since you discovered this? or checked the hotshoe contacts (cam and flash) make sure they're clean? Sorry forgot you said above ISO800 is fine as I typed that...


Last edited by Riv; 08-06-2012 at 06:44 PM.
08-06-2012, 06:47 PM   #5
New Member




Join Date: Jun 2012
Posts: 11
Original Poster
I checked the hotshoe contacts. The ISO setting seems to be the critical thing. This isn't inconvenient enough for me to want to reset the camera right now, I have a lot of settings that aren't default and calibration for a bunch of lenses. Camera's already out of warranty anyway.

But it's useful knowing that it's something particular to my camera. Thanks for checking.
09-18-2012, 02:49 AM   #6
Forum Member
Vinfer's Avatar

Join Date: Mar 2009
Location: Ottaviano (Italy)
Posts: 57
Same problem here but with flash Metz Af-58.
Firmware 1.13.

However resetting the camera everything is back to work fine.

Last edited by Vinfer; 09-18-2012 at 03:04 AM.
09-18-2012, 12:57 PM   #7
New Member




Join Date: Jun 2012
Posts: 11
Original Poster
Yeah I never posted a follow up but I found the time to reset my camera and it fixed the problem completely. It also didn't erase my lens focus calibrations settings so it was a lot easier than I expected.
09-18-2012, 05:32 PM   #8
Forum Member
Vinfer's Avatar

Join Date: Mar 2009
Location: Ottaviano (Italy)
Posts: 57
I just have found the source of the problem: is it option "lens correction" in camera (distortion and chromatic aberration). If one or both options are active, the problem returns

09-19-2012, 12:22 PM   #9
New Member




Join Date: Jun 2012
Posts: 11
Original Poster
QuoteOriginally posted by Vinfer Quote
I just have found the source of the problem: is it option "lens correction" in camera (distortion and chromatic aberration). If one or both options are active, the problem returns
In my case I never activate those features and they were definitely off when I was having the problem with my camera. I might have had them on for a short time at some point in the past and maybe that's what caused my camera to get messed up but they were definitely off when I was trying to diagnose the problem.
09-20-2012, 09:50 AM   #10
Forum Member




Join Date: Apr 2010
Photos: Albums
Posts: 91
Hi,

I got my K-5 freezing while shooting with AF 540 in M mode yesterday. Camera ISO was set to 100, M mode. It happened only once but camera was not responding to any buttons. Removing the battery solved that and I never encountered such disfunction earlier... but I use flash rarely and it could be that previous shooting with flash was before 1.13 upgrade.

The rest of the session went flawlessly. I paid no attention to that unless I saw this thread.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
af-360, camera, dslr, firmware, flash, k-5, k-5 ii, k-5 iis, k5, pentax, pentax k-5, screen
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pentax rugged 360 degree digital camera. Wait, what? i83N Pentax News and Rumors 40 09-22-2012 04:37 PM
Digital preview... is it a shutter count? HoBykoYan Pentax K-5 14 05-04-2012 09:22 PM
For Sale - Sold: Pentax AF 360 flash zhuxyg Sold Items 2 12-01-2011 12:47 PM
What is digital preview on live view? kshapero Pentax DSLR Discussion 2 11-12-2010 05:38 PM



All times are GMT -7. The time now is 04:43 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top