Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-10-2012, 01:15 PM   #1
New Member




Join Date: Aug 2012
Location: IASI
Posts: 10
k-5 pop-up flash does not work

today, from my k-5, stop working, pop up flash in any mode I try to shoot. when pop up flash is down, everything work well.
I bought this body new from a shop, have only 2 month old and only 1500 shutter count.
I found some discussions about this problem on the forum, but without solution to repair this problem.
how anyone solve this problem, must be send to warranty? THX

10-10-2012, 01:44 PM   #2
Pentaxian
amoringello's Avatar

Join Date: May 2008
Location: Virginia, USA
Photos: Gallery
Posts: 1,393
All I can think of is that the capacitor for the flash is not charing and not allowing the photo to be taken. I believe there is a setting to wait for flash to charge before allowing the photo to be taken or not. Sadly, my K5 just went back to the shop to have the weather seals put in properly after the prior repair. So I cannot check what menu item that might be.

I'd try turning that off and see if the photo can be taken. If it is, and the flash does not go off, that might be the problem.
Either way, it sounds like repair is in your future.
10-10-2012, 02:48 PM   #3
Site Supporter
SpecialK's Avatar

Join Date: Dec 2006
Location: So California
Photos: Gallery
Posts: 14,440
Have you started wearing a hat with a brim? If it pushes the flash down a little, it will not fire. I very rarely use the pop up for a bit of fill, and I have to remember to push my hat back first.

(Hoping for the easiest solution).
10-11-2012, 02:00 AM   #4
New Member




Join Date: Aug 2012
Location: IASI
Posts: 10
Original Poster
if I push little bit down popup flash, the k-5 body take any photo well, I think the capacitor or flash lamp are broken

10-11-2012, 02:04 AM   #5
New Member




Join Date: Aug 2012
Location: IASI
Posts: 10
Original Poster
QuoteOriginally posted by amoringello Quote
All I can think of is that the capacitor for the flash is not charing and not allowing the photo to be taken. I believe there is a setting to wait for flash to charge before allowing the photo to be taken or not. Sadly, my K5 just went back to the shop to have the weather seals put in properly after the prior repair. So I cannot check what menu item that might be.

I'd try turning that off and see if the photo can be taken. If it is, and the flash does not go off, that might be the problem.
Either way, it sounds like repair is in your future.
i know this menu, if I set to not wait charging flash, body work well, but flash light still do not work.
10-11-2012, 02:08 AM   #6
Pentaxian
amoringello's Avatar

Join Date: May 2008
Location: Virginia, USA
Photos: Gallery
Posts: 1,393
QuoteOriginally posted by giani Quote
i know this menu, if I set to not wait charging flash, body work well, but flash light still do not work.
Sad to hear it, but at least it sounds like you've narrowed down the problem to something that is not caused simply by you doing something silly.
10-11-2012, 02:08 AM   #7
Pentaxian




Join Date: Oct 2011
Location: Savannah, GA
Posts: 4,989
Mine stopped working, wouldn't fire. I hardly ever use flash, and my camera was pretty lightly used overall. I'd used the flash a few times that day, and just a few minutes before it stopped working. Once it broke, AF would not operate on half-press with flash up, although it would start to AF on full-press as it was firing. Everything worked perfectly with flash down. So I fiddled with it, reset to defaults, tried different battery, etc, and then finally gave up and sent it in for warranty repair. Got in back 3 weeks later, they replaced the flash unit, all is well. I have heard of several others with same issue -- some part or connection in there must be dodgy -- hopefully repair will be permanent.
10-11-2012, 04:50 AM   #8
Site Supporter




Join Date: Nov 2008
Location: Singapore
Photos: Gallery
Posts: 904
QuoteOriginally posted by giani Quote
today, from my k-5, stop working, pop up flash in any mode I try to shoot. when pop up flash is down, everything work well.
I bought this body new from a shop, have only 2 month old and only 1500 shutter count.
I found some discussions about this problem on the forum, but without solution to repair this problem.
how anyone solve this problem, must be send to warranty? THX
Send it in for warranty repair.

10-21-2012, 11:22 PM   #9
New Member




Join Date: Aug 2012
Location: IASI
Posts: 10
Original Poster
I went to warranty and found a flash fuse burned in 30 minutes was repaired.
Thanks for all the answers.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, flash, k-5, k-5 ii, k-5 iis, k5, pentax k-5, pop
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K-X: Using the Pop-Up Flash dmfw Pentax DSLR Discussion 6 12-05-2011 04:03 AM
K20D pop-up flash doesn't pop up! ducdao Pentax DSLR Discussion 3 11-29-2011 07:57 AM
K-x and pop-up flash rajubhai55 Pentax DSLR Discussion 12 07-11-2011 07:44 PM
k5 pop-up flash hook (that holds the flash down) broken... Thesorus Troubleshooting and Beginner Help 4 01-06-2011 08:34 PM
K2000 - Pop up flash will not pop up. tkindred Pentax DSLR Discussion 6 08-17-2009 08:54 AM



All times are GMT -7. The time now is 07:07 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top