Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
12-13-2012, 07:35 AM   #1
Junior Member




Join Date: Jul 2011
Location: Bunbury
Posts: 29
Canon S100 backup camera

I know I know... this is Pentax forum! But for those of you brandishing backup cameras, I just wanted you to know about my Canon experience. (I own a K-5 BTW). Here is my post to the Canon forum about why I wont ever buy into Canon again - ever:

Canon S100 ' Lens Error' issues:

I wonder how many of you have experienced Canon's infamous 'Lens Error' issue? My recently bought S100 camera succumbed. It was bought at T-Dimension in Hong Kong in March 2012. As Canon proclaimed it was a manufacturing fault, I assumed Canon Australia would fix the fault. Nope. (A few days later I received an email from them saying they would in fact fix it. Meantime I'd already sent the camera off to seller in Hong Kong). This kind of response from Canon was going to prove prophetic. Read on:

So having duly sent the camera off to T-Dimension Hong Kong, they now say Canon claim it is a user fault??? They sent me three pictures of the camera's exterior to prove this. The camera in the picture looked damaged in a way that mine was definitely not. Even so; wouldn't you say the INSIDE of the camera would be better way to ascertain exactly what the fault was? I wanted T-dimension to confirm my camera serial number was that on the pictured camera. The number they quoted me was NOTHING like a Canon S100 serial. Different sequence and numbers altogether. Go figure. (Mine has 30xxxxxx prefix - in the nasty 29-41 batch!)

Now T-Dimension are demanding money for camera repair and shipping... having already posted to them at my expense. (Did I mention it's still under Warranty!!!)They will not give me any information in relation to either the camera, likely costs or who exactly is doing the repair. So either Canon are refusing to take responsibility for the manufacturing fault or T-Dimension are pulling a fast one thru a third party repairer so they can avoid both postage (and repair?) costs. Presently T-Dimension, other than giving me lots of 'anything we can do to help' on their emails, has failed to inform me of a single fact pertaining to the repair of my camera. I have not heard from them in 36 hours. So I wonder if anyone else has any similar reassuring Canon or T-Dimension stories?

I know five things for sure and certain:

I. Climate change is real

2. I will never - repeat NEVER - buy ANY Canon product again.

3. I will never buy from T-Dimension again.

4. I will post every gram of negative feedback I can to every forum I know about this issue.

5. I will ritually hammer the camera to dust when/if it is returned and post it to Canon so they can enema it back to where it belongs.
Denisio F.

PS: I took some time to check out how common this S100 issue was. Seems like it is possibly an epidemic. I collected a bunch of links/complaints/info about this issue if anyone would like to see it. Wasnt able to link the Word Doc here unfortunately.

PSS: Did I mention the video of said deed in item #5? I will post on Utube. Stay tuned.

12-13-2012, 08:02 AM   #2
Pentaxian




Join Date: Jun 2009
Location: GMT +10
Photos: Albums
Posts: 10,586
A good topic for Whirlpool . The feedback on this seller is useful, since they do sell Pentax too. So I guess it is worth noting.

People always assume the grass is greener on the other side of the fence with their camera brands and regional distributors. This highlights how it may not always be the case...
12-13-2012, 08:06 AM   #3
Site Supporter




Join Date: May 2009
Location: Seattle, WA
Posts: 828
I have a s100 that had this issue. Canon finally admitted it was their error and will fix/replace at their cost (although I did have to pay shipping 1-way). Seems like folks who had their cameras repaired before this should be able to get a refund.
12-13-2012, 08:33 AM   #4
Pentaxian
seventysixersfan's Avatar

Join Date: Aug 2010
Location: Alexandria, VA
Posts: 1,701
Sorry to hear that this happened to you. The lens error problem is very common to the Canon point-and-shoot compacts. I have a Canon S95 as a small pocketable camera when I can't bring my K-x, and so far it's been okay-- every now and then I get a weird "memory card error" problem, but I turn it off and turn it back on and then it works again. Definitely they have some quality control issues.

12-13-2012, 08:51 AM   #5
Veteran Member
Docrwm's Avatar

Join Date: Sep 2010
Location: Somewhere in the Southern US
Photos: Gallery | Albums
Posts: 11,275
I had a Canon P&S years ago that developed a fault that was widely posted about online. Canon denied it was their fault and will never get my business again. Even if I need faster AF I'll go to Nikon instead of Canon if I ever leave Pentax.
12-13-2012, 03:19 PM   #6
Veteran Member




Join Date: Mar 2009
Location: Chicago suburbs
Photos: Albums
Posts: 848
QuoteOriginally posted by Docrwm Quote
I had a Canon P&S years ago that developed a fault that was widely posted about online. Canon denied it was their fault and will never get my business again. Even if I need faster AF I'll go to Nikon instead of Canon if I ever leave Pentax.
Agree. Oly P&S much more robust than Canon.
12-13-2012, 03:55 PM   #7
Veteran Member
Docrwm's Avatar

Join Date: Sep 2010
Location: Somewhere in the Southern US
Photos: Gallery | Albums
Posts: 11,275
QuoteOriginally posted by gp1806 Quote
Agree. Oly P&S much more robust than Canon.
As I recall, from years ago, Canon had shifted from one country of origin for the P&S to another for the same model. The reports of faults from those from the 2nd country were extremely high. Mine developed precisely the fault that was being complained about and was from the same serial number range and from that country. Canon just said, nope - no SDM...errr...focus problem with our camera.
12-13-2012, 04:33 PM   #8
Loyal Site Supporter
paulh's Avatar

Join Date: Sep 2010
Location: DFW Texas
Photos: Gallery | Albums
Posts: 12,462
I'm not a huge Canon fan, altho I have an old Powershot A430 (4mp entry-level P&S) that still gets regular use. I think I got it back in '04, and it's all dinged up from bouncing around in my wife's purse, and has been dropped and banged-on numerous times. But it hasn't missed a beat (yet!). Maybe they had better QC back then.

btw, why is this in the K-5 forum?

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, canon, dslr, fault, hong, k-5, k-5 ii, k-5 iis, k5, kong, pentax k-5, repair
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
For Sale - Sold: Canon Powershot s100 oeriies Sold Items 0 08-18-2012 12:59 PM
X100 as 2nd/backup camera abieleck Non-Pentax Cameras: Canon, Nikon, etc. 7 08-16-2012 07:08 AM
Balance between a teaching camera and a backup camera for my K-5 MSL Pentax DSLR Discussion 20 03-08-2012 08:08 PM
Fuji X10 vs Canon S100 raider Non-Pentax Cameras: Canon, Nikon, etc. 5 11-05-2011 01:34 AM



All times are GMT -7. The time now is 04:01 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top