Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
12-15-2012, 07:43 PM   #1
Pentaxian
Designosophy's Avatar

Join Date: Sep 2010
Location: Northeast Philadelphia
Photos: Gallery | Albums
Posts: 1,094
K-5 with occasionally stuck shutter

My K-5's shutter seems to be getting stuck now and then. It's making me miss shots. Mostly it sticks closed (won't take a photo), but sometimes it sticks open (black viewfinder). I suppose it could be the mirror, not the shutter, getting stuck. But has anyone had this problem before, and is there anything I can do for it, aside from sending it to CRIS? The K-5 has about 27,000 actuations on it.

12-15-2012, 09:44 PM   #2
Pentaxian




Join Date: Jun 2009
Location: GMT +10
Photos: Albums
Posts: 10,576
Is there any pattern to when these issues occur - eg after a long shoot, or using any particular AF or exposure mode, or with grip/ without grip attached, or using any particular lens, or only on hot days? Etc.
12-16-2012, 09:20 AM   #3
Pentaxian
Designosophy's Avatar

Join Date: Sep 2010
Location: Northeast Philadelphia
Photos: Gallery | Albums
Posts: 1,094
Original Poster
I haven't noticed any patterns, but I'm trying to. So far, it's happened with manual and AF lenses, HSM & screw drive, Pentax and third-party, and minutes after starting the camera up, as well as after an hour of usage.
12-16-2012, 10:29 AM   #4
Pentaxian
StephenHampshire's Avatar

Join Date: Oct 2009
Location: Winchester
Photos: Gallery | Albums
Posts: 1,060
QuoteOriginally posted by Designosophy Quote
I haven't noticed any patterns, but I'm trying to. So far, it's happened with manual and AF lenses, HSM & screw drive, Pentax and third-party, and minutes after starting the camera up, as well as after an hour of usage.
Yes, I had exact same problem, only way ti get mirror to drop back was to tap the camera. Started happening when the camera was 9 months old, first it was once a week, then once a day then 3 times a day..... got a K30 and sent my K5 off for repair. Normally happened after a continuous burst but latterly after a single shot - new battery, old battery no difference, sometimes got a battery depleted message.Outdoors in the cold and wet, in the sun, indoors in the warm, happened everywhere. Google tells me it is probably a faulty mirror actuating motor ( which fits with the battery depleted message too - actuator stuck, pulling large current trying to move) So far no news on the K5 (luckily still under warranty) the K30 is a good substitute and was very cheap.

12-16-2012, 05:09 PM   #5
Senior Member
jrforman's Avatar

Join Date: Mar 2008
Location: Minneapolis
Photos: Gallery | Albums
Posts: 202
Had same problem, same symptoms. Camera out of Warranty. CRIS replaced mirror motor, no problems. I can't remember the exact cost of the repair. No problems since then.
12-16-2012, 06:43 PM   #6
Pentaxian
Designosophy's Avatar

Join Date: Sep 2010
Location: Northeast Philadelphia
Photos: Gallery | Albums
Posts: 1,094
Original Poster
QuoteOriginally posted by StephenHampshire Quote
Yes, I had exact same problem, only way ti get mirror to drop back was to tap the camera. Started happening when the camera was 9 months old, first it was once a week, then once a day then 3 times a day..... got a K30 and sent my K5 off for repair. Normally happened after a continuous burst but latterly after a single shot - new battery, old battery no difference, sometimes got a battery depleted message.Outdoors in the cold and wet, in the sun, indoors in the warm, happened everywhere. Google tells me it is probably a faulty mirror actuating motor ( which fits with the battery depleted message too - actuator stuck, pulling large current trying to move) So far no news on the K5 (luckily still under warranty) the K30 is a good substitute and was very cheap.
QuoteOriginally posted by jrforman Quote
Had same problem, same symptoms. Camera out of Warranty. CRIS replaced mirror motor, no problems. I can't remember the exact cost of the repair. No problems since then.
Thanks for the info. Sounds exactly like my problem. I guess I'll end up sending the camera in, probably in January. Fortunately, I have my K-01 backup! I love that thing, though I still prefer my K-5.
12-17-2012, 03:37 AM   #7
Pentaxian
StephenHampshire's Avatar

Join Date: Oct 2009
Location: Winchester
Photos: Gallery | Albums
Posts: 1,060
QuoteOriginally posted by Designosophy Quote
Thanks for the info. Sounds exactly like my problem. I guess I'll end up sending the camera in, probably in January. Fortunately, I have my K-01 backup! I love that thing, though I still prefer my K-5.
Just received my K5 back from the UK service agent, they repaired it in 7 working days, 12 days door to door. Mirror motor replaced, which is what I assumed would happen based on posts here and elsewhere on the net.
12-17-2012, 08:50 AM   #8
Senior Member




Join Date: Dec 2009
Location: United States
Posts: 149
QuoteOriginally posted by Designosophy Quote
My K-5's shutter seems to be getting stuck now and then. It's making me miss shots. Mostly it sticks closed (won't take a photo), but sometimes it sticks open (black viewfinder). I suppose it could be the mirror, not the shutter, getting stuck. But has anyone had this problem before, and is there anything I can do for it, aside from sending it to CRIS? The K-5 has about 27,000 actuations on it.
Yes. Eventually, it was permanently stuck. I had to send it in to CRIS for the mirror motor repair.

12-17-2012, 06:45 PM   #9
Pentaxian
Designosophy's Avatar

Join Date: Sep 2010
Location: Northeast Philadelphia
Photos: Gallery | Albums
Posts: 1,094
Original Poster
QuoteOriginally posted by skyoftexas Quote
Yes. Eventually, it was permanently stuck. I had to send it in to CRIS for the mirror motor repair.
What did it end up costing?
01-06-2013, 09:01 AM   #10
Pentaxian
Designosophy's Avatar

Join Date: Sep 2010
Location: Northeast Philadelphia
Photos: Gallery | Albums
Posts: 1,094
Original Poster
Well, it happened. The shutter/mirror finally locked up completely. I'll be sending it off tomorrow.
01-28-2013, 01:04 PM   #11
Pentaxian
Transit's Avatar

Join Date: Aug 2007
Location: Whanganui NZ
Photos: Gallery | Albums
Posts: 3,876
I think I might be headed down this road
Does it make a noise but not release ?
Pete
01-28-2013, 01:08 PM   #12
Pentaxian
Designosophy's Avatar

Join Date: Sep 2010
Location: Northeast Philadelphia
Photos: Gallery | Albums
Posts: 1,094
Original Poster
QuoteOriginally posted by Transit Quote
I think I might be headed down this road
Does it make a noise but not release ?
Pete
It would make a little "trying to move" noise, but not much. It depended on whether or not it was stuck up or down - it stuck both places. Also, I sent it out on the 7th of January, and I'm still waiting. CRIS is pretty slow.
01-28-2013, 01:45 PM   #13
Pentaxian
Transit's Avatar

Join Date: Aug 2007
Location: Whanganui NZ
Photos: Gallery | Albums
Posts: 3,876
Trying to move pretty much covers it...
I'll be sending mine to Aussie where they have a good rep

now contemplating a temporary replacement.
Kx's are getting cheaper here now though even *ist still attract keen interest
Pete in NZ
01-28-2013, 06:58 PM   #14
Pentaxian
Designosophy's Avatar

Join Date: Sep 2010
Location: Northeast Philadelphia
Photos: Gallery | Albums
Posts: 1,094
Original Poster
My backup is the K-01. Over here, it's $316 new, which is an excellent deal.
01-29-2013, 10:10 AM   #15
Pentaxian
Transit's Avatar

Join Date: Aug 2007
Location: Whanganui NZ
Photos: Gallery | Albums
Posts: 3,876
No K-01 discounts in NZ
No Pentax discounts in NZ for that matter...
picked up a K100D with FAJ 75-300 for $us150 as a stopgap
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, k-5, k-5 ii, k-5 iis, k5, pentax k-5, shutter, sticks
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with Pentax Kr (similar to K-5 shutter problem) babilon Pentax K-r 24 07-24-2012 04:11 PM
K-x shutter release button stuck? Priit Visitors' Center 3 10-25-2011 01:40 AM
k-x shutter permanently stuck at about 2 seconds grinchicago Pentax DSLR Discussion 8 08-19-2011 06:27 AM
K-5 Shutter No Activation With Manual Focus Septrain Pentax K-5 9 04-02-2011 09:00 PM
Pentax KX Shutter starting to stuck at slow shutter speed. Spirit722 Pentax Film SLR Discussion 7 03-03-2011 09:49 PM



All times are GMT -7. The time now is 05:37 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top