Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
01-08-2013, 07:26 PM   #1
Veteran Member
kaiserz's Avatar

Join Date: Nov 2011
Location: NoVa The "burg"
Photos: Gallery
Posts: 899
Just got myself a new k5

And it has major front focus! I adjusted it to the max already and still it's not even close to hitting the target...
I got it at buydig.com, got the package last week. The package box was small and once I opened it, there was my new k5 inside its own lil box. Inside, it didn't even had those packing peanuts and bubble things. The first thing I've noticed is that the box has a big noticeable dent/damage on one of its side, but I didn't care that much.
Did my initial check, and felt that it's soft, checked the shutter count and it's at one. Changed the settings and made sure it's ready for me to use. Shot a couple more shots, and it's just wrong. iIt's soft not like my k7 or k01, so I did the AF test and BAM. we have our problem... LV AF seems okay, but it's just sad that this happened to me. 3 or 4 adjustment is okay with me, but something that's over 10 and can't even be fixed is just sad. I have a feeling that this k5 in box was dropped from a very high place, because I'm pretty sure that kind of damage/dent on the box would be from just that...

Anyway, should I return/exchange it? or should I send it to pentax for repairs. I want to exchange it, but they might not do it and just have me send it to pentax for repairs, so I'm thinking of just returning it. Maybe I should just save some more and get the k5II? or if I can get my hands on the k5IIs. But I want to get myself some flash and the 55 1.4....

I'm just letting some steam out... thanks guys lol.

01-08-2013, 07:33 PM   #2
Veteran Member
milesy's Avatar

Join Date: Jan 2009
Location: Melbourne
Photos: Gallery
Posts: 379
Out of interest what did you use to test the focus .. I found mine seemed a little soft at first but i think it was the noise reduction being a bit heavy handed in camera
01-08-2013, 07:34 PM   #3
Veteran Member
Docrwm's Avatar

Join Date: Sep 2010
Location: Somewhere in the Southern US
Photos: Gallery | Albums
Posts: 11,275
Sorry about the K-5. I've been there, had to get 3 Tamron 70-200s sent to me for one to a) work at all, and b) not have serious misalignment problems. For a BNIB item I say return it and get another. Good luck.
01-08-2013, 07:37 PM   #4
Pentaxian




Join Date: Jan 2012
Photos: Gallery
Posts: 588
Update to the latest firmware.

01-08-2013, 07:50 PM   #5
Ash
Community Manager
Loyal Site Supporter
Ash's Avatar

Join Date: Mar 2007
Location: Toowoomba, Queensland
Photos: Gallery | Albums
Posts: 22,695
If all else fails, return the dud for a replacement.
01-08-2013, 07:58 PM   #6
Veteran Member
kaiserz's Avatar

Join Date: Nov 2011
Location: NoVa The "burg"
Photos: Gallery
Posts: 899
Original Poster
QuoteOriginally posted by milesy Quote
Out of interest what did you use to test the focus .. I found mine seemed a little soft at first but i think it was the noise reduction being a bit heavy handed in camera

Sent from my HTC Legend using Tapatalk 2
I made a focus chart, and then tripod. Tested it with the 28 - 75 tammy, and then did catch in focus with the 50 1.7
I shoot raw with everything turned off. noise reduction. shadow, DR were off.

QuoteOriginally posted by Docrwm Quote
Sorry about the K-5. I've been there, had to get 3 Tamron 70-200s sent to me for one to a) work at all, and b) not have serious misalignment problems. For a BNIB item I say return it and get another. Good luck.
D: it's frustrating, cause I needed it for an event, so I was stuck with the k01 (Surprisingly it was an awesome backup) I tried shooting with the k5, but I didn't even bother cause of the AF problem.. Should I return it and get it from say adorama and B&H? or should I risk it again and get it from them?


QuoteOriginally posted by dtmateojr Quote
Update to the latest firmware.
Ok will try to do that. Currently it has 1.01
01-08-2013, 08:25 PM   #7
Site Supporter
KB1SFVE3's Avatar

Join Date: Nov 2012
Location: Sarnia, Ontario / Port Huron, Michigan
Photos: Gallery | Albums
Posts: 69
QuoteOriginally posted by kaiserz Quote
I made a focus chart, and then tripod. Tested it with the 28 - 75 tammy, and then did catch in focus with the 50 1.7
I shoot raw with everything turned off. noise reduction. shadow, DR were off.



D: it's frustrating, cause I needed it for an event, so I was stuck with the k01 (Surprisingly it was an awesome backup) I tried shooting with the k5, but I didn't even bother cause of the AF problem.. Should I return it and get it from say adorama and B&H? or should I risk it again and get it from them?




Ok will try to do that. Currently it has 1.01
First, I'd give the dealer that sold it to you a shot at trying to fix things. Chances are they are probably not even aware that the unit is defective.

I've owned and operated a number of businesses in the past. And I've always appreciated customers giving me the opportunity to make things right. That's because It's been shown that for every person that complains to a seller about an issue, there are 25 more who don't. Most often, those 25 will simply tell others (as you are doing here in a public forum) about their issues without even giving the merchant a chance to fix things.

Any merchant who wants to stay in business can ill afford such negative advertising. They know that if such negative advertising continues unchecked, they won't be in business for very much longer.

So, again, I strongly suggest you give the merchant who sold you the camera a chance to exceed your expectations. I'd first try calling them on the phone or sending them an e-mail with your concerns. If they don't reply (or fix things to your satisfaction) THEN it might be time for something else.
01-08-2013, 08:31 PM   #8
Veteran Member
Docrwm's Avatar

Join Date: Sep 2010
Location: Somewhere in the Southern US
Photos: Gallery | Albums
Posts: 11,275
QuoteOriginally posted by kaiserz Quote
I made a focus chart, and then tripod. Tested it with the 28 - 75 tammy, and then did catch in focus with the 50 1.7
I shoot raw with everything turned off. noise reduction. shadow, DR were off.

D: it's frustrating, cause I needed it for an event, so I was stuck with the k01 (Surprisingly it was an awesome backup) I tried shooting with the k5, but I didn't even bother cause of the AF problem.. Should I return it and get it from say adorama and B&H? or should I risk it again and get it from them?

Ok will try to do that. Currently it has 1.01
Firmware update is a MUST, the improvements are significant IMHO from 1.01.

I originally went with another seller and then with Amazon. The trick for me was that the first Amazon package was sent UPS and looked like it had been used as a football (I posted pics here). I complained to Amazon about UPS and they sent the 2nd copy Next Day Air - Early Morning Delivery at no extra charge and the box looked like it had never been touched by human hands. Since then I have paid the extra for 1 day delivery on camera gear (when available) and read online that those packages receive MUCH gentler treatment.

Good luck.

01-08-2013, 08:34 PM   #9
Veteran Member




Join Date: Aug 2011
Location: Niagara
Photos: Gallery | Albums
Posts: 792
QuoteOriginally posted by kaiserz Quote
I made a focus chart, and then tripod. Tested it with the 28 - 75 tammy, and then did catch in focus with the 50 1.7
I shoot raw with everything turned off. noise reduction. shadow, DR were off.



D: it's frustrating, cause I needed it for an event, so I was stuck with the k01 (Surprisingly it was an awesome backup) I tried shooting with the k5, but I didn't even bother cause of the AF problem.. Should I return it and get it from say adorama and B&H? or should I risk it again and get it from them?




Ok will try to do that. Currently it has 1.01
Jeez, sounds like new "old stock" given that firmware. Send it back
01-08-2013, 08:36 PM   #10
Veteran Member
Docrwm's Avatar

Join Date: Sep 2010
Location: Somewhere in the Southern US
Photos: Gallery | Albums
Posts: 11,275
QuoteOriginally posted by Franky2step Quote
Jeez, sounds like new "old stock" given that firmware. Send it back
I don't know of a Pentax camera that has shipped with newer firmware. I'm open to more information but my K-5 had 1.01 months after several updates, my Q had the older firmware, and my K-01 had the older firmware in it too.
01-08-2013, 08:46 PM   #11
Senior Member
ChrisTrevino's Avatar

Join Date: May 2012
Location: Ecorse, MI
Photos: Gallery
Posts: 123
My Tamron 28-75 is at -5 and the K-5 at +-0. In my case the issue was the lens and not the body.

My 1st random question would be, are you testing in Live View? Which focusing mode is it on? Contrast/Face/Focus Point

When focusing in the Viewfinder is the Diopter set correctly for your eyes? I would actually need 1 more click to the right for mine to be correct for my sight. Unfortunately it won't go that far so I get it as close as I can and guess +/-

I'd test with only the center focus point and adjust increments of +/- 1 at a time. I tried adjusting too far when I 1st got the camera and it took me a while to get it correct at -5 with my Tamron 28-75. Eventually I just started at -10 and backed up 1 at a time until it was right. You could simply test with the 50mm f/1.7, get the diopter how u want it, then focus to what you believe is in focus via the viewfinder and then adjust the camera to match it. if you never manage to get it to beep based on what your eyes say is in focus I'd get a replacement.
01-08-2013, 08:48 PM   #12
Veteran Member
kaiserz's Avatar

Join Date: Nov 2011
Location: NoVa The "burg"
Photos: Gallery
Posts: 899
Original Poster
Updated the firmware. And still not good. I'm gonna send it back tomorrow. I have a feeling that the reason it's acting up like this is because of how they (Buydig's crew) took care of the camera for shipping. I'm thinking of just spending the extra $ and order it from adorama. or I can just get it from my local camera store, but they won't accept returns, (I asked if they can make sure that the camera I'm gonna buy doesn't have any front/back AF issues, but they said they can't do that cause they're gonna put shutter counts on it )

Whatchu guys think? Ask if I can get it exchanged? or get a refund and get it from adorama/local store?
01-08-2013, 08:58 PM - 1 Like   #13
Veteran Member
Docrwm's Avatar

Join Date: Sep 2010
Location: Somewhere in the Southern US
Photos: Gallery | Albums
Posts: 11,275
QuoteOriginally posted by kaiserz Quote
Updated the firmware. And still not good. I'm gonna send it back tomorrow. I have a feeling that the reason it's acting up like this is because of how they (Buydig's crew) took care of the camera for shipping. I'm thinking of just spending the extra $ and order it from adorama. or I can just get it from my local camera store, but they won't accept returns, (I asked if they can make sure that the camera I'm gonna buy doesn't have any front/back AF issues, but they said they can't do that cause they're gonna put shutter counts on it )

Whatchu guys think? Ask if I can get it exchanged? or get a refund and get it from adorama/local store?
With a no returns policy your local camera store is shooting themselves in the foot. Sorry but both the places I dealt with for my 70-200 had solid return policies or I would never, ever, under any circumstances have bought from them. Go with Adorama or B&H.
01-08-2013, 09:14 PM   #14
Veteran Member
kaiserz's Avatar

Join Date: Nov 2011
Location: NoVa The "burg"
Photos: Gallery
Posts: 899
Original Poster
QuoteOriginally posted by Docrwm Quote
With a no returns policy your local camera store is shooting themselves in the foot. Sorry but both the places I dealt with for my 70-200 had solid return policies or I would never, ever, under any circumstances have bought from them. Go with Adorama or B&H.
Thank you sir. I'm just wondering, when you got your k5, did you ever needed to micro adjust it out from the box?
01-08-2013, 09:50 PM   #15
Veteran Member
kaiserz's Avatar

Join Date: Nov 2011
Location: NoVa The "burg"
Photos: Gallery
Posts: 899
Original Poster
QuoteOriginally posted by ChrisTrevino Quote
My Tamron 28-75 is at -5 and the K-5 at +-0. In my case the issue was the lens and not the body.

My 1st random question would be, are you testing in Live View? Which focusing mode is it on? Contrast/Face/Focus Point

When focusing in the Viewfinder is the Diopter set correctly for your eyes? I would actually need 1 more click to the right for mine to be correct for my sight. Unfortunately it won't go that far so I get it as close as I can and guess +/-

I'd test with only the center focus point and adjust increments of +/- 1 at a time. I tried adjusting too far when I 1st got the camera and it took me a while to get it correct at -5 with my Tamron 28-75. Eventually I just started at -10 and backed up 1 at a time until it was right. You could simply test with the 50mm f/1.7, get the diopter how u want it, then focus to what you believe is in focus via the viewfinder and then adjust the camera to match it. if you never manage to get it to beep based on what your eyes say is in focus I'd get a replacement.
Thanks, but yeah, I'm really upset cause I do know that my lenses are spot-on, on my k7 and then on the k5 they're all off. And your question is not random at all, diopter not being calibrated to one's eyesight is a very common mistake, but that is not the case in mine. I've been doing this for a while now and I do know what to look for (: and also my camera doesn't beep when it gets a lock in focus, I hate that beep sound, so I always turn it off.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
af, box, camera, dslr, k-5, k-5 ii, k-5 iis, k5, package, pentax, pentax k-5, repairs
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Just got myself a D FA 100mm F2.8 Macro WR, wow ! Matchete Pentax SLR Lens Discussion 19 07-09-2012 08:16 AM
Just got my K5 wombatwal Pentax K-5 12 09-21-2011 06:36 AM
Just got myself a 500mm f8 m42! ismaelg Pentax SLR Lens Discussion 7 09-15-2010 01:59 PM
G'day all ... just got myself a K-7 PanterA Welcomes and Introductions 8 06-30-2010 03:30 PM
Just got myself an ME Super wshi Pentax Film SLR Discussion 17 05-02-2010 11:10 AM



All times are GMT -7. The time now is 08:55 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top