Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
07-10-2015, 01:54 AM - 1 Like   #46
New Member




Join Date: Mar 2013
Location: Weimar, Germany
Photos: Albums
Posts: 22
Original Poster
QuoteOriginally posted by bobD Quote
Sorry to revive an old thread.

Having searched for several days this is the first thread I've found where with contributors having such high level insights into the workings of tethering, Linux, and Pentax..

I have recently acquired a K10D that I need to run tethered using Linux. (Ubuntu)
Unfortunately it will not work with Pktriggercord nor the much older Pkremote.
I had suspected a GTK problem, as smigol had noted with their K10D, until I tried my K200D with the same set up and it worked just fine.

I suspect that, with K10D firmware 1.20 and beyond, the introduction of compatibility with Pentax's own 'Remote Assistant software has broken the Linux operability somehow.

My K10D is running firmware 1.31 which can no longer be downgraded and so I cannot test this.

Pktether does work without any problems but can't be run using Wine (no usb support)
I have tried running it using WinXP in Virtualbox on Ubuntu but there seems to be a known issue in VBox where their claimed usb 2.0 only transfers at 1.1 speeds. This then is also not a workable option.

Has anyone suggestions ?
or light to shed upon this conundrum ?
Comments most welcome..(excepting.."buy a new camera" )
Have you tried the latest version of pktriggercord? The newest version 0.82.02 has just appeared ~10 days ago, so you might have missed that. In addition I'd strongly recommend using the command line interface pktriggercord-cli for testing.

If it does not work, and otherwise pktether handles your camera/firmware properly, there is a good chance to get the missing pieces into pktriggercord as well. The author has been very helpful when I asked for supporting my K5IIs some two years ago and you should not hesitate to contact him (see project homepage pkTriggerCord). The K10D has been a supported camera before, but as you noted major firmware change might have introduced changes in low-level scsi communication.

Thomas

07-10-2015, 03:53 AM   #47
Veteran Member




Join Date: Nov 2008
Location: Waikikamukau
Photos: Albums
Posts: 959
Thanks for the reply Thomas.

Yes I started with the very latest Pktriggercord and have tried several older versions and on several Ubuntu versions just in case.
All those work with my K200D but not the K10D.

The K200D is mostly a K10D under the hood and both cameras work with PKtether.
Thus we can probably dismiss hardware and Pktriggercord as being the problem which leaves only the firmware and, most logically, the Remote Assistant compatibility in the K10D as being the hurdle.

I had hoped it would be something simpler that perhaps even I could fix.

I have just emailed Andras the details and will follow up your suggestion of using the cli option tomorrow.
I guess I should have started Pktriggercord from a terminal and looked for what errors it is throwing..... I will try that tomorrow too.
07-10-2015, 04:55 AM   #48
New Member




Join Date: Mar 2013
Location: Weimar, Germany
Photos: Albums
Posts: 22
Original Poster
QuoteOriginally posted by bobD Quote
...
I have just emailed Andras the details and will follow up your suggestion of using the cli option tomorrow.
I guess I should have started Pktriggercord from a terminal and looked for what errors it is throwing..... I will try that tomorrow too.
Indeed, that is a good idea!
Would be nice if you could post any progress regarding your issue (even if it is somewhat off-topic). Good luck!
07-11-2015, 08:26 PM   #49
Loyal Site Supporter




Join Date: Sep 2006
Location: Texas
Photos: Gallery | Albums
Posts: 23,769
I read this entire thread, and don't understand a damn thing in it. All it did was make me feel dumber than I already am on this sort of technical expertise.
Only posted to say you guys are very intelligent and I am glad you are here.....it is good to know we have such minds at this place in case we need help.

From an old squirrel shooter, that knows little about the technicalities of cameras.....Best Regards!

07-29-2015, 12:06 AM   #50
Veteran Member




Join Date: Nov 2008
Location: Waikikamukau
Photos: Albums
Posts: 959
Update... solved for the K10d tethering...
https://www.pentaxforums.com/forums/groups/197-pentax-linux/4107-k10d-tetheri...#gmessage55679
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
bulb, camera, dslr, exposure, exposures, images, k-5, k-5 ii, k-5 iis, k5, mode, pentax k-5, time
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Is Histogram RAW or JPG? w1wbz Visitors' Center 5 07-01-2013 08:52 AM
K5 RAW Preview Image is Desaturated/Overexposed, RAW Correct. WTF? Epoch of Entropy Pentax K-5 15 11-15-2012 10:47 AM
PDCU: overwrite RAW or save altered RAW-file Alfie Digital Processing, Software, and Printing 4 09-27-2012 09:33 PM
why not in raw? bull drinkwater Pentax Medium Format 4 06-20-2012 04:28 PM
Why do RAW my RAW images not look great... pjthiel Digital Processing, Software, and Printing 23 05-17-2011 07:00 AM



All times are GMT -7. The time now is 05:14 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top