Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
07-25-2013, 07:36 PM   #16
Pentaxian
Paul the Sunman's Avatar

Join Date: Aug 2011
Location: Melbourne
Photos: Gallery
Posts: 1,122
My experience is that the Metz 52 AF-1 works perfectly on the K5 hotshoe, but does not communicate correctly with the camera in slave P-TTL mode. It overexposes by many stops! However, it works absolutely perfectly on my son's K30.

In order to get it to expose properly in slave P-TTL mode with the flash quite close to the subject, I found I had to:
1. Correct the 52 AF-1 by two stops (-2 EV)
2. Correct the camera's built-in flash by -2EV in the flash settings; and
3. Set the camera sensitivity correction to -2 EV.
All three of these are usually necessary; I set them up as one of the programmable User modes. With the flash much further away, these corrections were too extreme, and could be dialled back somewhat.

I wasn't sure if this was just my K5 behaving this way. As I said, it works fine with the K30. However, today I tried it with another K5 in a camera repair shop, and the result was the same; extreme overexposure.

So, it seems the 52 AF-1 and K5 don't communicate properly. I hope this is something that will be corrected with a Metz firmware update at some stage (there has been no new firmware release for the 52 AF-1 since it came on the market). Is anyone at Metz listening?

By the way, does anyone understand why (according to the diagram in the back of the manual) the 52 AF-1's wireless TTL sensor is on the BACK of the unit, just under the touchscreen?


Last edited by Paul the Sunman; 07-25-2013 at 09:40 PM. Reason: Correction
08-01-2013, 06:55 AM   #17
Pentaxian
Class A's Avatar

Join Date: Aug 2008
Location: Wellington, New Zealand
Posts: 8,934
I understand that flash overexposure issues are the fault of the K-5, not that of any Metz flash.

The K-5 flash overexposure bug is well-known and apparently even the first K-5 II firmwares were affected. It appears that the V1.03 firmware for the K-5 II was the first to address the bug.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, k-5, k-5 ii, k-5 iis, k5, pentax k-5
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pentax K5 with Metz 52 AF-1 flash ikongraphics Troubleshooting and Beginner Help 6 03-17-2013 09:55 AM
K-30 and external flash: Metz 50/52 Sigma 610 SG or? bcorson Pentax K-30 & K-50 13 12-31-2012 05:38 AM
K5 and Metz 58 non consistant exposure in slave mode digitaddict Troubleshooting and Beginner Help 2 10-30-2012 11:14 AM
New Metz Mecablitz 52 Flash SyncGuy Flashes, Lighting, and Studio 5 09-25-2012 10:31 AM
Just got my K5! and 18-135 and Metz 50 Af-1 Javaslinger Pentax K-5 21 01-22-2011 07:51 AM



All times are GMT -7. The time now is 03:14 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top