Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
04-01-2013, 04:14 AM   #1
Pentaxian
RobG's Avatar

Join Date: Dec 2009
Location: Canberra
Photos: Gallery | Albums
Posts: 3,486
K-5iis 1.03 Firmware stability (or lack of it)

I had the rare opportunity of a pair of very small birds close up this afternoon, but after about ten frames at the high shutter release setting, the camera froze requiring the battery to be removed. I don't ever remember the K200 freezing, and maybe only one time the K7 froze, but the K5iis seems to freeze a lot when the CPU is working hard. First it was in-camera HDR (which seems to have been fixed with the first firmware update) and now high speed shutter. Also, the focus lock with the 1.03 firmware seems much worse than earlier firmware. When I first got the camera, its ability to achieve a focus lock with the DA55-300 was brilliant and now it's atrocious. I missed a lot of photos today because the camera wound the focus all the way in and out and still couldn't lock on a bird silhouetted against the sky. Yes, the light was poor, but the contrast was high, and the K5ii is supposed to focus in low light.

Is anyone else with a K5iis experiencing the same thing with the 1.03 firmware?


Last edited by RobG; 04-01-2013 at 04:16 AM. Reason: added link
04-01-2013, 07:23 AM   #2
New Member




Join Date: Jan 2013
Photos: Gallery
Posts: 11
QuoteOriginally posted by RobG Quote
I had the rare opportunity of a pair of very small birds close up this afternoon, but after about ten frames at the high shutter release setting, the camera froze requiring the battery to be removed. I don't ever remember the K200 freezing, and maybe only one time the K7 froze, but the K5iis seems to freeze a lot when the CPU is working hard. First it was in-camera HDR (which seems to have been fixed with the first firmware update) and now high speed shutter. Also, the focus lock with the 1.03 firmware seems much worse than earlier firmware. When I first got the camera, its ability to achieve a focus lock with the DA55-300 was brilliant and now it's atrocious. I missed a lot of photos today because the camera wound the focus all the way in and out and still couldn't lock on a bird silhouetted against the sky. Yes, the light was poor, but the contrast was high, and the K5ii is supposed to focus in low light.

Is anyone else with a K5iis experiencing the same thing with the 1.03 firmware?
I experienced the same hang-ups 2 times, but as for me there was no CPU load. I shot RAW without any in-camera processing.
04-01-2013, 02:23 PM   #3
Pentaxian
RobG's Avatar

Join Date: Dec 2009
Location: Canberra
Photos: Gallery | Albums
Posts: 3,486
Original Poster
QuoteOriginally posted by Ayrat Quote
I experienced the same hang-ups 2 times, but as for me there was no CPU load. I shot RAW without any in-camera processing.
Glad I'm not the only one. Interesting to know that it is happening even when shooting only RAW.
04-01-2013, 04:01 PM   #4
New Member




Join Date: Dec 2012
Location: Rockford, MI
Posts: 11
Same here. I updated from version 1.01 and was hoping this update would clear up the freeze issue. Unfortunately I think it's worse. I was out shooting my sons RC truck when it froze up 3 times in a couple minute period. The good news is that after that a got off a 100 shots or so with no problems. I'm still loving this camera though.

04-01-2013, 06:26 PM   #5
Pentaxian
RobG's Avatar

Join Date: Dec 2009
Location: Canberra
Photos: Gallery | Albums
Posts: 3,486
Original Poster
QuoteOriginally posted by jsboening Quote
Same here. I updated from version 1.01 and was hoping this update would clear up the freeze issue. Unfortunately I think it's worse. I was out shooting my sons RC truck when it froze up 3 times in a couple minute period. The good news is that after that a got off a 100 shots or so with no problems. I'm still loving this camera though.
I love the results from the camera when it works as well! Having it hang is frustrating however, especially if it happens during a brief opportunity to take a photo. Have you noticed any change in the AF performance?
04-01-2013, 06:52 PM   #6
New Member




Join Date: Dec 2012
Location: Rockford, MI
Posts: 11
I have not notice any change in the autofocus. I mainly use the selectable autofocus or the center autofocus. Any idea if I should have installed v1.02 first? I'm wondering if there was something in that package I'm missing by skipping right to v1.03. Thoughts?
04-01-2013, 07:05 PM   #7
Pentaxian
RobG's Avatar

Join Date: Dec 2009
Location: Canberra
Photos: Gallery | Albums
Posts: 3,486
Original Poster
QuoteOriginally posted by jsboening Quote
I have not notice any change in the autofocus. I mainly use the selectable autofocus or the center autofocus. Any idea if I should have installed v1.02 first? I'm wondering if there was something in that package I'm missing by skipping right to v1.03. Thoughts?
I normally use centre AF myself, but yesterday I found I could only get focus lock using multipoint AF. On the Pentax web page for the update it says that the 1.03 update includes the 1.02 updates so no need to install 1.02.
04-01-2013, 07:48 PM   #8
New Member




Join Date: Dec 2012
Location: Rockford, MI
Posts: 11
Thanks for clarifying that. I was hoping it was a software issue. I never had a problem with it freezing up before the current update so maybe it's something that will get worked out in the future. In any case is still a wonderful camera that I enjoy using.

04-02-2013, 02:38 PM   #9
Pentaxian
RobG's Avatar

Join Date: Dec 2009
Location: Canberra
Photos: Gallery | Albums
Posts: 3,486
Original Poster
QuoteOriginally posted by jsboening Quote
Thanks for clarifying that. I was hoping it was a software issue. I never had a problem with it freezing up before the current update so maybe it's something that will get worked out in the future. In any case is still a wonderful camera that I enjoy using.
I'm hoping that a future update improves the stability and restores the AF performance. Agreed - the results when the camera works are awesome. The only other odd behaviour is that it doesn't work with my ring flash while the K7 and K200 are fine.
04-06-2013, 06:24 AM   #10
Pentaxian




Join Date: Jul 2011
Location: Eastern Oregon
Posts: 604
I had 1 freeze in 400 images on FW 1.02, so far it's been OK with 1.03.

And I hadn't noticed any difference in AF with 1.03.
04-06-2013, 01:16 PM   #11
New Member




Join Date: Aug 2011
Location: California
Posts: 21
Hi all. My Pentax iis still has firmware 1.00 on it. I don't use bounce flash, and I just use the standard 18mm-55mm zoom and the 1.4mm fixed. Are there other areas where I might see benefits from upgrading to a more recent firmware rev? I hesitate to proceed with just as part of regular maintenance, give some of your claims about freezes.

Thanks!

-Kurt
04-07-2013, 07:46 PM   #12
Pentaxian
RobG's Avatar

Join Date: Dec 2009
Location: Canberra
Photos: Gallery | Albums
Posts: 3,486
Original Poster
QuoteOriginally posted by Kurt Euler Quote
Hi all. My Pentax iis still has firmware 1.00 on it. I don't use bounce flash, and I just use the standard 18mm-55mm zoom and the 1.4mm fixed. Are there other areas where I might see benefits from upgrading to a more recent firmware rev? I hesitate to proceed with just as part of regular maintenance, give some of your claims about freezes.
The camera froze for me when doing in-camera HDR on the 1.00 firmware. Updating to 1.01 seemed to resolve this although it's not mentioned as a fix in the notes for the update. The camera is still freezing sometimes on 1.03, but I can't say for sure exactly what is causing the freezes. Personally I'm not sure that there's any significant improvements I have observed other than the initial update fixing the problem with HDR. In fact, the AF performance seems to have become worse - at least with the DA55-300. However, I haven't done anything like a significant amount of testing, and I don't have the means to do a side-by-side comparison of the AF behaviour at 1.00 and 1.03. At the moment I'd say stick with 1.00 if you don't need the LCD contrast adjustment feature in 1.01. I've mainly been upgrading because I have been hoping that the claimed "improved stability" will result in the elimination of freezes.
02-21-2014, 01:56 PM   #13
New Member




Join Date: Dec 2008
Location: Mèxico
Photos: Gallery
Posts: 5
HELP HELP my friends

Please HELP. My k5iis doesn´t allow to update firmware (is running 1.0), when i turn on the camera pressing de menu buton just turn on but doesn´t download de firmware?!!
Thank you inadvance.

Sorry for my english
02-21-2014, 08:17 PM   #14
Site Supporter
sholtzma's Avatar

Join Date: Sep 2007
Location: Salisbury, NC
Photos: Gallery | Albums
Posts: 996
QuoteOriginally posted by optiosv Quote
Please HELP. My k5iis doesn´t allow to update firmware (is running 1.0), when i turn on the camera pressing de menu buton just turn on but doesn´t download de firmware?!!
Thank you inadvance.

Sorry for my english
Where are you in the process? Have you downloaded the most recent firmware from Ricoh/Pentax website?
02-23-2014, 02:44 AM   #15
Pentaxian
RobG's Avatar

Join Date: Dec 2009
Location: Canberra
Photos: Gallery | Albums
Posts: 3,486
Original Poster
FWIW I don't recall having a single time when the K5iis has needed a battery removal reset since 1.06.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, firmware, focus, k-5, k-5 ii, k-5 iis, k5, light, lot, pentax k-5, shutter
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Number of freezes since firmware 1.03 secateurs Pentax K-5 67 03-18-2014 01:47 PM
K-30 Firmware Update v. 1.03 bluenose Pentax K-30 & K-50 4 03-18-2013 09:07 AM
K-5 IIs firmware 1.03 improves tilt flash overexposure issue bjdavey Pentax K-5 11 03-11-2013 10:42 AM
k-5 firmware same as k-5iis firmware? grant richie Pentax K-5 2 12-09-2012 12:15 PM
K-7 firmware 1.03 Jadran Pentax DSLR Discussion 3 02-17-2010 10:19 AM



All times are GMT -7. The time now is 03:18 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top