Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
04-19-2013, 07:34 AM   #1
New Member




Join Date: Apr 2013
Posts: 6
K-5 II viewfinder issue

I just purchased a new K-5 II and 18-135 lens. When looking through the viewfinder the image is round, about 75% of the area, and surrounded by black. The info at the bottom is visible and full width as expected. This appears to be something related to the viewfinder as live view looks normal.

Any ideas?

04-19-2013, 07:58 AM   #2
Veteran Member




Join Date: Aug 2011
Location: Niagara
Photos: Gallery | Albums
Posts: 792
hmmm, maybe your K-5ii is actually the long awaited K-3 ..........
04-19-2013, 08:01 AM   #3
Pentaxian




Join Date: Jun 2009
Location: GMT +10
Photos: Albums
Posts: 10,828
Have you:
- mounted the lens properly
- put on the hood the right way round
- properly adjusted your viewfinder diopter settings?
04-19-2013, 08:05 AM   #4
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 27,424
Welcome to the Pentax Forums! Vignette in the viewfinder, but not in live view? What does it look like when no lens is mounted?


Steve

04-19-2013, 08:20 AM   #5
New Member




Join Date: Apr 2013
Posts: 6
Original Poster
Thanks for the suggestions. My first thought was the hood, so I removed it altogether. Adjusting the diopter has no effect. Pictures come out normally when viewed on my computer, so that leads me to believe it's not a lens issue.
04-19-2013, 08:24 AM   #6
New Member




Join Date: Apr 2013
Posts: 6
Original Poster
QuoteOriginally posted by stevebrot Quote
Welcome to the Pentax Forums! Vignette in the viewfinder, but not in live view? What does it look like when no lens is mounted?


Steve
With no lens, it's rectangular.
04-19-2013, 08:29 AM   #7
Site Supporter
i83N's Avatar

Join Date: Mar 2009
Location: Lithuania
Photos: Gallery
Posts: 1,154
Try to remove rubber eyepiece from viewfinder
04-19-2013, 09:51 AM   #8
New Member




Join Date: Apr 2013
Posts: 6
Original Poster
The issue appears to be the focus screen. It's loose and floating around inside the body.

04-19-2013, 10:38 AM   #9
Veteran Member
VisualDarkness's Avatar

Join Date: Nov 2011
Location: Uppsala, Sweden
Photos: Gallery
Posts: 4,441
Loose, how? Can you take pics of it? It should be fitted in a hinge frame that you can lower but when closed it should fit snugly.
04-19-2013, 10:55 AM   #10
New Member




Join Date: Apr 2013
Posts: 6
Original Poster
My guess is that the frame wasn't hinged properly. In the picture you can see it flopped down. The focus screen itself was completely unattached and just fell out after removing the lens.
Attached Images
 
04-19-2013, 10:56 AM   #11
Veteran Member
VisualDarkness's Avatar

Join Date: Nov 2011
Location: Uppsala, Sweden
Photos: Gallery
Posts: 4,441
Get the camera replaced, the screen will be junk now and who knows if it damaged something else.
04-19-2013, 11:11 AM   #12
Veteran Member
kcobain1992's Avatar

Join Date: Dec 2010
Location: Bucharest, Romania
Photos: Gallery
Posts: 1,409
Oh God, that's just messed up.
04-19-2013, 05:44 PM   #13
Pentaxian




Join Date: Jun 2009
Location: GMT +10
Photos: Albums
Posts: 10,828
Wow, ugly. Camera must have been thrown around in the box prior to delivery, or something. Get a replacement if you can.
04-19-2013, 06:25 PM   #14
New Member




Join Date: Apr 2013
Posts: 6
Original Poster
I was able to get in back in place, but it still seems a little off. Sending it back for an exchange.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, ii, k-5, k-5 ii, k-5 iis, k5, pentax k-5, viewfinder
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K-5 K-5 II K-5 IIs, e dial issue, Noise Eder Pentax K-5 17 06-03-2014 12:33 AM
New Firmware For K-01, K-30, K-5, K-5 II, K-5 IIs, K-r Adam Pentax News and Rumors 63 02-18-2013 02:04 PM
K-5 II Issue with Photomatix themurth Troubleshooting and Beginner Help 12 01-21-2013 02:14 PM
K-5 ii vs K-5 iis comparison with higher sharpness in K-5 ii kataria0 Pentax K-5 62 12-22-2012 10:12 PM
K 5 cpl and viewfinder issue Extreme G Troubleshooting and Beginner Help 3 08-15-2012 02:54 AM



All times are GMT -7. The time now is 07:22 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top