Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
05-03-2013, 07:16 AM   #1
New Member




Join Date: Apr 2013
Posts: 13
New K5 II won't upgrade the firmware

Although I started in the K5 section I somehow posted this request to the K30 section, so will try again!

Shiny new camera arrived yesterday replacing one of my *ist's
Checked the existing Firmware and it says 1.00
Downloaded 1.04 and followed the instructions
When I press Menu & Switch on, I get the 5 sec Existing Version message then it reverts to normal
Tried several times.
Held Menu button down while the 5 sec msg displayed and kept holding it - NO change
Formatted card in camera and re-tried - NO change
Formatted card again, connected camera via cable and copied file from PC via the cable. - NO change

Suggestions anyone?


05-03-2013, 07:29 AM - 1 Like   #2
Veteran Member




Join Date: Sep 2010
Posts: 466
Is the file Fwdc216b.bin in the root directory of the card?
05-03-2013, 07:54 AM - 1 Like   #3
Senior Member
dboeren's Avatar

Join Date: Feb 2013
Location: Marietta, GA
Photos: Albums
Posts: 148
Maybe your file is somehow corrupted - try downloading it again?
05-03-2013, 07:58 AM - 1 Like   #4
Forum Member




Join Date: Apr 2010
Location: Santa Barbara
Photos: Albums
Posts: 60
Describe "followed the instructions". The Fwdc216b.bin file inside of downloaded k5_2_104.EXE must be (double clicked} uncompressed on PC and Fwdc216b.bin file copied onto the SD card. Sounds like you are copying over the downloaded file instead of the Fwdc216b.bin. BTW, Fuji sends straight bin files, what feels like mailing item with stamp on it instead of boxed...

05-03-2013, 08:15 AM - 1 Like   #5
Pentaxian
RonHendriks1966's Avatar

Join Date: Jan 2009
Photos: Gallery
Posts: 8,714
You have the .bin file in the folder, but it needs to be directly on the card and not in the folder.
05-03-2013, 08:16 AM - 1 Like   #6
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 43,215
QuoteOriginally posted by eLaReF Quote
Although I started in the K5 section I somehow posted this request to the K30 section, so will try again!

Shiny new camera arrived yesterday replacing one of my *ist's
Checked the existing Firmware and it says 1.00
Downloaded 1.04 and followed the instructions
When I press Menu & Switch on, I get the 5 sec Existing Version message then it reverts to normal
Tried several times.
Held Menu button down while the 5 sec msg displayed and kept holding it - NO change
Formatted card in camera and re-tried - NO change
Formatted card again, connected camera via cable and copied file from PC via the cable. - NO change

Suggestions anyone?
Follow these instructions and links and things will definitely work for you

Pentax K-5 II and K-5 IIs Firmware v1.04 - Pentax News - PentaxForums.com

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

05-03-2013, 09:37 AM   #7
New Member




Join Date: Apr 2013
Posts: 13
Original Poster
OK guys
I originally d/loaded k5_2_104.exe from http://www.pentax.jp/english/support/digital/k-5_2_s.html
when run this created a folder on the PC with FWDC216B.BIN in it.
This was copied to the root folder on the SDHC card
That didn’t work
I then d/loaded the zip file from Pentax K-5 II and K-5 IIs Firmware v1.04 - Pentax News - PentaxForums.com as suggested by Adam and extracted the same file from it and repeated the process
That worked!!
Looks like, as dboeren suggested, that my original file was corrupted

Thks for all your help
05-03-2013, 10:14 AM - 1 Like   #8
Senior Member
dboeren's Avatar

Join Date: Feb 2013
Location: Marietta, GA
Photos: Albums
Posts: 148
Glad it's working now, that's the important thing!

05-03-2013, 10:24 AM   #9
Veteran Member
Kobayashi.K's Avatar

Join Date: Mar 2013
Posts: 324
I compared the fwdc216b.bin file from Pentax Japan and from PentaxForums and they have exactly the same size (11,272,192 bytes). So, the Pentax Japan file is definitely not corrupted, which would be very strange indeed. K5-II and K5-IIs mixed up?
05-03-2013, 11:23 AM   #10
New Member




Join Date: Apr 2013
Posts: 13
Original Poster
I can't check, having deleted the original. I gave the links above from my browser history and they are correct
I've seen d/loaded files state a size when the file was actually empty, so I must confess to not trusting downloaded files absolutely, although I know that it can only be a miniscule percentage of the files I have ever downloaded that went wrong.
The file may start correct at it's source, but it is what is finally written to my hard drive that may not be the same.
Yes, I know, with all the protocols, checksums etc. that shouldn't happen, but it does.
Thks again for everyone's input - as dboeren said - It's working
Just need some sunshine so I can go out and give it a good workout

Last edited by eLaReF; 05-03-2013 at 11:43 AM.
05-03-2013, 01:50 PM - 1 Like   #11
Ash
Community Manager
Loyal Site Supporter
Ash's Avatar

Join Date: Mar 2007
Location: Toowoomba, Queensland
Photos: Gallery | Albums
Posts: 22,695
Mistake might have downloaded the IIs update for the II, which won't work (but is so easy to do - I did this myself and wondered why it wouldn't work).
05-04-2013, 12:23 PM   #12
New Member




Join Date: Apr 2013
Posts: 13
Original Poster
I actually did that initially, but realised before I got too far down the path so never created the file on the card
You're correct though - It's easy!
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
cable, camera, card, change, dslr, firmware, k-5, k-5 ii, k-5 iis, k5, menu, pentax k-5
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K5 -II sensor upgrade... plainsman Pentax K-5 2 03-24-2013 08:02 AM
K100D firmware update - now won't power up bjcwheeler Pentax DSLR Discussion 6 04-26-2012 04:10 PM
K5 won't turn on! ozlizard Pentax K-5 10 03-14-2012 02:35 PM
K5 firmware upgrade which version? selar Pentax K-5 15 11-23-2011 08:58 AM
k7 won't work after firmware upgrade obxeye Troubleshooting and Beginner Help 5 02-17-2010 02:47 AM



All times are GMT -7. The time now is 02:45 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top