Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
06-15-2013, 08:34 PM   #1
Senior Member
Halco's Avatar

Join Date: Aug 2009
Posts: 123
K-5 Underexposing Question

Forgive this potentially obvious question, but as a new K-5 user I feel I must get some input. I'm coming from using a 645NII and K-X tandem. I used a Sigma APO 70-200mm 2.8 with the K-X, which I am now using on the K-5. The K-X was always very consistent with providing consistent, correct exposure with this lens.

Using the lens and a Tamron 17-50/2.8 zoom on the K-5 however, I seem to be consistently getting shots 2-3 stops underexposed and having to use heavy exposure comp to get near correct exposure (matrix meter). When compared to the 645 and K-X under the same conditions and ISO the 'correct' settings on the K-5 seem silly. I essentially shoot the exact same scene constantly, and have done so thousands of times before, so this is not an experience issue.

06-15-2013, 08:51 PM   #2
Pentaxian




Join Date: Jun 2009
Location: GMT +10
Photos: Albums
Posts: 10,576
I used to have the same issue with the Tamron 17-50 and the K-5 (and my K-x DSLR, fwiw), although the under-exposure was never more that 0.5 to 1 stop. However in a recent shoot involving literally hundreds of shots with the K-5 and the Tamron 17-50 in daylight (and using flash too), the problem wasn't there at all. I was shooting the exact same locations as well that I used to have problems with last year.

All I can suggest is to perhaps update to the latest K-5 firmware, and maybe try centre-weighted metering for a while. Perhaps also check under the camera menu options that you haven't set the AE metering to follow the AF point, or something like that.

Another suggestion would be to open up a problem image in Photome (see image below) and see what the AE point graphical display shows about the LV of the scene. And maybe also just generally review the EXIF data to see what the camera is recording for your problem images.


Last edited by rawr; 06-15-2013 at 09:17 PM.
06-16-2013, 12:51 AM   #3
Pentaxian
adwb's Avatar

Join Date: Sep 2009
Location: Bristol UK
Photos: Gallery
Posts: 1,631
My k5 also underexposes with any lens compaired to previously owned Kr,Kx and now k30, but not by 2 stops more like 1 and it's not consistent either, some are worse than others.

I have a feeling that all k5 bodies under expose a bit as there have been loads of comments on this before.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, exposure, k-5, k-5 ii, k-5 iis, k-x, k5, lens, pentax k-5, question
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
New Firmware For K-01, K-30, K-5, K-5 II, K-5 IIs, K-r Adam Pentax News and Rumors 63 02-18-2013 02:04 PM
K-5 IIs question Wingincamera Pentax K-5 6 10-26-2012 11:25 PM
K-5 Warranty Question EsBee Pentax K-5 9 09-15-2012 10:53 PM
K-x metering issue (underexposing shots) legacy Pentax DSLR Discussion 13 07-23-2011 01:42 PM
Metz 48 underexposing on Pentax k-x elg Flashes, Lighting, and Studio 12 01-23-2011 09:24 AM



All times are GMT -7. The time now is 03:31 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top