Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-12-2013, 01:40 AM   #1
New Member




Join Date: Sep 2012
Posts: 3
Firmware 1.15 breaks

ARRGGHH !
I have just applied the new version of the firmware (1.15), and now my K5 only displays 'F--' and '100'.
Any idea ?

09-12-2013, 01:43 AM   #2
Pentaxian
Clavius's Avatar

Join Date: Feb 2011
Location: De Klundert
Photos: Gallery
Posts: 4,115
Dang, that sucks! Try doing a ~5 minute battery pull.

Do you already one of the new HD ltds?
09-12-2013, 01:45 AM   #3
Pentaxian




Join Date: Jun 2009
Location: GMT +10
Photos: Albums
Posts: 10,596
Did you install the firmware properly, following all the instructions in the readme.txt?

What happens if you power down without a SD card, then re-start holding the back 'menu' button? Do you see your current firmware version?
09-12-2013, 01:52 AM   #4
New Member




Join Date: Sep 2012
Posts: 3
Original Poster
QuoteOriginally posted by rawr Quote
Did you install the firmware properly, following all the instructions in the readme.txt?
Yes, I think so. The 'COMPLETE' displayed after updating.
QuoteOriginally posted by rawr Quote
What happens if you power down without a SD card, then re-start holding the back 'menu' button? Do you see your current firmware version?
Yes:
PENTAX K-5
VER:1.15

09-12-2013, 02:03 AM   #5
Pentaxian
calsan's Avatar

Join Date: Nov 2008
Location: Perth, Australia
Photos: Gallery
Posts: 1,367
Are you using a lens with an aperture ring? Check "using aperture ring" custom setting. Otherwise, check aperture ring is set to A.
09-12-2013, 04:43 AM   #6
New Member




Join Date: Sep 2012
Posts: 3
Original Poster
QuoteOriginally posted by calsan Quote
Are you using a lens with an aperture ring? Check "using aperture ring" custom setting. Otherwise, check aperture ring is set to A.
Thanks a lot calsan !
I use a DA* 16-50, without aperture ring. I removed it and turned the camera on: it works. So I replaced the lens: it still works fine !
09-12-2013, 04:49 AM   #7
New Member




Join Date: May 2013
Posts: 4
Format SD card after update

Be sure to format the SD card after updating is complete.
09-12-2013, 04:55 AM   #8
Pentaxian




Join Date: Nov 2008
Location: Bangalore
Photos: Gallery
Posts: 2,435
QuoteOriginally posted by brulain Quote
Thanks a lot calsan !
I use a DA* 16-50, without aperture ring. I removed it and turned the camera on: it works. So I replaced the lens: it still works fine !
Generally a good idea to load defaults/factory reset after firmware upload.

09-12-2013, 05:47 AM   #9
Veteran Member
mysterick's Avatar

Join Date: Oct 2006
Location: 44266
Photos: Gallery | Albums
Posts: 418
Ricoh has taken it down. The highest on the site is v. 1.14. But on the Ricoh.jp site is.

Last edited by mysterick; 09-12-2013 at 06:05 AM. Reason: more info
09-12-2013, 06:03 AM   #10
Site Supporter




Join Date: Jan 2008
Location: Fly-over, USA
Photos: Gallery
Posts: 1,172
QuoteOriginally posted by mysterick Quote
Ricoh has taken it down. The highest on the site is v. 1.14.
You sure...? Check out...

Latest K-5 Firmware Update : Software Downloads | RICOH IMAGING

Cheers...M
09-15-2013, 07:53 AM   #11
Site Supporter
grahamcoad's Avatar

Join Date: Nov 2009
Location: West Cornwall
Photos: Gallery | Albums
Posts: 117
Just updated here in Cornwall, UK, all went well, custom features still as before. Everything seeming slick.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, firmware, k-5, k-5 ii, k-5 iis, k5, pentax k-5
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
*** FYI for K-5 new firmware 1.15 *** abmj Pentax K-5 35 09-16-2013 05:21 AM
Focus Peaking for the Q with Firmware 1.1 pico Pentax Q 113 12-20-2012 06:51 PM
K7 Firmware Upgrade to ver 1.1 Problem David Lee Visitors' Center 2 10-19-2011 09:21 PM
Travel Cedar Breaks - Pt 1 SpecialK Post Your Photos! 5 07-09-2011 08:03 PM
Don't update to the 1.01 firmware! It breaks autofocus jms698 Pentax DSLR Discussion 45 10-01-2008 01:22 PM



All times are GMT -7. The time now is 03:17 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top