Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-13-2013, 08:42 PM   #1
Junior Member




Join Date: Oct 2007
Location: Chicago, Illinois
Photos: Gallery
Posts: 39
K5 IIs series of problems on a shoot

So I have been loving my Pentax K5 IIs since buying it back in December. About 2 weeks ago I was using it on a birthday party/surprise wedding shoot (don't ask) and the strangest thing happened: after having changed lenses and going to shoot, I discovered that the viewfinder and top LCD displays were no longer showing me the EV comp information. It was showing me the symbol, but not the +.3 -.3 numbering that is usually there when using the front dial. (which is how I have it set up when in AV mode)

That was really odd. Then it seemed that it was not adjusting the EV at all. I could not see a difference from one shot to the next with an adjustment. I tried using the EV button on top, but it was not doing anything. It would not work. Then I noticed that my auto ISO was no longer working, and was stuck on one setting.

Then the autofocus on my DA*50-135 decided to stop working. It had been sent in for the SDM focus problem 9 months after purchase a couple of years before, and had been fine for the most part ever since. Had to go to manual focus for that.

I tried turning it on and off, no luck. I removed my grip and battery, no luck. I removed the lens and put a wide angle lens on, and the auto focus started working again. I had to switch to manual mode using manual focus for a while to lock it down in one spot. I reinstalled the DA* 50-135 and the auto focus was back. Then a few minutes later I tried going back to AV and found that the display was working again.

So for at least 10-15 minutes I could not get my camera to behave very well, and then it changed its mind and seemed fine.

It all happened again for a brief time at another shoot last week, but again mysteriously resolved itself.

Both shoots were hundreds of shots, the first one was just over 900 frames taken.

I have a number of wedding and other shoots coming up this month, so I don't have time to send this off for warranty repair right now. I have my old GX10 as a backup body though I am loathe to use it if I don't have to. If this thing starts acting up again however I I'll have no choice.

SO, the question to you fellow Pentax users is simple: what do you think is going on here? Is my body flakey? Dd my lens start this? Anyone else have something like this before? I would love to hear theories...

I have another question regarding remaining shot counts on camera, but will ask that in a separate post.

Thanks in advance.

09-13-2013, 10:01 PM   #2
Veteran Member
gbeaton's Avatar

Join Date: Apr 2012
Location: Montreal
Photos: Gallery | Albums
Posts: 342
Sounds like dirty contacts at the lens mount. Try cleaning with a q-tip.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
auto, body, camera, dslr, focus, k-5, k-5 ii, k-5 iis, k5, lens, pentax k-5, shoot
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
pentax k5 iis $999 on Amazon pearsaab Pentax Price Watch 23 05-09-2013 05:20 PM
Weird and scary glitch on monitor during Live View on K5 IIs wafflehaus Pentax K-5 14 03-15-2013 08:19 AM
Anyone Pre-order a K5-II or IIs yet? Eric Auer Pentax K-5 97 11-09-2012 01:44 AM
Manual white balance problems on K5 2grahamb Pentax K-5 10 09-29-2011 01:06 AM
A little video and pictures of Birds all shoot with the K5 vievetrick Pentax K-5 5 12-27-2010 08:32 AM



All times are GMT -7. The time now is 08:51 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top