Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-20-2013, 01:30 PM   #16
Veteran Member
krebsy75's Avatar

Join Date: Jun 2010
Location: Chester County, Pa.
Posts: 804
I just found this thread on the issue: K5II+1.05fw=battery issues?: Pentax SLR Talk Forum: Digital Photography Review

09-21-2013, 06:22 AM   #17
Veteran Member
krebsy75's Avatar

Join Date: Jun 2010
Location: Chester County, Pa.
Posts: 804
De-charging the battery using our spare K-01 did the trick. Our K-5IIs powers up and shows full battery. I tried downgrading the firmware and the camera wouldn't let me.
09-21-2013, 11:07 AM   #18
Site Supporter
Wingincamera's Avatar

Join Date: Oct 2012
Location: Spanaway, WA. USA
Photos: Gallery | Albums
Posts: 550
Just for the record after reading all this I removed the battery from my K-5 II with the new firmware and installed a newly charged battery. No problems. So the problem must be in only some cameras.
09-21-2013, 04:06 PM   #19
Veteran Member
krebsy75's Avatar

Join Date: Jun 2010
Location: Chester County, Pa.
Posts: 804
My K-5IIs worked fine with freshly charged batteries and 1.05 for about 100 clicks.

09-22-2013, 12:07 PM   #20
Veteran Member
alexeyga's Avatar

Join Date: Dec 2008
Location: Montreal, Canada
Posts: 838
Original Poster
The number of affected bodies is clearly very limited, but to what extend - we'd never know. I'm sure that Pentax service centers are receiving a lot of "dead" k5II/s bodies - not all the people have the will/time/knowledge to deal with problems like that. I will need the camera for a trip on 2nd week of November, so I really can't afford sending it into service with an uncertain return date.
09-22-2013, 01:32 PM   #21
Veteran Member
krebsy75's Avatar

Join Date: Jun 2010
Location: Chester County, Pa.
Posts: 804
I'm taking a wait and see approach. I'd rather send it in for service once the problem is acknowledged.
09-25-2013, 04:13 PM   #22
Veteran Member
krebsy75's Avatar

Join Date: Jun 2010
Location: Chester County, Pa.
Posts: 804
I shipped my camera to CRIS. It cost a whopping $35 to ship. Grrrr.
09-26-2013, 06:58 AM   #23
Veteran Member
alexeyga's Avatar

Join Date: Dec 2008
Location: Montreal, Canada
Posts: 838
Original Poster
I'm hanging there for now - will see if the new firmware will solve anything. Haven't heard from Pentax anymore - dead silence... ((( Got in touch with Dan from Pentax Canada though and gave him a detailed description of the problem, perhaps that will lead somewhere...

09-26-2013, 08:11 AM   #24
Veteran Member
krebsy75's Avatar

Join Date: Jun 2010
Location: Chester County, Pa.
Posts: 804
Based on this thread there doesn't seem to be a mass failure. Perhaps our cams were the lucky recipients of a bad batch of something or other.
10-02-2013, 11:15 PM   #25
Pentaxian
Class A's Avatar

Join Date: Aug 2008
Location: Wellington, New Zealand
Posts: 9,047
Hopefully, good news: V1.06 is available.
10-03-2013, 05:53 AM   #26
Veteran Member




Join Date: Jan 2009
Location: Edmonton, Alberta Canada
Posts: 554
I just loaded f 1.06 into my K5IIs and it fixed my wonky battery issue. Thank you Ricoh!

Dale
10-03-2013, 06:04 AM   #27
Veteran Member
krebsy75's Avatar

Join Date: Jun 2010
Location: Chester County, Pa.
Posts: 804
Good for you!!! SUCKS TO BE ME!!! I sent my damn cam to CRIS. I NEVER thought Pentax would have resolved this so quickly. Historically speaking, if course.

I'm happy to see Pentax jumped on this. Puzzled as to why other S users didn't experience this problem.
10-03-2013, 06:13 AM   #28
Veteran Member
alexeyga's Avatar

Join Date: Dec 2008
Location: Montreal, Canada
Posts: 838
Original Poster
I'll do the update first thing when I'll get home tonight - can't wait!!! )))

That being said, after a full discharge/recharge cycle with a new after-market battery my "affected" K5II has decided to work with it even at the full 8.35V out of the charger. Still a dead brick with the OEM battery. Go figure why! ((( Hopefully 1.06 will make me forget about all that mumbo-jumbo!

Lesson to be learned? I guess I won't be so in a hurry to load the latest FW versions anymore... at least no with my Pentax gear.
10-03-2013, 08:19 AM   #29
Site Supporter
Shanti's Avatar

Join Date: Jul 2012
Location: Western Denmark
Photos: Gallery | Albums
Posts: 903
Had similar problems with K5II & orig battery grip...both batteries died at the same time,and meter showed full charge?? after a day long recharge it worked fine again..FW 1.03 I think back then,hope it doesn't happen again
10-03-2013, 02:48 PM   #30
Veteran Member
alexeyga's Avatar

Join Date: Dec 2008
Location: Montreal, Canada
Posts: 838
Original Poster
Bloody hell!!! She's alive!!! )))

On a positive note - I've got a free battery, even if it's an aftermarket one... )))
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
battery, brick, camera, dslr, k-5, k-5 ii, k-5 iis, k5, k5ii, pentax k-5, shots
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange battery drain on K5II Shanti Pentax K-5 2 06-20-2013 06:22 PM
For Sale - Sold: Never used BG4 K7/K5/K5ii/K5iis battery grip new pics slip Sold Items 8 06-06-2013 08:00 AM
For Sale - Sold: Pentax D-BG4 battery grip for K5/K5II/K5IIS/K7 hongzhibin1987 Sold Items 7 04-01-2013 07:18 PM
K-5 battery problem? camera problem? user problem? imtheguy Pentax K-5 39 11-03-2010 06:02 PM
Optio S60 BATTERY DEPLETION & Shut Down Problem fxg Pentax Compact Cameras 6 04-15-2008 06:35 AM



All times are GMT -7. The time now is 07:05 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top