Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-21-2013, 12:57 AM   #1
Senior Member




Join Date: Mar 2012
Photos: Gallery
Posts: 165
K5 hot shoe have sleep timer?

My k5 is now almoust 2 years old. From new it have had strange behaviour with hot shoe. Sometimes hot shoe works nicely but sometimes its dead. Need to take flash off, put back again, offon power flash and camera and suddenly itworks again. So suddenly signal just disappear from hot shoe and as result no flash...This really makes me mad. But Pc-sync works fine. Now i did finally notice that problem exist mostly when camera and flash/trigger are on and not take photo about few minutes then no flashsignal from hot shoe anymore.

Anobody else notice this timer sleep off function in k5?

09-21-2013, 09:46 AM   #2
Pentaxian
fs999's Avatar

Join Date: Jul 2008
Location: Luxembourg
Photos: Gallery
Posts: 3,664
I think it is more crisis problem. Never heard that the K5 had a hot shoe sleep timer, unlike the flashes does have one...
09-21-2013, 09:50 AM   #3
Pentaxian




Join Date: Oct 2011
Location: Savannah, GA
Posts: 4,999
Sounds more like a flash problem -- what is the exact set-up?
09-21-2013, 12:06 PM   #4
Pentaxian




Join Date: Jul 2010
Location: Lyngby, Copenhagen
Photos: Albums
Posts: 742
I've experienced something similar. I had a K5, a 540FGZ flash on an ebay p-ttl coiled cord and an ebay flash battery box. All power save features disabled, both on the flash and the camera. After a 5-10 minute pause from shooting, the flash would stop firing. I had to power cycle the flash to make it go again.

I discovered that if I switched the battery box off before the pause and on again before commencing shooting, the flash would keep working. I wrote it off as a bug in the flash.

Regards,
--Anders.

09-21-2013, 11:25 PM   #5
Senior Member




Join Date: Mar 2012
Photos: Gallery
Posts: 165
Original Poster
Cos i experience this same problem with all different setups i assume its camera related problem. Yesterday i did change location of my lightstand once and adjusting directions carefully few mins and again i had no flash signal, so this time using radiotriggers.

Asp1880: i will try to off powersave feature in my camera maybe it have something to do with this. If not help i will go local pentax maintenance cos this problem drives me nuts...
09-23-2013, 12:57 PM   #6
Senior Member




Join Date: Mar 2012
Photos: Gallery
Posts: 165
Original Poster
QuoteOriginally posted by asp1880 Quote
I've experienced something similar. I had a K5, a 540FGZ flash on an ebay p-ttl coiled cord and an ebay flash battery box. All power save features disabled, both on the flash and the camera. After a 5-10 minute pause from shooting, the flash would stop firing...
.
Tnx Anders! Today I did off power save feature in camera (before it was 30mins) and no more this hot shoe problem during many hours shooting session. First time ever flash works without problems even keeping breaks also
09-23-2013, 03:43 PM   #7
Veteran Member
ChrisJ's Avatar

Join Date: Nov 2008
Location: Eckington, Derbyshire UK
Photos: Gallery | Albums
Posts: 316
I had the problem with my K5 and my Metz flash, TTL was random, it would be perfect for a few frames then over/under expose a couple of frames and then go back to perfect again. Same on my K-01, my Pentax Q has always worked perfectly.

After a little research I found I wasn't alone so I updated the firmware in the Metz flash and it now works perfectly on all my Pentax cameras every time, I still think the fault is in the cameras firmware though, Metz specifically mention that the update has been made necessary only for auto and manual operation on the K5 ll and K30, an older update was required for the K5 and a more recent one for the K-01 (all included in the latest download).

http://www.metz.de/index.php?eID=tx_nawsecuredl&u=0&file=fileadmin/fm-dam/Do...a98321af1c8700

It's as if Pentax have altered the flash function on every new model they release.

Chris
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, flash, k-5, k-5 ii, k-5 iis, k5, notice, pentax k-5, shoe
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hot shoe syncing crossmr Flashes, Lighting, and Studio 12 01-16-2013 04:56 PM
Hot shoe covers? slackercruster General Talk 6 08-01-2012 05:55 PM
Hot Shoe Cover dadipentak Flashes, Lighting, and Studio 15 06-20-2012 08:42 PM
Broken Hot Shoe batvans46 Troubleshooting and Beginner Help 6 12-28-2011 08:41 AM



All times are GMT -7. The time now is 06:56 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top