Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-03-2013, 02:15 PM   #1
Junior Member




Join Date: Sep 2012
Posts: 35
is my k5 knackered?

why whilst trying lastest update,camera turned on then displayed card error.noe it turns on but only the top screen is working,but will not take a photo?

10-03-2013, 02:35 PM   #2
Junior Member




Join Date: Oct 2010
Location: Guildford
Posts: 27
Did you format the card after carrying out the update?
10-03-2013, 02:42 PM   #3
Junior Member




Join Date: Sep 2012
Posts: 35
Original Poster
QuoteOriginally posted by alan1 Quote
why whilst trying lastest update,camera turned on then displayed card error.noe it turns on but only the top screen is working,but will not take a photo?
no it just said card error!
10-03-2013, 02:45 PM   #4
Junior Member




Join Date: Oct 2010
Location: Guildford
Posts: 27
After carrying out the update you have to format the card before you use it.

10-03-2013, 02:53 PM   #5
Pentaxian




Join Date: Oct 2009
Location: Far North Qld
Posts: 3,248
QuoteOriginally posted by velvia Quote
After carrying out the update you have to format the card before you use it.
Never needed to do this.
The OP is unlikely to be able to format the card if the rear LCD isn't working!

@alan1: Have you tried pressing the info button a couple of times?
10-03-2013, 10:39 PM   #6
Site Supporter
davidreilly3207's Avatar

Join Date: Sep 2009
Location: South Jersey
Photos: Gallery | Albums
Posts: 566
What version # were you upgrading to?
10-04-2013, 04:54 AM   #7
Col
Veteran Member
Col's Avatar

Join Date: Apr 2007
Location: Stansted Essex
Photos: Gallery
Posts: 615
QuoteOriginally posted by alan1 Quote
why whilst trying lastest update,camera turned on then displayed card error.noe it turns on but only the top screen is working,but will not take a photo?
I had that recently... the cure was to throw away the card.
10-04-2013, 11:37 AM   #8
Junior Member




Join Date: Sep 2012
Posts: 35
Original Poster
evening all thanks for your advice,I got up this morning (I feel a song coming) and although the camera was off it was warm.I removed the memory card and the battery,then replaced them.the camera worked fine,although the battery was on its last legs,I think while it was malfunctioning it did'nt turn off correctly and drained the battery.Am currently charging the battery and will let you all know the outcome.ie.if battery is history.thanks again for your advice.

10-06-2013, 11:44 AM   #9
Junior Member




Join Date: Sep 2012
Posts: 35
Original Poster
QuoteOriginally posted by alan1 Quote
evening all thanks for your advice,I got up this morning (I feel a song coming) and although the camera was off it was warm.I removed the memory card and the battery,then replaced them.the camera worked fine,although the battery was on its last legs,I think while it was malfunctioning it did'nt turn off correctly and drained the battery.Am currently charging the battery and will let you all know the outcome.ie.if battery is history.thanks again for your advice.
Hi all,alan here letting you know the outcome of my k-5 saga.everything is fine the battery works well and holds a charge.Thinking back I don't belive I removed the battery whilst doing the upgrade,only the memorycard,so I belive that was where the problem arose from.message to myself.....FOLLOW INSTRUCTIONS..I hope this may help someone else who has the same problem.thanks again.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
What is my K5 autofocus doing? LowVoltage Pentax DSLR Discussion 29 01-17-2013 10:35 AM
My K5 is on the way. JD44 Pentax K-5 10 10-14-2012 10:55 AM
Something in my K5 Body is moving misterpi Pentax K-5 6 07-04-2012 04:14 AM
My new K5 is on it's way... jeztastic Pentax K-5 7 03-31-2012 02:34 PM
Sent my K5 to Pentax here is how it is going. vievetrick Pentax K-5 273 03-16-2011 03:37 PM



All times are GMT -7. The time now is 03:07 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top