Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
11-06-2013, 04:08 AM   #1
Veteran Member




Join Date: Sep 2013
Posts: 306
My K5 after 1,5 year use

I have kept my k5 with care always, just for information. Ithas been used a lot anyway, i do not know how many pics taken. Until now it has few faults already, i am going to take my k5 to maintenance service soon. List of problems is here just for ur information, maybe u have same faults...

-electronic level to use straight horizons is not correct. Right place is between 2nd and 3rd led on right side. This has been from new already.

-problems positioning flash connections properly to hot shoe. I think body hot shoe flash pins are not exactly right place cos i did not have problems with my older pentax bodies. Flash must be exactly right place, even tiny flash movement when taking pics will cause no connection. This has also been from new.

-body rubber is pealing off under front control wheel. Started after few months use, i have been using scotch tape to fix...

-some buttons not work so nicely as new, must press few times sometimes before something happends...yeah i been using some buttons a lot, i even use much incamera editing...

-lens f rings can not use anymore, there is no information coming to body from lenses that have aperture rings. Even this feature is enabled in body settings. Anyway selecting aperture from body still works fine.

-after take photo sometimes, many buttons not work at all, must offon cam or onoff liewview tomake buttons work normally again. Can not even look pic...This is getting more and more worse...

These are for maintenance to fix, quarantie is still on until 2 years. Just for u to know sharing these only.

11-06-2013, 07:45 AM   #2
Veteran Member
crewl1's Avatar

Join Date: Jul 2010
Location: Los Angeles, CA
Photos: Gallery | Albums
Posts: 9,795
You can upload a picture to find out the shutter count at this forum or various websites.

As for the other items be sure to send it in before your warranty expires.

Otherwise thanks for the warning, I will put you on my ' don't buy a k-5 from this guy' list.
11-06-2013, 01:59 PM   #3
Veteran Member




Join Date: May 2013
Posts: 304
QuoteOriginally posted by Joojoo2010 Quote
Just for u to know sharing these only.
This is for you my friend:

12-04-2013, 02:59 AM   #4
Veteran Member




Join Date: Sep 2013
Posts: 306
Original Poster
Hmmm...have newone. I think mirror is start to get stuck too. Sometimes viewfinder is black many secs after taking pic like 1/60 sec but pic is still fine so it must be mirror left up. Lets see how long mirrorworks at all.

12-04-2013, 03:58 PM   #5
Veteran Member
crewl1's Avatar

Join Date: Jul 2010
Location: Los Angeles, CA
Photos: Gallery | Albums
Posts: 9,795
QuoteOriginally posted by Joojoo2010 Quote
Hmmm...have newone. I think mirror is start to get stuck too. Sometimes viewfinder is black many secs after taking pic like 1/60 sec but pic is still fine so it must be mirror left up. Lets see how long mirrorworks at all.
Did you ever find out the shutter count?
12-05-2013, 12:42 AM   #6
Veteran Member




Join Date: Sep 2013
Posts: 306
Original Poster
QuoteOriginally posted by crewl1 Quote
Did you ever find out the shutter count?
I use ipad mini for editing nowdays and i have been trying to upload unedited camera jpg files to shutter count service here in pentaxforums but result i get is always same unknown. Maybe ipad do something to jpg files automatically. Must trywith pc maybe itworks.
12-05-2013, 01:06 AM   #7
Pentaxian




Join Date: Oct 2011
Location: Savannah, GA
Posts: 4,988
QuoteOriginally posted by Joojoo2010 Quote
-lens f rings can not use anymore, there is no information coming to body from lenses that have aperture rings. Even this feature is enabled in body settings. Anyway selecting aperture from body still works fine.
Aperture data is never transmitted from a lens with an aperture ring if you take it off the 'A' setting. It never did that. If you don't use 'A' (or the lens doesn't have one), you must use manual mode and take meter readings with green button. (The "feature" you enabled "allow aperture ring" simply allows the camera to fire without aperture data known.)
12-05-2013, 12:36 PM   #8
Veteran Member
AndrewG NY's Avatar

Join Date: Dec 2006
Location: Chappaqua, NY
Photos: Gallery
Posts: 675
QuoteOriginally posted by vonBaloney Quote
Aperture data is never transmitted from a lens with an aperture ring if you take it off the 'A' setting. It never did that.
Was thinking the same thing.

12-05-2013, 03:46 PM   #9
Veteran Member




Join Date: Sep 2013
Posts: 306
Original Poster
Ok tnx. Film time on my mind again...
12-05-2013, 04:01 PM   #10
Loyal Site Supporter




Join Date: Mar 2012
Location: Rochester, NY
Photos: Gallery
Posts: 1,811
Have you tried to clean the contacts on the lens and camera body? That may solve a few problems.
12-06-2013, 03:00 PM   #11
Veteran Member




Join Date: Sep 2013
Posts: 306
Original Poster
Contacts are clean.

Its done. Not take pic anymore. After pressing shutterbutton battery shows empty, even battery not empty. I did try also with new batt same every time. Mirror not up anymore...great.
12-15-2013, 06:51 AM   #12
Veteran Member




Join Date: Sep 2013
Posts: 306
Original Poster
Camera PENTAX K-5
Manufature Date 2011:11:03
Shutter Count 37,909
12-15-2013, 06:52 AM   #13
Veteran Member




Join Date: Sep 2013
Posts: 306
Original Poster
Camera PENTAX K100D Super
Manufature Date 2007:08:29
Shutter Count 19,257

But my old girl is still like new condition, everything works fine
12-16-2013, 05:17 PM   #14
Site Supporter
Ex Finn.'s Avatar

Join Date: Nov 2007
Location: Southern Maryland.
Photos: Gallery | Albums
Posts: 6,041
No way the K100D can kick K5 butt in durability. Unless the 5 was maybe severely abused in "club environment" or someting equivalent.

Cheers.
12-17-2013, 03:51 AM   #15
Veteran Member




Join Date: Sep 2013
Posts: 306
Original Poster
No any abuse in this case sorry
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
aperture, body, camera, dslr, flash, information, k-5, k-5 ii, k-5 iis, k5, maintenance, pentax k-5
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Abstract 13 year old daughter experimenting with my K5! MarkJerling Photo Critique 9 03-13-2013 01:38 AM
so after 1 year ownership, I finally tried this...... liukaitc Pentax K-5 33 07-03-2012 03:52 AM
After one week of use with the K-5: I love it! Vorture Pentax K-5 43 03-31-2012 02:16 AM
Just picked up my second K-5 after breaking my first an3ony Pentax K-5 10 12-19-2011 05:14 PM
Can I use this lens on my K5? Tracie Pentax SLR Lens Discussion 7 12-02-2011 11:51 AM



All times are GMT -7. The time now is 06:19 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top