Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
02-12-2014, 11:06 AM   #1
Site Supporter
jpzk's Avatar

Join Date: Jan 2009
Location: Québec
Photos: Gallery | Albums
Posts: 6,976
K5 AF "focus priority" revisiting with questions !

Well, I have been my K5 for quite some time and I am still puzzled with the fact that even if I set the AF to be triggered with "focus prority", (in AF-S, burst mode) it seems that it fires continously anyway even if the subject is out of focus range.

I checked this thread: https://www.pentaxforums.com/forums/115-pentax-k-5/177437-af-s-vs-af-c-intere...servation.html among a few others, but I am somewhat clueless of why this is happening.

Maybe I am not setting the camera properly?
Can anyone shed some "light" on this?

Thanks!

JP


Last edited by jpzk; 02-12-2014 at 11:13 AM.
02-12-2014, 11:15 AM   #2
Pentaxian




Join Date: Feb 2010
Location: East Bay Area
Photos: Gallery
Posts: 775
I ran into this a while back. I seem to remember having to turn the camera off and on AFTER setting it in the menu for it to work for me.
02-12-2014, 12:11 PM   #3
Site Supporter
jpzk's Avatar

Join Date: Jan 2009
Location: Québec
Photos: Gallery | Albums
Posts: 6,976
Original Poster
QuoteOriginally posted by ruggiex Quote
I ran into this a while back. I seem to remember having to turn the camera off and on AFTER setting it in the menu for it to work for me.
Really ?

I had no idea that this could actually help.
I'll give it a go when I am back from work tonight. (Imeant ... when it's not dark !)

Thanks.

JP

Last edited by jpzk; 02-12-2014 at 12:21 PM.
02-12-2014, 03:28 PM   #4
Site Supporter
slip's Avatar

Join Date: Oct 2006
Location: 2 hours north of toronto ontario canada
Photos: Gallery | Albums
Posts: 3,515
QuoteOriginally posted by jpzk Quote
Well, I have been my K5 for quite some time and I am still puzzled with the fact that even if I set the AF to be triggered with "focus prority", (in AF-S, burst mode) it seems that it fires continously anyway even if the subject is out of focus range.

I checked this thread: https://www.pentaxforums.com/forums/115-pentax-k-5/177437-af-s-vs-af-c-intere...servation.html among a few others, but I am somewhat clueless of why this is happening.

Maybe I am not setting the camera properly?
Can anyone shed some "light" on this?

Thanks!

JP
I noticed the same. What I figured out that once ANY part of the scene I am shooting is in focus it will just fire away.
In other words if I am shooting sports and I have a blurred subject, chances are it locked focus on something other than the subject....most times the background. The focus priority doesn't care what part of the scene is in focus as long as SOMETHING is in focus.
Hope this makes sense

Thanks

Randy

02-13-2014, 08:38 AM   #5
Site Supporter
jpzk's Avatar

Join Date: Jan 2009
Location: Québec
Photos: Gallery | Albums
Posts: 6,976
Original Poster
QuoteOriginally posted by slip Quote
I noticed the same. What I figured out that once ANY part of the scene I am shooting is in focus it will just fire away.
In other words if I am shooting sports and I have a blurred subject, chances are it locked focus on something other than the subject....most times the background. The focus priority doesn't care what part of the scene is in focus as long as SOMETHING is in focus.
Hope this makes sense

Thanks

Randy
Yes, it does make sense !
That would explain why the AF will keep firing on "something" that is not the intended target.

In that case, one might as well use Manual focus with CIF (catch-in-focus).

Thanks for the info.

JP

Last edited by jpzk; 02-13-2014 at 08:39 AM. Reason: added info
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
af, camera, dslr, k-5, k-5 ii, k-5 iis, k5, k5 af, pentax k-5
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
The infamous "F- - -" showed up with my K5 with DA*300/4 jpzk Troubleshooting and Beginner Help 10 08-15-2013 04:36 PM
Is K5 Low Light AF Really that "Bad?" Biff Pentax K-5 16 05-10-2013 03:28 PM
difference between "focus indicator" with "matte field" cmrhm Pentax K-5 3 07-31-2012 02:12 PM
"This image cannot be displayed" problem with K5 sb in ak Troubleshooting and Beginner Help 6 06-14-2012 10:08 PM
K-x "aperture priority" records as "automatic" in meta data charlestm Pentax DSLR Discussion 3 12-05-2011 12:12 PM



All times are GMT -7. The time now is 06:34 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top