Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-08-2014, 02:10 PM   #16
Senior Member




Join Date: Jul 2008
Location: Sammamish, WA
Photos: Gallery
Posts: 157
Just updated mine, installed in a few minutes...all is good. I keep 3 8GB and 1 32GB (Video only) and just used one 8GB that had nothing on it cept an empty folder, deleted the folder installed the bin file so it is the only thing on the SD card, and installed per the read me...

03-08-2014, 04:53 PM   #17
Senior Member
zekewhipper's Avatar

Join Date: Dec 2010
Photos: Albums
Posts: 298
My Norton antivirus said the file was very new to it, so I'm not going to update my K-5 for a good month or more until the update it is well established to be O.K. to upload.
03-08-2014, 04:56 PM   #18
Senior Member




Join Date: Jul 2008
Location: Sammamish, WA
Photos: Gallery
Posts: 157
LOL, someone is still using Norton? A company like Ricoh/Pentax is not going to put out a virus file. A FYI, the "FREE" MS AV works great, have used it on all 4 pc's here and never an issue, and its not bloatware like Norton is in my experience. Never notice it and thats how a AV should be, and who better to protect Windows?
03-08-2014, 05:21 PM   #19
Loyal Site Supporter




Join Date: Mar 2012
Location: Rochester, NY
Photos: Gallery
Posts: 1,815
QuoteOriginally posted by zekewhipper Quote
My Norton antivirus said the file was very new to it, so I'm not going to update my K-5 for a good month or more until the update it is well established to be O.K. to upload.
I upgraded my K5 and K5-IIs with no problems. FWIW, Norton passed both files with flying colors.

03-09-2014, 01:09 AM   #20
Moderator
Site Supporter
MarkJerling's Avatar

Join Date: May 2012
Location: Wairarapa, New Zealand
Photos: Gallery | Albums
Posts: 5,206
Original Poster
QuoteOriginally posted by zekewhipper Quote
My Norton antivirus said the file was very new to it, so I'm not going to update my K-5 for a good month or more until the update it is well established to be O.K. to upload.
Windows 8.1 threw up quite a few warnings too, but I don't think Rikoh is about to copy my bank details or send me a Russian bride, so I ignored those and installed anyway.
03-10-2014, 04:09 AM   #21
Junior Member




Join Date: Mar 2011
Location: Netherlands
Posts: 26
QuoteOriginally posted by zekewhipper Quote
My Norton antivirus said the file was very new to it, so I'm not going to update my K-5 for a good month or more until the update it is well established to be O.K. to upload.
My Norton Internet Security 2013 didn't complain about the update file. The update went smooth and within a few minutes on my K-5 (as usual).
03-10-2014, 03:22 PM   #22
Moderator
Site Supporter
MarkJerling's Avatar

Join Date: May 2012
Location: Wairarapa, New Zealand
Photos: Gallery | Albums
Posts: 5,206
Original Poster
QuoteOriginally posted by TomGarn Quote
No way to turn it on again ... it is fully dead - no lights - nothing ...

After 20 minutes of "updating" I knew something went wrong ... and the screen flickered
sometimes shortly - as if to start over again. My only chance was to turn it off and try again
before batteries would finish the trip anyway.

Update 1.15 went fine - last time - everything was OK with the camera, I think. The only thing
strange to me was that it didn't work together with HDMI Out (but I suspected the cable connection)
It didn't turn off the screen when I connected it - so maybe some small software problem was there ?

EDIT:
But I have to say it didn't even start to update 4 times before - it only showed the firmware
status ...This should have alarmed me that something may have gone wrong with the data
and better download it again and then unzip it again ... Now these thoughts come to late of
course ... The file may have been corrupt ... or the camera had a hidden mistake allready,
that I just wasn't aware of.

When those first updates didn't start - I again formatted the card - and put the bin on again.
I did this formatting in camera - and in the card reader, both. Didn't make a difference.
Why the fifth time it started the update procedure and stopped for 20 minutes in part 1/2 I
can't imagine. I doubted waiting even longer than 20 Minutes could not do any better.
What a nightmare. One would think they have some kind of failsafe for this. Clearly not.
03-10-2014, 03:48 PM   #23
pid
Senior Member




Join Date: Jan 2010
Photos: Gallery
Posts: 149
first time I heared that a firmware Update killed a Cam. Thats hard!
I just copied the firmware on my SD Card without cleaning it before. All the pictures where on the card, nothing went wrong. It just updated as all the times before.

03-10-2014, 05:37 PM   #24
Inactive Account




Join Date: Mar 2007
Location: Long Island, N.Y.
Photos: Gallery
Posts: 1,124
Can't be all bad. I just updated my K5ii to version 1.07 without any problem or thought. All seems OK.
03-11-2014, 05:50 PM   #25
Veteran Member




Join Date: Sep 2013
Location: Hamburg
Posts: 301
Only one hint I may have had ... if that means something was wrong with my camera
... if it was not a corrupted file - badly downloaded, unzipped or on a bad SD-card - or bad battery
... and I checked the SD-card with h2testw.exe - and windows too - also the battery was full.

One day before this firmware-update I tried to view my camera via HDMI on my tv-set - but it didn't
work.out - also the camera-display did not switch off ... that may be either an indication for a broken
cable - or that something on the hardware or software was allready broken ...
Possibiliy of a shock through connecting wrongly with a tv-set ?
No answers ...
03-12-2014, 12:27 AM   #26
Site Supporter
beachgardener's Avatar

Join Date: Sep 2013
Location: Australia
Photos: Gallery
Posts: 1,932
update to 1.16 went smoothly here, no problems.
03-12-2014, 02:12 AM   #27
Moderator
Site Supporter
MarkJerling's Avatar

Join Date: May 2012
Location: Wairarapa, New Zealand
Photos: Gallery | Albums
Posts: 5,206
Original Poster
QuoteOriginally posted by TomGarn Quote
Only one hint I may have had ... if that means something was wrong with my camera
... if it was not a corrupted file - badly downloaded, unzipped or on a bad SD-card - or bad battery
... and I checked the SD-card with h2testw.exe - and windows too - also the battery was full.

One day before this firmware-update I tried to view my camera via HDMI on my tv-set - but it didn't
work.out - also the camera-display did not switch off ... that may be either an indication for a broken
cable - or that something on the hardware or software was allready broken ...
Possibiliy of a shock through connecting wrongly with a tv-set ?
No answers ...
Interesting. Voltage issues from the TV perhaps?
03-12-2014, 04:41 AM   #28
Veteran Member




Join Date: Sep 2013
Location: Hamburg
Posts: 301
They say (sometimes, somewhere on the web) that not all HDMI cables do their duty.
Just for idiots I now ordered a Pentax K-5 HDMI cable ... to afraid to have this death occur again ...
Amazon.com: dCables Pentax K-5 HDMI Cable - HD Video Cable for Pentax K-5: Camera & Photo
03-12-2014, 10:47 AM   #29
KX5
Forum Member




Join Date: Apr 2012
Location: Belgium
Posts: 61
Updated with success.
What does it improve really?
Did u notice some AF improvment on your K5?
For me it seems a little bit more nervous but it's very hard to judge...
03-13-2014, 06:45 PM   #30
New Member




Join Date: Feb 2014
Posts: 3
firm ware

Thanks for the update.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
battery, bin, camera, card, dslr, file, firmware, k-5, k-5 firmware version, k-5 ii, k-5 iis, k5, laptop, memory, name, pentax, pentax k-5, pm, post, update, windows
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K-5 Firmware Version mysterick Troubleshooting and Beginner Help 23 12-02-2016 07:09 AM
K-7 FIRMWARE Version 1.12 KILLED MY CAMERA Electric Eye Troubleshooting and Beginner Help 83 05-21-2016 07:45 AM
New Firmware for K-500, K-50, K-5 II, K-5 IIs, K-5, K-30, K-01, K-r, and 645D is out Adam Pentax News and Rumors 60 09-16-2013 05:46 AM
*** FYI for K-5 new firmware 1.15 *** abmj Pentax K-5 35 09-16-2013 05:21 AM
New Firmware For K-01, K-30, K-5, K-5 II, K-5 IIs, K-r Adam Pentax News and Rumors 63 02-18-2013 02:04 PM



All times are GMT -7. The time now is 04:09 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top