Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-06-2014, 03:58 AM - 1 Like   #1
Moderator
Site Supporter
MarkJerling's Avatar

Join Date: May 2012
Location: Wairarapa, New Zealand
Photos: Gallery | Albums
Posts: 5,775
New K-5 firmware version 1.16

Latest firmware update now available from Latest K-5 Firmware Update : Software Downloads | RICOH IMAGING
I've done the update and K-5 is functioning correctly after.
Do remember to read the "readme" file and ensure you have a fully charged battery and a formatted SD card for doing the upgrade.

03-06-2014, 04:14 AM   #2
Senior Member
topace's Avatar

Join Date: Sep 2011
Location: Stockholm
Posts: 196
QuoteQuote:
Changes to V1.16
  • Correspond to HD PENTAX-DA AF REAR CONVERTER 1.4X AW.
  • Improved stability for general performance.
*Contents of [Version 1.15] and earlier version will be also updated.
Looks like a definition update for the teleconverter, though they could of course have snuck something interesting in under the "stability and general performace" part. Probably nothing big, though.
03-06-2014, 04:18 AM   #3
Veteran Member




Join Date: Jul 2009
Location: London
Posts: 873
Was the .bin file name correct? I ask because the v1.07 .bin file name for the K5II is the same as that for the v1.06 .bin file, and was wondering if it's a common error?
03-06-2014, 07:24 AM   #4
Veteran Member
jerryleejr's Avatar

Join Date: Aug 2011
Location: TN
Posts: 420
When I went there 1,14 was on top 1.15 was below it, didn't see 1.16 I'll keep checking...

JJ

03-06-2014, 07:29 AM   #5
Site Supporter
sholtzma's Avatar

Join Date: Sep 2007
Location: Salisbury, NC
Photos: Gallery | Albums
Posts: 1,014
Just to clarify...this is for K-5 only and not also for K-5ii/s?
03-06-2014, 07:44 AM   #6
Junior Member




Join Date: Mar 2011
Location: Netherlands
Posts: 26
QuoteOriginally posted by sholtzma Quote
Just to clarify...this is for K-5 only and not also for K-5ii/s?
There is also an update for K-5ii/s (version 1.07), other DSLR's and K-01.
For de K-5ii/s use this link: Latest K-5II/K-5IIs Firmware Update : Software Downloads | RICOH IMAGING
03-06-2014, 07:45 AM   #7
Veteran Member
peterjcb's Avatar

Join Date: Dec 2013
Location: Weddington, NC
Posts: 468
Thanks for the heads-up....went very smoothly.
03-06-2014, 02:04 PM   #8
Pentaxian




Join Date: Jun 2009
Location: GMT +10
Photos: Albums
Posts: 10,720
Smooth upgrade for me too.

03-06-2014, 06:14 PM   #9
Moderator
Site Supporter
MarkJerling's Avatar

Join Date: May 2012
Location: Wairarapa, New Zealand
Photos: Gallery | Albums
Posts: 5,775
Original Poster
QuoteOriginally posted by JohnX Quote
Was the .bin file name correct? I ask because the v1.07 .bin file name for the K5II is the same as that for the v1.06 .bin file, and was wondering if it's a common error?
So far as I'm aware, the bin file name does not change. For instance, the 1.15 firmware and 1.16 firmware versions for the K-5 both have the same bin file name, Fwdc209b.bin.

---------- Post added 03-07-14 at 02:30 PM ----------

QuoteOriginally posted by jerryleejr Quote
When I went there 1,14 was on top 1.15 was below it, didn't see 1.16 I'll keep checking...

JJ
1.16 is right at the top, with the download button on the very bottom of this page: Latest K-5 Firmware Update : Software Downloads | RICOH IMAGING

---------- Post added 03-07-14 at 02:30 PM ----------

QuoteOriginally posted by peterjcb Quote
Thanks for the heads-up....went very smoothly.
My pleasure!

---------- Post added 03-07-14 at 02:31 PM ----------

QuoteOriginally posted by topace Quote
Looks like a definition update for the teleconverter, though they could of course have snuck something interesting in under the "stability and general performace" part. Probably nothing big, though.
You never know. They always use this "stability and general performance" blah!
03-06-2014, 07:46 PM - 1 Like   #10
Senior Member
KRaZiGLiTcH's Avatar

Join Date: Jan 2014
Location: Australia
Photos: Gallery
Posts: 204
I updated and it went fine ^_^ thanks everyone here for the news about it.
03-07-2014, 07:05 AM   #11
Veteran Member




Join Date: Sep 2013
Location: Hamburg
Posts: 301
Firmware Update went wrong - K-5 is dead !!!

I did many typical and short updates before - but this took longer than 20 minutes !
So before battery running down ... and something must have gone wrong ...
I stopped the update that never went further but to show phase 1/2

I formatted the card / put on the bin-folder on it again / but the camera did not react
at all .. no power anymore.

Called the service - they said the board is dead. A new one will cost 380,- €
(that's the price I paid for this used all right camera)

Any idea left ? How long did you need for the update ?

Last edited by TomGarn; 03-07-2014 at 07:19 AM.
03-07-2014, 04:38 PM   #12
Senior Member
KRaZiGLiTcH's Avatar

Join Date: Jan 2014
Location: Australia
Photos: Gallery
Posts: 204
QuoteOriginally posted by TomGarn Quote
Firmware Update went wrong - K-5 is dead !!!

I did many typical and short updates before - but this took longer than 20 minutes !
So before battery running down ... and something must have gone wrong ...
I stopped the update that never went further but to show phase 1/2

I formatted the card / put on the bin-folder on it again / but the camera did not react
at all .. no power anymore.

Called the service - they said the board is dead. A new one will cost 380,-
(that's the price I paid for this used all right camera)

Any idea left ? How long did you need for the update ?
Omg,That sucks T_T it took me only like 3-5 mins for it to finish.
03-07-2014, 04:52 PM   #13
Moderator
Site Supporter
MarkJerling's Avatar

Join Date: May 2012
Location: Wairarapa, New Zealand
Photos: Gallery | Albums
Posts: 5,775
Original Poster
QuoteOriginally posted by TomGarn Quote
Firmware Update went wrong - K-5 is dead !!!

I did many typical and short updates before - but this took longer than 20 minutes !
So before battery running down ... and something must have gone wrong ...
I stopped the update that never went further but to show phase 1/2

I formatted the card / put on the bin-folder on it again / but the camera did not react
at all .. no power anymore.

Called the service - they said the board is dead. A new one will cost 380,-
(that's the price I paid for this used all right camera)

Any idea left ? How long did you need for the update ?
Gosh, that's terrible. For me, part 1/2 went quite fast, probably no more than a minute, although I did not time it. 2/2 took longer, probably about 3-4 minutes. Too late now, but never turn off the camera when doing a firmware update. What happens now if you turn the camera on? Or, what happens now if you try to run the update again?
03-07-2014, 05:37 PM   #14
Veteran Member




Join Date: Sep 2013
Location: Hamburg
Posts: 301
QuoteOriginally posted by MarkJerling Quote
Gosh, that's terrible. For me, part 1/2 went quite fast, probably no more than a minute, although I did not time it. 2/2 took longer, probably about 3-4 minutes. Too late now, but never turn off the camera when doing a firmware update. What happens now if you turn the camera on? Or, what happens now if you try to run the update again?
No way to turn it on again ... it is fully dead - no lights - nothing ...

After 20 minutes of "updating" I knew something went wrong ... and the screen flickered
sometimes shortly - as if to start over again. My only chance was to turn it off and try again
before batteries would finish the trip anyway.

Update 1.15 went fine - last time - everything was OK with the camera, I think. The only thing
strange to me was that it didn't work together with HDMI Out (but I suspected the cable connection)
It didn't turn off the screen when I connected it - so maybe some small software problem was there ?

EDIT:
But I have to say it didn't even start to update 4 times before - it only showed the firmware
status ...This should have alarmed me that something may have gone wrong with the data
and better download it again and then unzip it again ... Now these thoughts come to late of
course ... The file may have been corrupt ... or the camera had a hidden mistake allready,
that I just wasn't aware of.

When those first updates didn't start - I again formatted the card - and put the bin on again.
I did this formatting in camera - and in the card reader, both. Didn't make a difference.
Why the fifth time it started the update procedure and stopped for 20 minutes in part 1/2 I
can't imagine. I doubted waiting even longer than 20 Minutes could not do any better.

Last edited by TomGarn; 03-07-2014 at 07:21 PM.
03-08-2014, 10:20 AM   #15
Site Supporter
savoche's Avatar

Join Date: Jun 2011
Location: Lowlands of Norway
Posts: 7,954
QuoteOriginally posted by TomGarn Quote
No way to turn it on again ... it is fully dead - no lights - nothing ...

After 20 minutes of "updating" I knew something went wrong ... and the screen flickered
sometimes shortly - as if to start over again. My only chance was to turn it off and try again
before batteries would finish the trip anyway.

Update 1.15 went fine - last time - everything was OK with the camera, I think. The only thing
strange to me was that it didn't work together with HDMI Out (but I suspected the cable connection)
It didn't turn off the screen when I connected it - so maybe some small software problem was there ?

EDIT:
But I have to say it didn't even start to update 4 times before - it only showed the firmware
status ...This should have alarmed me that something may have gone wrong with the data
and better download it again and then unzip it again ... Now these thoughts come to late of
course ... The file may have been corrupt ... or the camera had a hidden mistake allready,
that I just wasn't aware of.

When those first updates didn't start - I again formatted the card - and put the bin on again.
I did this formatting in camera - and in the card reader, both. Didn't make a difference.
Why the fifth time it started the update procedure and stopped for 20 minutes in part 1/2 I
can't imagine. I doubted waiting even longer than 20 Minutes could not do any better.
Really sorry to hear that.

I had no problems, took just a few minutes, as usual. I've never bothered with formatting the card, really, just grabbed one, sometimes one with pictures already on it, never had any problems. That doesn't mean I recommend doing it that way!
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
battery, bin, camera, card, dslr, file, firmware, k-5, k-5 firmware version, k-5 ii, k-5 iis, k5, laptop, memory, name, pentax, pentax k-5, pm, post, update, windows
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K-5 Firmware Version mysterick Troubleshooting and Beginner Help 23 12-02-2016 07:09 AM
K-7 FIRMWARE Version 1.12 KILLED MY CAMERA Electric Eye Troubleshooting and Beginner Help 83 05-21-2016 07:45 AM
New Firmware for K-500, K-50, K-5 II, K-5 IIs, K-5, K-30, K-01, K-r, and 645D is out Adam Pentax News and Rumors 60 09-16-2013 05:46 AM
*** FYI for K-5 new firmware 1.15 *** abmj Pentax K-5 35 09-16-2013 05:21 AM
New Firmware For K-01, K-30, K-5, K-5 II, K-5 IIs, K-r Adam Pentax News and Rumors 63 02-18-2013 02:04 PM



All times are GMT -7. The time now is 12:12 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top