Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-18-2014, 09:25 AM   #1
Senior Member




Join Date: Oct 2009
Location: Florida
Photos: Albums
Posts: 235
Flash Problem, k5iis

Hi,

Just discovered a problem with my new k5iis. I have a Metz 58 AF-2 and a Digital Concepts 952AF/PEN (similar to the cheap Vivitar) which both worked perfectly with my k7. Today I put the 952AF on the k5iis and as soon as I metered the flash started strobing (about 5/s). Sliding the mode switch to S (Slave) or turning off the k5 was the only way to stop the flash from the continuous strobe.

I brought out the k7 to see if it had the same problem, and it doesn't.

I'm confident the problem is with the communication with the k5 since the k7 works as it always did. I moved the flash around, tightened/loosened the plastic nut that holds it to the hot shoe and used freshly charged batteries (Flash and Camera) to rule those issues out, and none had any effect.

Has anyone seen this? I'm going to leave the 952 off the k5iis and use only the Metz mounted in the hot shoe just to make sure this 'cheaper' flash isn't creating a problem for the k5, and the 952 does work fine in Slave mode, which is why I purchased it anyway, but I do want to make sure there isn't a problem with my new k5. I would hate to let this go and find out after warranty the Metz starts doing this.

I have the latest firmware in the k5 and k7.

Thanks for any info,

Bill

03-18-2014, 10:42 AM   #2
Senior Member
Timd's Avatar

Join Date: Dec 2008
Location: Cape Town, SA
Posts: 255
What is the trigger voltage on the 952? It could be that it is too high for the K5, causing the trigger switch to break down, triggering the flash, which recharges until the trigger voltage is too high. There is a website that has the trigger voltage of many flashes if you don't have a voltmeter.
03-18-2014, 12:03 PM   #3
Pentaxian




Join Date: Jan 2012
Location: Slovenia
Photos: Gallery
Posts: 2,177
Probably not, since the trigger voltage should be same for all Pentax DSLRs. I'd second the communication problem hypothesis, since flashes often need firmware updates to work with newer cameras.
03-18-2014, 01:22 PM   #4
Senior Member




Join Date: Oct 2009
Location: Florida
Photos: Albums
Posts: 235
Original Poster
QuoteOriginally posted by Giklab Quote
Probably not, since the trigger voltage should be same for all Pentax DSLRs. I'd second the communication problem hypothesis, since flashes often need firmware updates to work with newer cameras.
You know I didn't think about that. There is a small connector on the front of this flash, but it's probably for power. This is an inexpensive flash, but I think a very good one. It cost about $110.00 a few years ago and worked well with the k7 and k-x. I can't remember if I tried it before today on my newer k5iis.

As far as voltage, I checked before I bought it & it had low (digital) voltage. Thanks though.

I'm more worried I have a camera problem but the Metz still works so I don't know.

Thanks again,

Bill

03-18-2014, 02:26 PM   #5
Veteran Member
sterretje's Avatar

Join Date: Dec 2008
Location: Roodepoort, South Africa
Photos: Gallery | Albums
Posts: 3,534
There have been changes in the design of the flash circuitry. There are threads about the K5 in combination with the Yongnuo 560 where the flash only fires once. I know that your symptoms are different and that you're using he K5/IIs.

I guess that changes in the circuitry have resulted in incompatibility of your 952 flash with the K5/IIs.
03-18-2014, 05:12 PM   #6
Senior Member




Join Date: Oct 2009
Location: Florida
Photos: Albums
Posts: 235
Original Poster
QuoteOriginally posted by sterretje Quote
There have been changes in the design of the flash circuitry. There are threads about the K5 in combination with the Yongnuo 560 where the flash only fires once. I know that your symptoms are different and that you're using he K5/IIs.

I guess that changes in the circuitry have resulted in incompatibility of your 952 flash with the K5/IIs.
That could be too. Do you remember where you read/heard about the circuitry changes? On this site?

Thanks,

Bill
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, flash, k-5, k-5 ii, k-5 iis, k5, metz, mode, pentax k-5, shoe, slave
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Viltrox JY670 ring flash - K5iis can only fire flash once, K7 is fine RobG Flashes, Lighting, and Studio 19 10-07-2015 10:58 PM
Flash problem sorl Ricoh GR 2 03-09-2014 08:11 PM
Suggestions for a flash for a K5iis and an LX Johnyb3000 Flashes, Lighting, and Studio 3 05-23-2013 09:55 PM
K5IIs - which budget flash? JayX2A Pentax K-5 3 02-27-2013 01:28 AM
K10D+540 flash problem using trailing flash wirelessly PaulT Flashes, Lighting, and Studio 4 01-18-2010 10:00 AM



All times are GMT -7. The time now is 09:26 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top