Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
04-16-2014, 06:26 PM   #1
Pentaxian
fgaudet's Avatar

Join Date: Oct 2013
Location: Ontario
Posts: 726
Odd K5 issues running FW 1.16

First off, my K5 has been a stellar camera for more than a year. Never glitched or misbehaved in the slightest. Solid as a rock. Until yesterday.

I turned it on, with a Sigma 35mm (A) mounted on it. but instead of the usual info menu, I got the focal length selector screen. A quick power off / power on and all was good. Few minutes later after it went to sleep, it happened again but I left the setting as it was (200mm) and took a few shots. EXIF show the proper 35mm. Being a new*ish lens I thought I'd try with my 17-70. Same issue every few power ons. I Tried with a Pentax 50-135, same thing. Tried a few very slow shutter speed shots to test the SR and all seems good even with a very wrong focal length entered when prompted to so the camera ends up detecting the lens OK.

Anyway, not a big deal since it doesn't look like it's affecting anything.

But then...

Today I decided to do some macro so I used Liveview. Took a few shots, everything is OK but at one point I could hear the shot being taken, the mirror going back up afterwards but liveview won't turn back on. I can change aperture, iso, shutter speed, everything but no liveview (mirror up so no viewfinder either) and the camera won't fire. Turning the power off doesn't do anything, I have to take the battery out. Problem will happen with a Sigma 17-70mm screwdrive, Sigma 35mm HSM, Pentax DA* 50-135 SDM, Pentax A 50mm screwdrive with aperture ring, Takumar 28mm fully manual and a Vivitar 200mm M42.

Tried with Pentax batteries (old and new) fully charged and with cheapo batteries. Tried with the grip, with two batteries, with only one in the camera and with only one in the grip. Even tried with AA. No matter what I do, after a random number of shots in liveview, mirror will lock up and the camera won't fire. Tried self timer, and a remote too.

I updated the firmware (1.16) about a week ago and I shoot usually 50+ pictures a day and I did some macro work on Sunday with no issues.

Anyone has any idea?

04-16-2014, 07:43 PM   #2
Site Supporter
kiwi_jono's Avatar

Join Date: Dec 2009
Location: Christchurch, New Zealand
Photos: Gallery | Albums
Posts: 1,035
Well I don't have much to offer other than I am running 1.16 on my K-5 and its all good - nothing noticeably different with any of my lenses. So I am guessing that either its:
1. To do with settings you are using (may be worth resetting settings to default and going from there?)
2. Hardware. Possibly worth trying cleaning lens contacts on body (or at least giving them a good inspection).

Update: actually on reflection I have seen it recently show a black screen a couple of times after taking a photo (rather than preview). Not a biggie but could be related to firmware change.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
aperture, batteries, camera, dslr, k-5, k-5 ii, k-5 iis, k5, mirror, pentax, pentax k-5, sigma
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pentax FW video hack K5 em-tx Video and Pentax HDSLRs 29 09-26-2013 02:42 PM
FW 1.04 and longer AF lenses: any improvement? Doundounba Pentax K-01 4 09-24-2013 08:16 PM
Tone Expansion after FW 1.11 ??? dodel Pentax Q 19 04-03-2013 07:26 AM
Q FW v1.1 + DA 55-300 Handheld snostorm Pentax Q 21 11-07-2012 10:53 AM
K5 FW Upgrade Path Avenger Pentax K-5 5 03-16-2011 03:51 AM



All times are GMT -7. The time now is 09:02 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top