Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
04-17-2014, 07:55 AM   #1
Veteran Member
nanhi's Avatar

Join Date: May 2009
Location: Bangalore, India
Photos: Gallery | Albums
Posts: 440
Unique Battery & Preview Problem

The Ricoh produced, Jan 2013 purchased K-5 has the original battery. The Problem:-
a) After a few shots on a fully charged battery, the indicator will show low charge - 3/4 to 1/4. Then again after the camera is shut down and restarted it will show full charge.
While this was a known problem on the Hoya produced K-5, I am not sure if it still exists with the newer Ricoh produced ones.
b) When the preview Button is pressed to see the photo, it appers on the LCD momentarily but soon goes away. This problem repeats when the button is pressed again.
Both these problems are random, and the camera will work OK most of the time.
We have a 2-year Canadian warranty on the camera. Need some reassuring advice as we have cut a sorry figure in the past at Service Centres for electronic equipment, where such random problems refused to surface, and had to face ridicule.
Thanks in advance.

04-17-2014, 12:06 PM   #2
New Member




Join Date: Feb 2014
Posts: 18
Have you updated your firmware? Best place to start...
04-17-2014, 11:30 PM   #3
Veteran Member
nanhi's Avatar

Join Date: May 2009
Location: Bangalore, India
Photos: Gallery | Albums
Posts: 440
Original Poster
QuoteOriginally posted by 737george Quote
Have you updated your firmware? Best place to start...
Yes George, to version 1.15.
I am yet to apply version 1.16.
Thanks for the input.
04-18-2014, 12:56 AM   #4
New Member




Join Date: Feb 2014
Posts: 18
Hello again, am surprised you have not received more feedback. I am new here, bought K5 IIs just over a month ago. So far all is good, however already had 2 firmware update? Good Luck.. If you find your problem and get corrected, please post information here for us new people to Pentax.

Sincerely
737george

04-22-2014, 06:34 AM   #5
Pentaxian




Join Date: Jan 2009
Location: Nevada, USA
Posts: 485
QuoteOriginally posted by nanhi Quote
The Ricoh produced, Jan 2013 purchased K-5 has the original battery. The Problem:-
a) After a few shots on a fully charged battery, the indicator will show low charge - 3/4 to 1/4. Then again after the camera is shut down and restarted it will show full charge.
While this was a known problem on the Hoya produced K-5, I am not sure if it still exists with the newer Ricoh produced ones.
b) When the preview Button is pressed to see the photo, it appers on the LCD momentarily but soon goes away. This problem repeats when the button is pressed again.
Both these problems are random, and the camera will work OK most of the time.
We have a 2-year Canadian warranty on the camera. Need some reassuring advice as we have cut a sorry figure in the past at Service Centres for electronic equipment, where such random problems refused to surface, and had to face ridicule.
Thanks in advance.
Batteries tend to display that kind of behavior. Their voltage drops a bit while under heavy load, so the meter reading may drop if the battery is getting close to the end of it's charge, especially if you are shooting in live view or reviewing the image after each shot. With a brief rest, then battery voltage recovers, so the meter reading may go back up. But if you are seeing this when the battery is fully charged, it may be the battery is showing it's age. Batteries do wear out and lose capacity over time.

If you touch the shutter button or any other control which activates metering the playback screen turns off. I do this accidently sometimes when reviewing a shot. Maybe this is what you are seeing?
04-22-2014, 09:52 AM   #6
Veteran Member
nanhi's Avatar

Join Date: May 2009
Location: Bangalore, India
Photos: Gallery | Albums
Posts: 440
Original Poster
Thanks CFRAZ Sir, for the detailed explanation. Sounds technically perfect and I shall watch out for this odd behaviour with a new Pentax Battery on order.
The current batteries were purchased early Jan 2013 - one Pentax original that came with the Kit, and the other a 3rd Party bought from evil bay.
Regards.
04-24-2014, 07:30 AM   #7
Loyal Site Supporter
TER-OR's Avatar

Join Date: Apr 2009
Location: Dundee, IL
Photos: Gallery | Albums
Posts: 5,834
My K5's battery meter is unreliable when the charge is low-ish. I liken it to the older automobile gas tank level indicators which were...less than precise. It will operate for a long time on an "empty" rating.

I haven't had the display problem, though, that's something new to me.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
battery, battery & preview, button, camera, dslr, k-5, k-5 ii, k-5 iis, k5, pentax k-5, preview, ricoh
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K5II & battery problem alexeyga Pentax K-5 45 12-05-2013 08:58 AM
K-5 battery problem? camera problem? user problem? imtheguy Pentax K-5 39 11-03-2010 06:02 PM
Unique *istDL problem freeflyr Pentax DSLR Discussion 8 07-21-2008 07:47 AM
Optio S60 BATTERY DEPLETION & Shut Down Problem fxg Pentax Compact Cameras 6 04-15-2008 06:35 AM



All times are GMT -7. The time now is 06:25 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top