Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-08-2014, 09:01 PM   #1
Veteran Member
RonakG's Avatar

Join Date: Jan 2011
Location: Bay Area, CA
Photos: Gallery
Posts: 603
New K-5 IIs owner: couple of doubts

Just got myself a K-5 IIs. I have couple of doubts regarding the camera.

1. When I switch the camera on, some kind of scratching sound comes from the camera. First I thought it is dust removal, but then I turned startup dust removal off and the sound is still there every time I turn on the camera.

2. Viewfinder is very warm compared to my K-x. When I compare both side by side, K-x viewfinder shows colors that are much closer to actual whereas K-5 IIs viewfinder is warm.

Any ideas?

09-08-2014, 10:46 PM   #2
Moderator
MarkJerling's Avatar

Join Date: May 2012
Location: Wairarapa, New Zealand
Photos: Gallery | Albums
Posts: 5,166
The only sound it should make on startup is the dust removal sound. And, I won't describe that as scratching. As the viewfinder is optical, you should see the colours as real as can be. (Unless someone's replaced the focus screen perhaps?) Have you checked shutter count to make sure it's new if it's supposed to be new?

Last edited by MarkJerling; 09-08-2014 at 10:53 PM.
09-08-2014, 10:47 PM   #3
Site Supporter
jimr-pdx's Avatar

Join Date: May 2010
Location: 1hr north of PDX
Photos: Gallery | Albums
Posts: 3,480
Curious about those sounds, so it's not the SR system in your estimation? As to color temperature, it can be adjusted in great detail via the menu system - though I haven't seen one need anything right out of the box. I'd contact the sellers and let them know. Hope it's all easy stuff!

Edit - oops, didn't think you meant viewfinder!! I was thinking LCD
09-08-2014, 10:52 PM   #4
Veteran Member
RonakG's Avatar

Join Date: Jan 2011
Location: Bay Area, CA
Photos: Gallery
Posts: 603
Original Poster
QuoteOriginally posted by MarkJerling Quote
New or secondhand? The only sound it should make on startup is the dust removal sound. And, I won't describe that as scratching. As the viewfinder is optical, you should see the colours as real as can be. (Unless someone's replaced the focus screen perhaps?)
It's a new one. Got it today from Adorama. I've turned off dust removal on startup, so that can't be it.

I'll do some more comparison for viewfinder tomorrow morning in daylight. There's a perceivable difference in color temperature between viewfinders of K-x and K-5 IIs.

---------- Post added Sep 8th, 2014 at 11:03 PM ----------

QuoteOriginally posted by jimr-pdx Quote
Curious about those sounds, so it's not the SR system in your estimation? As to color temperature, it can be adjusted in great detail via the menu system - though I haven't seen one need anything right out of the box. I'd contact the sellers and let them know. Hope it's all easy stuff!

Edit - oops, didn't think you meant viewfinder!! I was thinking LCD
I've no idea what the sound is about. On another forum few people also mentioned that the sound is from SR mechanism, and is perfectly normal. They were very casual about the warm color temp about view finder too.

09-08-2014, 11:52 PM   #5
Pentaxian




Join Date: Jan 2012
Location: Slovenia
Posts: 2,141
That "scratching" is supposedly from the aperture activator. Mine was quietly audible at first, then the camera had a problem and got serviced. After that, the sound got really loud (and also could be felt through the camera).
I'd describe it as more of a fart though.
09-09-2014, 03:09 AM   #6
Site Supporter
Ex Finn.'s Avatar

Join Date: Nov 2007
Location: Southern Maryland.
Photos: Gallery | Albums
Posts: 6,040
Yup, aperture motor cycling at power-up.
As far as the viewfinder, are you using the same lens for comparison?
09-09-2014, 03:25 AM   #7
Pentaxian
Oldbayrunner's Avatar

Join Date: Mar 2013
Location: Havre de Grace, MD
Posts: 1,219
The difference you are seeing in the viewfinder is you are going from viewing through a Pentamirror on your K-x to a much better Pentaprism. I agree the quick start up noise is the aperture activator, mine does that.
09-09-2014, 06:18 AM   #8
Pentaxian
RobG's Avatar

Join Date: Dec 2009
Location: Canberra
Photos: Gallery | Albums
Posts: 3,475
Here's what my K5iis sounds like when I switch it on - twice.


As far as I know, this noise is completely normal.

09-09-2014, 07:31 AM   #9
Forum Member




Join Date: Jan 2011
Location: Sao Paulo
Posts: 54
QuoteOriginally posted by Oldbayrunner Quote
The difference you are seeing in the viewfinder is you are going from viewing through a Pentamirror on your K-x to a much better Pentaprism. I agree the quick start up noise is the aperture activator, mine does that.
That difference in color does have nothing to do with the fact the KX is pentamirror and K5IIs is pentaprism.

The K10D is pentaprism too, and have a more "cooler" and natural rendering of view. The whites look white.

My guess is that it have something to do with the optical engineering of the 100% coverage pentaprism of the K7-K5 bodies, and the fact the camera as a whole is a very compact pro body.
09-09-2014, 07:44 AM   #10
Veteran Member
RonakG's Avatar

Join Date: Jan 2011
Location: Bay Area, CA
Photos: Gallery
Posts: 603
Original Poster
Thanks everyone. So looks like nothing to worry about, just couple of things to get used to.
09-09-2014, 08:26 AM   #11
Pentaxian
fs999's Avatar

Join Date: Jul 2008
Location: Luxembourg
Photos: Gallery
Posts: 3,444
QuoteOriginally posted by sungibr Quote
The K10D is pentaprism too, and have a more "cooler" and natural rendering of view. The whites look white.
Never saw a difference in rendering between my K10D or K20D and K7 or K5...
09-15-2014, 09:40 AM   #12
Site Supporter




Join Date: May 2014
Location: Minnesota
Posts: 1,182
I have the K-5 IIs and the dust removal is so quiet I don't even know it's ON. I would send the camera back.
09-15-2014, 11:35 PM   #13
Pentaxian




Join Date: Jan 2012
Location: Slovenia
Posts: 2,141
QuoteOriginally posted by hjoseph7 Quote
I have the K-5 IIs and the dust removal is so quiet I don't even know it's ON. I would send the camera back.
He's not hearing the dust removal though...
09-16-2014, 12:09 AM   #14
kpl
Junior Member




Join Date: Mar 2014
Photos: Albums
Posts: 37
That sound ist absolutely ok.
Mine does that, too.
It did that sound when I unboxed it and it still does that after several thousands of shutter actuations
Nothing to worry about.

Cheers,
kpl
09-16-2014, 12:51 AM   #15
Veteran Member
crewl1's Avatar

Join Date: Jul 2010
Location: Los Angeles, CA
Photos: Gallery | Albums
Posts: 9,795
Startup sound is normal with K-5 series.
Here is my video like the one above
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, color, couple, dslr, dust, k-5, k-5 ii, k-5 iis, k-x, k5, pentax k-5, removal, sound, startup, viewfinder
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
New Pentax K-5, K-5 II & K-5 IIs Adobe Camera Profiles PentaxGuyUK Post-Processing Articles 7 12-04-2014 05:02 AM
New Firmware for K-500, K-50, K-5 II, K-5 IIs, K-5, K-30, K-01, K-r, and 645D is out Adam Pentax News and Rumors 60 09-16-2013 05:46 AM
A couple of new K5ii owner's questions Quagga Pentax K-5 3 06-12-2013 05:12 AM
New owner of a Pentax K-5 JPSanchezC Welcomes and Introductions 6 03-28-2013 07:43 PM
New Firmware For K-01, K-30, K-5, K-5 II, K-5 IIs, K-r Adam Pentax News and Rumors 63 02-18-2013 02:04 PM



All times are GMT -7. The time now is 05:39 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top