Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
04-15-2018, 05:23 PM   #1
New Member




Join Date: Jun 2017
Location: Columbus, Ohio USA
Posts: 11
55/300 F4/5.8 ED HD WD and a K5

I just received this lens after a long wait on a backorder. The AF function doesn't seem to be engaging. It make an initial search then seems to disengage and what I think is the motor just spins, The only thing I can do is to remove the battery to stop it. A note to B&H suggested to remove the lens, turn the camera off for two minutes, reattach the lens and turn the camera back on. Didn't work. Send help. Thanks

04-15-2018, 05:38 PM   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 47,241
QuoteOriginally posted by MichaelS Quote
I just received this lens after a long wait on a backorder. The AF function doesn't seem to be engaging. It make an initial search then seems to disengage and what I think is the motor just spins, The only thing I can do is to remove the battery to stop it. A note to B&H suggested to remove the lens, turn the camera off for two minutes, reattach the lens and turn the camera back on. Didn't work. Send help. Thanks
Is your battery getting old, of low quality, or not fully charged?

Also, you should clean your lens mount, and wiggle the lens slightly after mounting to ensure that the gears are engaged.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com server and development costs are user-supported. You can help cover these costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

04-15-2018, 06:04 PM   #3
New Member




Join Date: Jun 2017
Location: Columbus, Ohio USA
Posts: 11
Original Poster
QuoteOriginally posted by Adam Quote
Is your battery getting old, of low quality, or not fully charged?

Also, you should clean your lens mount, and wiggle the lens slightly after mounting to ensure that the gears are engaged.
Battery is fully charged but might be old. I cleaned the contacts on both the lens and camera. No luck. Thanks though.
04-15-2018, 06:05 PM   #4
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 47,241
QuoteOriginally posted by MichaelS Quote
Battery is fully charged but might be old. I cleaned the contacts on both the lens and camera. No luck. Thanks though.
If it's the original battery that came with your K-5, it's probably not able to deliver the current needed for extended AF operation with a lens like this. Could you post a video of what happens, so we can make sure that's the issue?


Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com server and development costs are user-supported. You can help cover these costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

04-15-2018, 06:16 PM   #5
New Member




Join Date: Jun 2017
Location: Columbus, Ohio USA
Posts: 11
Original Poster
I switched out my Pentax battery for a newer and fully charged ProMaster battery which I use while the Pentax is charging. No luck. I should have mentioned earlier that I had no trouble when I attached this lens to my istD body. Worked fine the first time.
04-15-2018, 07:17 PM - 1 Like   #6
Forum Member




Join Date: Jan 2016
Photos: Gallery | Albums
Posts: 57
Is this lens screw-drive AF? IIRC, had an issue on my K-50 where the focus selector switch can get bumped to a "between M and AF" state where the screw drive mechanism isn't fully extended or retracted but the camera still registers AF mode. Unfamiliar with the K-5, but give it a look.
04-16-2018, 05:04 AM   #7
Veteran Member




Join Date: Dec 2016
Posts: 559
Yes, try the suggestion above in making sure the camera is “all the way” in autofocus mode.
04-16-2018, 06:06 AM   #8
New Member




Join Date: Jun 2017
Location: Columbus, Ohio USA
Posts: 11
Original Poster
Well I've tried several things. Yes, it is screw drive. I checked the AF knob and it seems secure and everything works when I attach another lens to the k5 body. The new 55/300 also works fine when I attach it to an older, slower and clunckier *istD body. We're going to the camera store today and see what they say but Pentax is not abundant here. thanks to you all for the effort.

04-16-2018, 11:23 AM   #9
Journeyman Cat Wrangler
Loyal Site Supporter
SSGGeezer's Avatar

Join Date: Jun 2017
Location: Maine, U.S.
Photos: Gallery | Albums
Posts: 3,137
Is the AF working correctly with other screw drive lenses? If so it is kind of baffling. I would switch AF on and off several times and try again.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, f4/5.8 ed hd, hd wd, k-5, k-5 ii, k-5 iis, k5, lens, pentax k-5
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
55-200, 55-200 WR, 55-300, 55-300 PLM, etc, which telezoom I should get? Bui Pentax SLR Lens Discussion 67 06-25-2018 08:15 PM
For Sale - Sold: HD Pentax-DA 55-300 F4-5.8 ED WR PRICE REDUCTION PKMike Sold Items 7 02-15-2018 02:34 PM
HD-DA 55-300 F4-5.8 ED WR lens?? Gold Coast Pentax SLR Lens Discussion 13 01-29-2018 05:04 PM
12TB WD Hard Drive - Winder Digital Processing, Software, and Printing 2 09-16-2017 02:19 AM
different between Pentax 6x7 300 F4 ED(IF) and 645 300 F4 ED(IF) popkrab Pentax Medium Format 9 12-17-2011 05:46 PM



All times are GMT -7. The time now is 06:35 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top