Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
07-17-2018, 06:28 PM - 1 Like   #1
Junior Member




Join Date: Jun 2013
Posts: 32
Pentax K-5 II Power Issue - Suggestions Welcomed

Hey, I recently purchased a K-5 II with just under 400 shots on it. The issue is that when powered on it seems that the rear lcd and shutter will hand and not work. The top Lcd and wheels will all work. The strange thing is that it freezes when powered off and needs the battery removed. Now eventually if the battery is removed and put back several times the camera will start and act normal. The camera will remain normal if it is power off and then on within a relatively short time, if left out it will go through the same cycle of not working. To me it sounds like either a power issue or a short somewhere. The fact the camera does power on eventually and work normally gives me hope but this is really a headscratcher. I don't mind taking it apart so if anyone has any ideas, feel free to let me know, thanks so much for reading if you did.

07-17-2018, 06:59 PM - 1 Like   #2
Pentaxian
BirdDude007's Avatar

Join Date: Jun 2009
Location: Las Vegas NV
Photos: Albums
Posts: 658
Did you check and make sure the firmware is up to date?
07-17-2018, 06:59 PM - 1 Like   #3
Pentaxian




Join Date: Sep 2012
Location: NY
Photos: Gallery | Albums
Posts: 3,458
You may want to check to see if you are using an actual Pentax battery which is fully charged and not another brand. I had once tried off brand batteries and never used them again due to their failing and not holding power. I use just Pentax branded batteries now and am very satisfied.

Also, if you press your shutter button halfway, that may wake up the viewing screens/displays.

---------- Post added 07-17-18 at 10:05 PM ----------

You can also do a Reset of your camera menus. If you look under "Reset" in your manual it will tell you what to do. The instructions are on page 296 of my K-5 II/K-5 IIS manual.

Last edited by C_Jones; 07-17-2018 at 07:07 PM.
07-17-2018, 07:21 PM - 1 Like   #4
Junior Member




Join Date: Jun 2013
Posts: 32
Original Poster
Hey, thanks for the replies.

1. Firmware is up to date with 1.07 version
2. Yes, I have tried a fully charged Pentax Battery. It is proven good in a regular K-5.
3. I have also tried all the Menu resets there are.

It seems that it is completely random when it chooses to start and when it won't at all. I do know that the little gray clip that holds in the battery does have a switch that gets pressed to let the camera know a battery is in, similar to the SD card door. If I sometimes play with that it will work which technically means that it is a power/battery issue but I can't seem to lock down a real cause or get any sort of consistency.

07-17-2018, 07:30 PM - 1 Like   #5
Pentaxian




Join Date: Sep 2012
Location: NY
Photos: Gallery | Albums
Posts: 3,458
You may want to make sure the sd card has been formatted in the camera in use. If you possibly could shine a flashlight into your battery compartment to see if the contacts are clean and not damaged that might tell you something also. If you can't find what is wrong, if you have any local camera repair shop that could assess the problem and tell you what the fix may be that might help.

Last edited by C_Jones; 07-17-2018 at 07:37 PM.
07-17-2018, 07:46 PM - 1 Like   #6
Junior Member




Join Date: Jun 2013
Posts: 32
Original Poster
Yes, both the card has been formatted and the contacts are clean, it is a fairly unused camera. I am going to assume it is a fault on the mainboard somewhere. Not sure when there is a weird bug like this if there is anything that can be done besides replacing it. If it helps when it loads up and freezes and then the power is turned off, the top lcd will display the amount of pictures left, from then on it will not act properly until the battery is removed several times. More than likely a camera shop would just replace a whole part and never find the real cause. I mean it could just be a switch or something simple so I figured I'd ask around.
07-17-2018, 08:28 PM - 1 Like   #7
Pentaxian




Join Date: Sep 2012
Location: NY
Photos: Gallery | Albums
Posts: 3,458
Most likely you will get more feedback. I myself have experienced freeze ups, but it was not an ongoing occurrence. I too would remove the battery, wait a moment, place it back in, turn on the camera, and it would usually act normally after that.

Good luck.
08-23-2018, 07:02 AM   #8
Junior Member




Join Date: Feb 2009
Location: Finland
Posts: 28
Do you have any local service that you could ask have they dealt with similar issue?

08-23-2018, 07:02 AM   #9
Junior Member




Join Date: Feb 2009
Location: Finland
Posts: 28
Do you have any local service that you could ask have they dealt with similar issue?
08-23-2018, 12:54 PM   #10
Site Supporter
Site Supporter




Join Date: Dec 2012
Location: Huntsville, AL
Posts: 220
QuoteOriginally posted by apentacitis Quote
It seems that it is completely random when it chooses to start and when it won't at all. I do know that the little gray clip that holds in the battery does have a switch that gets pressed to let the camera know a battery is in, similar to the SD card door. If I sometimes play with that it will work which technically means that it is a power/battery issue but I can't seem to lock down a real cause or get any sort of consistency.
Based on this one fact, I'd bet you have a bad battery clip switch, or whatever the switch under that retainer clip is called. It could be causing some intermittent issues with the camera which might give you some of the issues you're seeing. Worth checking into that, and cleaning the contact points for the switch or perhaps replacing it.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
batteries, battery, brand, camera, dslr, ii, ii power issue, issue, k-5, k-5 ii, k-5 ii power, k-5 iis, k5, lcd, pentax, pentax battery, pentax k-5, power, power issue suggestions
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pentax K3II above the serial number for power off issue has had power off issue Azhure Pentax K-3 3 04-10-2017 03:23 PM
Why I won't buy a K1 - Short Pithy Reasons Welcomed LoneWolf Pentax Full Frame 5 02-18-2016 11:11 AM
Expertise welcomed, yeah it's me, the new guy aamendoza93 Welcomes and Introductions 9 02-11-2016 09:06 AM
How to power 540FGZ flash with Alienbees Vagabond mini II portable power? shadowbecomeswhite Flashes, Lighting, and Studio 2 07-25-2011 07:17 PM
Focus Ring issue on DA15 (owners welcomed in) scorpioh Pentax SLR Lens Discussion 3 08-14-2009 06:44 PM



All times are GMT -7. The time now is 12:22 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top