Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-26-2010, 11:26 AM   #16
Veteran Member




Join Date: Apr 2009
Location: Blacksburg, VA
Posts: 485
Camera received today, no issue with e-dial.

10-26-2010, 01:52 PM   #17
Site Supporter
filmamigo's Avatar

Join Date: Aug 2007
Location: Toronto
Photos: Gallery | Albums
Posts: 685
I had no issue with the e-dial, turning it quickly or slowly.
10-27-2010, 07:01 AM   #18
Site Supporter
Deimos's Avatar

Join Date: Oct 2010
Location: Kingdom of Wonder
Posts: 1,708
I read some posts about the K-r e-dial issue. Someone with a k-r had the issue then it went away. another member with an older pentax dslr said he had the same issue, but it went away shortly afterwards, it had been caused by some condensation or something like that.

Its possible that due to shipping etc this could be the issue. If so the e-dial should correct itself after a little bit when the condensation/residue or whatnot wears off.

Anyone else finding this?
10-27-2010, 02:53 PM   #19
Loyal Site Supporter
bwDraco's Avatar

Join Date: Jul 2010
Location: New York
Photos: Albums
Posts: 1,014
I'm concerned as to whether I can rely on the K-r - faulty e-dial, AF front focus under tungsten... How likely am I going to run into a problem given a random K-r camera body?

--DragonLord

10-27-2010, 05:26 PM   #20
Site Supporter
Deimos's Avatar

Join Date: Oct 2010
Location: Kingdom of Wonder
Posts: 1,708
QuoteOriginally posted by DragonLord Quote
I'm concerned as to whether I can rely on the K-r - faulty e-dial, AF front focus under tungsten... How likely am I going to run into a problem given a random K-r camera body?

--DragonLord
Well as I just posted above the e-dial could just be a condensation issue, and might if present at all just disappear after a bit of use.

I think front focus under tungsten is a problem for a lot of cameras isnt it?

Many people aren't reporting any issues. Mine should arrive tomorrow....
10-27-2010, 06:59 PM   #21
Forum Member




Join Date: Oct 2010
Posts: 62
Just got my K-r in. No e-dial issues at all... acts exactly as I would expect it too. I've scrolled quickly, slowly, both directions, in different menus... and all work okay so far.
11-06-2010, 01:15 PM   #22
Forum Member




Join Date: Apr 2010
Location: kayseri
Posts: 55
i got my k-r today, e dial is responsing slowly or doesnt respond at all. sometimes when i scroll it back it responds like i m scrolling forward.
so should i return it or will it work normally in time ? :/ it d cost me alot due to oversea shipping
11-06-2010, 01:29 PM   #23
Pentaxian
ovim's Avatar

Join Date: Sep 2008
Location: Tre, Finland
Photos: Gallery
Posts: 1,227
QuoteOriginally posted by deathdream Quote
i got my k-r today, e dial is responsing slowly or doesnt respond at all. sometimes when i scroll it back it responds like i m scrolling forward.
so should i return it or will it work normally in time ? :/ it d cost me alot due to oversea shipping
That doesn't sound right, but if others say it has been fixed by itself maybe you can wait a few days before returning it? I've had mine for a few days now and haven't noticed anything wrong with the dial.

11-06-2010, 10:38 PM   #24
Pentaxian
jackassp's Avatar

Join Date: Apr 2010
Location: Adelaide, South Australia
Photos: Gallery
Posts: 795
QuoteOriginally posted by deathdream Quote
i got my k-r today, e dial is responsing slowly or doesnt respond at all. sometimes when i scroll it back it responds like i m scrolling forward.
so should i return it or will it work normally in time ? :/ it d cost me alot due to oversea shipping
Mine was the same.
I subsequently returned the camera and got a replacement, and the e-dial is working perfectly.
11-07-2010, 06:49 AM   #25
Forum Member




Join Date: Aug 2008
Location: Auburn, WA
Posts: 65
Original Poster
Same issue with my K-r when first received. Pentax said it could be returned for warranty service. Amazon said it could be returned and a new one purchased. I chose to buy new one from Amazon, make sure it worked, then return defective. Refund was handled well and was done very quickly by Amazon.
11-07-2010, 07:39 AM   #26
Site Supporter
Deimos's Avatar

Join Date: Oct 2010
Location: Kingdom of Wonder
Posts: 1,708
my e-dial was fine straight out of the box. camera is great.

I vote +1 for a condensation/contact issue, that said if you dont see it going away quick after playing with it awhile, might as well do the return
11-09-2010, 01:42 PM   #27
Forum Member




Join Date: Apr 2010
Location: kayseri
Posts: 55
after using the camera abit, the issue went away :] still missing a click i spinn it too fast but i find the dial functional and dont see a reason to send it for replacement
11-09-2010, 02:05 PM   #28
Site Supporter
Deimos's Avatar

Join Date: Oct 2010
Location: Kingdom of Wonder
Posts: 1,708
QuoteOriginally posted by deathdream Quote
after using the camera abit, the issue went away :] still missing a click i spinn it too fast but i find the dial functional and dont see a reason to send it for replacement
guaranteed its condensation then, should hopefully disappear all together with time. keep us posted
11-09-2010, 03:03 PM   #29
Junior Member




Join Date: Sep 2010
Location: Melbourne
Posts: 42
QuoteOriginally posted by deathdream Quote
after using the camera abit, the issue went away :] still missing a click i spinn it too fast but i find the dial functional and dont see a reason to send it for replacement

may I know more specific...how much use is "abit"?
thanks
11-09-2010, 05:20 PM   #30
Forum Member




Join Date: Apr 2010
Location: kayseri
Posts: 55
i read on dprew about this issue, and a poster said it gone after taking some pics :P didnt count on his advice, so i take my camera to continous shooting n took a hundred pics in a row its been 2 days n dial is working as intended. still sometimes missing a click in a row, when i spin it fast.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, e-dial, k-r, kr, pentax k-r
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K-7 exposure dial not going down? Help please netuser Troubleshooting and Beginner Help 8 07-26-2010 11:20 AM
Is it normal for my K7 shutter button to reset slowly? allill Pentax DSLR Discussion 4 03-11-2010 04:17 PM
Sun Dial tpeace Monthly Photo Contests 2 01-10-2010 05:01 AM
What is your e-dial default? jjay Troubleshooting and Beginner Help 7 03-11-2009 10:37 PM
Fall is slowly saying goodbye fejker Post Your Photos! 12 10-24-2008 01:22 PM



All times are GMT -7. The time now is 08:43 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top