Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-31-2010, 02:34 PM   #1
New Member




Join Date: Oct 2010
Posts: 5
Pentax K-R - Red Dot in Video

Hi, I just recieved my Pentax K-R (first DSLR) and I'm having trouble with a red dot showing up in my videos. I tried dust removal and pixel mapping and it doesn't go away. I can see the dot very easily in video. I can also see the red dot on the LCD during LV for pictures and video. I'm having trouble seeing the dot in images. Can someone recommend anything else to try before i call up Pentax? Thanks for the help.

10-31-2010, 02:36 PM   #2
Inactive Account




Join Date: Aug 2008
Location: Michigan, USA
Photos: Gallery | Albums
Posts: 7,485
Hot pixel. Run the pixel mapping function in the setup menu.

10-31-2010, 02:51 PM   #3
New Member




Join Date: Oct 2010
Posts: 5
Original Poster
I ran the pixel mapping 2 times. Should I keeping trying it? Is there a limit to how many times the pixel mapping should be used? Thanks
10-31-2010, 03:00 PM   #4
Inactive Account




Join Date: Aug 2008
Location: Michigan, USA
Photos: Gallery | Albums
Posts: 7,485
What happens if you view the photos or video on a computer screen (or are you already)? I've only ever had to run the routine once.



10-31-2010, 03:00 PM   #5
Veteran Member




Join Date: May 2009
Location: Twin Cities, MN
Posts: 2,869
Might be valid cause for either warranty repair or return for a defective product to the retailer (I would prefer the latter personally, it doesn't sound like it is functioning properly on arrival). If the hotpixel isn't fixed via pixel mapping then it sounds more like an overheating issue with the sensor during video recording, rather than a particular pixel problem. If that is showing up right away (and not after several minutes of shooting video), I would pursue one of the above avenues right away.

Edit: Jeff has a valid question there - have you viewed the video off of the camera, on a PC or TV?
10-31-2010, 03:03 PM   #6
Veteran Member
KxBlaze's Avatar

Join Date: Feb 2010
Location: California
Photos: Gallery
Posts: 1,594
Transfer the video/picture from the SD card to your computer and see if the red dot shows up. If it does then its not a hot pixel (don't know what it can be). If it does not show up then most likely it's a hot pixel.
10-31-2010, 03:06 PM   #7
Inactive Account




Join Date: Aug 2008
Location: Michigan, USA
Photos: Gallery | Albums
Posts: 7,485
QuoteOriginally posted by KxBlaze Quote
Transfer the video/picture from the SD card to your computer and see if the red dot shows up. If it does then its not a hot pixel (don't know what it can be). If it does not show up then most likely it's a hot pixel.
I think you have that backwards. If it shows up on other than the camera screen, then it's recorded in the image. What I've always considered to be a Hot pixel (perhaps a dead photosite?). I had one on my K7 right out of the box, described exactly the same way. Pixel mapping took care of it.

10-31-2010, 03:06 PM   #8
Pentaxian




Join Date: Jun 2009
Location: GMT +10
Photos: Albums
Posts: 10,594
You can run the pixel mapping as often as you like without any harm. Try it a few more times. There maybe a clump of hot pixels. But if it doesn't work, call up Pentax for a warranty repair.

Out of curiosity, could you pls capture a JPG still image from the video of what the red-dot looks like and post it here. (P-170 of the K-r manual describes how to do this).

10-31-2010, 03:08 PM   #9
New Member




Join Date: Oct 2010
Posts: 5
Original Poster
The dot does show up when I view video on my computer. I can see the dot while using LV for images but i can't find the dot when i view images on the computer. It happens as soon as I turn on the camera.
10-31-2010, 03:37 PM   #10
New Member




Join Date: Oct 2010
Posts: 5
Original Poster
QuoteOriginally posted by rawr Quote
You can run the pixel mapping as often as you like without any harm. Try it a few more times. There maybe a clump of hot pixels. But if it doesn't work, call up Pentax for a warranty repair.

Out of curiosity, could you pls capture a JPG still image from the video of what the red-dot looks like and post it here. (P-170 of the K-r manual describes how to do this).

Here are 2 captures from a video. I will keep trying the pixel mapping to see if that helps. Thanks to everyone for your help.
Attached Images
   
10-31-2010, 03:52 PM   #11
Pentaxian




Join Date: Jun 2009
Location: GMT +10
Photos: Albums
Posts: 10,594
Yep, looks like a hot pixel or two to me.

That's the thing about hot-pixels in video. You notice them more than in stills, and they are much harder to clean up in video post-processing too than they are in still PP, so I have read.
11-01-2010, 11:25 AM   #12
New Member




Join Date: Oct 2010
Posts: 5
Original Poster
After trying pixel mapping about 20 more times i gave up. The camera is going back to the retailer today.

I also read on some canon forums that the pixel mapping on some cameras is just for still shots and not video. Is this the same for the K-r?
11-01-2010, 11:30 AM   #13
ogl
Pentaxian
ogl's Avatar

Join Date: Dec 2007
Location: Siberia
Photos: Gallery | Albums
Posts: 7,114
It's not hot. It's dead pixel IMO. But...as for me - I don't care about it
11-01-2010, 01:57 PM   #14
Pentaxian




Join Date: Jun 2009
Location: GMT +10
Photos: Albums
Posts: 10,594
QuoteOriginally posted by marlonf Quote
I also read on some canon forums that the pixel mapping on some cameras is just for still shots and not video. Is this the same for the K-r
I doubt it. The camera only has one sensor that does the job of both video and still images. Pixel mapping works at the sensor level.
11-12-2010, 09:02 AM   #15
Forum Member




Join Date: Aug 2010
Posts: 54
I just got my k-r the other day and it has the same problem. Pixel mapping does not fix the problem. I want to send it back to newegg, but I don't to receive a new one with the same problem or worse.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dot, k-r, kr, pentax, pentax k-r, trouble, video
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
oversaturated/ red Video result K7 bjan Pentax DSLR Discussion 2 07-25-2010 01:46 PM
K-7 with 16-50, video from WhatDC, video from pentax Isaac314 Pentax News and Rumors 10 05-21-2009 11:11 AM
Red and Blue dot in my picture? jeremy_c Pentax DSLR Discussion 7 11-17-2008 09:19 AM
www(dot)filterhouse(dot)com Ed in GA Pentax Camera and Field Accessories 1 05-17-2008 02:04 PM
Red Dot Sight / Scope - RDS DIY tswill2 Digital Processing, Software, and Printing 0 12-15-2006 10:51 AM



All times are GMT -7. The time now is 09:19 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top