Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
01-08-2011, 05:05 AM   #61
Veteran Member
Hypocorism's Avatar

Join Date: Sep 2010
Location: Melbourne .au
Posts: 623
QuoteOriginally posted by dragra Quote
It was quite hard for me to reproduce the FF issue under tungsten light. First I had to get a tungsten light source.
...
FF was there when camera was on AWB. It has gone away after set to Tungsten WB. My take on this is that when set to Tungsten WB the camera takes a hint of which wavelength the light may come. In AWB it guesses and since K-r does not employ color information it misses the guessing game.
Your take on that sounds quite logical to me. This might even be a good omen for encouraging more people to abandon their remaining legacy tungsten in interests of global warming too. So can't be all bad.

QuoteOriginally posted by dragra Quote
I must be the only one out there with a K-r which is intact. All other users have several problems, as you can see in this and other forums.
Yes it's hard not to feel for the few unlucky ones who received theirs with functions not operating at all. Otoh; so far mine has been a pleasant surprise overall, touch wood, and when I use the old K-x the 'missing features' can even be a bit of a frustrating reminder.

Hehe, I'm really more thankful for escaping the K-5 train wreck! That expensive exercise in misguided euphoria was on the agenda (for a short time).

.R.

01-08-2011, 10:54 AM   #62
ogl
Pentaxian
ogl's Avatar

Join Date: Dec 2007
Location: Siberia
Photos: Gallery | Albums
Posts: 7,112
"AF assist lamp doesn't work in main (exposure) modes with firmware 1.01 at all.
But it works very fine and correct in scene and picture modes" (from one K-r user)

Check it, please.
01-08-2011, 11:07 AM   #63
Senior Member
dragra's Avatar

Join Date: Dec 2010
Location: Ljubljana
Photos: Albums
Posts: 238
QuoteOriginally posted by ogl Quote
"AF assist lamp doesn't work in main (exposure) modes with firmware 1.01 at all.
But it works very fine and correct in scene and picture modes" (from one K-r user)

Check it, please.
Works in Av and all other modes. Just checked.

cheers,
d
01-08-2011, 01:01 PM   #64
Veteran Member




Join Date: Jul 2010
Location: Santa Cruz, CA
Photos: Albums
Posts: 377
QuoteOriginally posted by dragra Quote
Works in Av and all other modes. Just checked.

cheers,
d
Phew! That's good news. I was pretty scared for a second.

01-08-2011, 01:43 PM   #65
Senior Member
dragra's Avatar

Join Date: Dec 2010
Location: Ljubljana
Photos: Albums
Posts: 238
QuoteOriginally posted by bsamcash Quote
Phew! That's good news. I was pretty scared for a second.
That green lamp is a LED, so I doubt it would go dead in any time near. Probably was disabled by user.
01-09-2011, 06:52 AM   #66
ogl
Pentaxian
ogl's Avatar

Join Date: Dec 2007
Location: Siberia
Photos: Gallery | Albums
Posts: 7,112
QuoteOriginally posted by dragra Quote
That green lamp is a LED, so I doubt it would go dead in any time near. Probably was disabled by user.
Is it real to switch AF assist lamp off?
01-09-2011, 07:48 AM   #67
Senior Member
dragra's Avatar

Join Date: Dec 2010
Location: Ljubljana
Photos: Albums
Posts: 238
QuoteOriginally posted by ogl Quote
Is it real to switch AF assist lamp off?
@ogl: do you have the camera or is your question just theoretic?

C2 Menu, chapter 11.

cheers,
d
01-09-2011, 08:50 AM   #68
ogl
Pentaxian
ogl's Avatar

Join Date: Dec 2007
Location: Siberia
Photos: Gallery | Albums
Posts: 7,112
QuoteOriginally posted by dragra Quote
@ogl: do you have the camera or is your question just theoretic?

C2 Menu, chapter 11.

cheers,
d
I have no.
The user already solved problem - he tried to use AF.C No any problem with AF assist lamp.

01-09-2011, 09:07 AM   #69
Senior Member
dragra's Avatar

Join Date: Dec 2010
Location: Ljubljana
Photos: Albums
Posts: 238
QuoteOriginally posted by ogl Quote
I have no.
The user already solved problem - he tried to use AF.C No any problem with AF assist lamp.
AF assist works regardless AF-S, AF-C or MF, simply beyond certain low LV value the light goes on automatic. It is good to have a option to switch the AF assist off in places where it would be disturbing.
01-09-2011, 10:11 PM   #70
Forum Member




Join Date: Oct 2010
Posts: 87
For those who thought it was a little paranoid to not just upgrade the firmware when it was available... here's one reason for people to be hesitant about upgrades:
Apple - Support - Discussions - Problems after Firmware update 7.5.2? ...

I have this AirPort router, and like many others, it seems, Apple's latest update has caused many, many problems.
01-09-2011, 10:18 PM   #71
Forum Member




Join Date: Oct 2010
Posts: 87
QuoteOriginally posted by Hypocorism Quote
Your take on that sounds quite logical to me. This might even be a good omen for encouraging more people to abandon their remaining legacy tungsten in interests of global warming too. So can't be all bad.
Actually, my brother has been testing various lights under a spectrometer recently for the purpose of setting up lighting conditions in a lab. He tested a couple CFL's because a colleague was curious.

Even a "full-spectrum" CFL basically uses three phosphors, meaning three primary wavelengths of light are emitted. The light is not white or beige or whatever approximation -- it's red, green, and blue mixed together. This could potentially make certain colours look a bit off, especially when photographed. Then there's the fact that they're hazardous waste.

Tungsten? Sure, it's warm (to the red end of the spectrum), but it's a fairly even curve across the spectrum, at least.

I've actually got a bunch of CFLs here at home. It's just a couple fixtures on dimmers that I use incandescents for, but I switched them to some new higher-efficiency halogens. I really like them.
01-15-2011, 11:19 AM   #72
Banned




Join Date: Jan 2011
Posts: 242
QuoteOriginally posted by dragra Quote
It was quite hard for me to reproduce the FF issue under tungsten light. First I had to get a tungsten light source. When I finally got it I found out that the light source has to be dimmed down to an extent where normal picture taking and focusing with an human eye would become difficult.

FF was there when camera was on AWB.
Can anyone post some photos with front focus?

I updated my K-r to 1.01, but I cannot see any difference.
EDIT: but there is two differences - better AF in very low light (the AF assist lamp turns on not so frequently) and FF in tungsten is worse, more evident (at least at my Kr).

Last edited by ursamajor; 01-16-2011 at 10:19 AM.
01-20-2011, 10:06 AM - 1 Like   #73
New Member




Join Date: Jan 2011
Posts: 11
Stealth update for K-r too!

Thought of checking it out and as we can see the K-r packet has also changed.

8d39af36261600867a8e306e069b6818 kr_e101m.zip
98e5aa23181c0a3c78a4de23faabe983 kr_e101m(2).zip

Internal version 1.01.20.8 -> 1.01.20.9.

Haven't noticed any difference yet, after updating.
01-21-2011, 03:08 PM   #74
Banned




Join Date: Jan 2011
Posts: 242
Can a new firmware solve the front focus problem in tungsten light? Or it is a service problem?
01-23-2011, 03:53 AM   #75
Banned




Join Date: Jan 2011
Posts: 242
Nobody knows?
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, firmware, k-r, kr, pentax, pentax k-r, pentax k-r firmware
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pentax firmware update RED LIGHT!!! Silverkarn Pentax DSLR Discussion 48 01-08-2011 03:47 PM
Anyone noticed Pentax quietly update K200D firmware from 1.01.00.05 to 1.01.00.06? arm_jstp Pentax DSLR Discussion 10 09-23-2010 12:28 PM
Why no firmware update from Metz for Pentax? quaker Flashes, Lighting, and Studio 4 11-09-2009 02:43 PM
Pentax K20D Firmware Update Nelepl Pentax News and Rumors 8 05-11-2009 04:36 PM
Sigma EF-500 DG ST Flash Firmware Update For Pentax K10D stewart_photo Flashes, Lighting, and Studio 3 08-10-2007 07:06 PM



All times are GMT -7. The time now is 11:28 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top