Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-14-2011, 09:11 AM   #106
New Member




Join Date: Sep 2011
Photos: Gallery
Posts: 14
Hi
Join the club lots of people seem to have this problem it can only be caused by one thing Faulty parts with poor quality controle. Note the tungston lighting problem can't be fixed.Dust seals suspect gives this modle a poor track record.

09-21-2011, 10:50 AM - 1 Like   #107
Inactive Account




Join Date: Feb 2011
Location: buffalo, new york
Photos: Gallery
Posts: 5
i received my k-r in april, e-dial acted up shortly thereafter (moving it either way would result in a fast forwarding/sporadic to the highest zoom or aperture, etc and it would get stuck there). the moving it fast back and forth technique did little to help me. i sent it to pentax and had it fixed under warranty. received it from pentax repair, worked for awhile (< a month), then last month had the same issues while on vacation. i emailed pentax for what to do, send it for repair again or ask for a new body, they said "send it for repair again".

last night i went to my local home depot and picked up this contact cleaner http://www.crcindustries.com/Catalog/images/Cleaners%20and%20Degreasers/02130.jpg
after applying the contact solution, my e-dial is working like it hasn't ever worked before ... like new!
the dial moves incrementally, step by step as it should in all modes.

note: home depot also sells a CRC degreaser, but it did not say it was safe for plastics so i bought the contact cleaner instead. also, the contact cleaner did not come with a straw for intricate spraying, so i took one off another can for this purpose. don't tell. hope this helps skeptics on the fence.
09-29-2011, 10:02 PM   #108
jdg
Forum Member
jdg's Avatar

Join Date: Mar 2008
Location: Cavite, Philippines
Posts: 85
Does this problem affect even new k-r's that are available today or is it an old batch issue?

When using a contact cleaner without disassembling the top of the camera, would the contact cleaner or grease residues on the e-dial be blown somewhere inside the camera and affect the buttons and pcb board near it?

Last edited by jdg; 09-29-2011 at 10:19 PM.
09-29-2011, 10:31 PM   #109
Forum Member




Join Date: Oct 2010
Posts: 87
QuoteOriginally posted by jdg Quote
Does this problem affect even new k-r's that are available today or is it an old batch issue?
Hard to say without a survey, but the K-x also have had issues with the e-dial... Other models, too:
https://www.pentaxforums.com/forums/pentax-dslr-discussion/40715-e-dial-wheel...lp-please.html

09-29-2011, 10:59 PM   #110
Veteran Member
Philoslothical's Avatar

Join Date: May 2011
Posts: 1,723
It hasn't become an issue on my K-r yet, over 3 months in now. It's definitely not every copy affected. It's such an easy thing to fix that there's no need to worry about it.
09-30-2011, 09:36 AM   #111
Veteran Member
lammie200's Avatar

Join Date: Jun 2011
Location: San Francisco
Photos: Albums
Posts: 1,028
+1

QuoteOriginally posted by Philoslothical Quote
It hasn't become an issue on my K-r yet, over 3 months in now. It's definitely not every copy affected. It's such an easy thing to fix that there's no need to worry about it.

Same here. No problems thus far and the dial has always had a very positive feel about it. Hope that it stays that way.

Funny because the demo model in the store definitely had the problem.
10-02-2011, 05:52 PM   #112
Veteran Member




Join Date: Nov 2010
Location: Edmonton, Alberta
Posts: 800
I noticed I was having this issue the other day and decided I would do something about it. I sat there and moved the wheel left for 3 minutes and... it works fine... for now. So far that's been the only issue with this wonderful camera
11-13-2011, 08:21 PM   #113
Senior Member
CP140's Avatar

Join Date: Jun 2011
Location: Greater Vancouver
Photos: Gallery | Albums
Posts: 188
My edial had been working fine until today. Today I was playing with macro and had the camera pointed straight down for an extended time while I played with focus and other settings.

The edial started becoming "flakey" towards the end of the afternoon.

As suggested, I pulled the battery (it was time to recharge anyway), gave the dial a couple short squirts of contact cleaner, rotated the dial back and forth a few times and let the camera sit while the battery charged.

The dial is now back to working fine. I suspect the prolonged period pointed straight down gave enough time for a blob of the grease to work itelf free while I was playing with settings...

In any case...add me to the positive reviews for the "2 squirts of contact cleaner" solution.

11-14-2011, 02:24 PM   #114
Junior Member




Join Date: Jan 2011
Location: Pa.
Photos: Gallery
Posts: 26
Another positive response for the contact cleaner. My e-dial had been fine until last month. I bought my K-r in Feb.
It gradually became worse until this weekend when it was unset-able. I used the contact cleaner today and it now works just fine. Thanks for the info.
11-16-2011, 10:29 AM   #115
Inactive Account




Join Date: Jun 2011
Location: Indiana
Photos: Albums
Posts: 10
Still going good.

I used the contact cleaner in July and the eDial is still working perfectly. I was a bit paranoid in the beginning and used to carry around the contact cleaner in case the dial acted up again. I am pleased to report that I never had to use the contact cleaner after the very first time. I've been in hot & humid to nearly freezing weather since then and the dial's still working perfectly This winter, I can take this camera half-way around the world with full confidence.
11-18-2011, 09:35 PM   #116
Veteran Member




Join Date: Mar 2011
Location: Eastern Kentucky
Posts: 416
Edial on my K_X which is about 9 months old isn't working right,also the shutter button sticks.Have tried spinning it and blowing air around it but it don't help.Plan on putting up with it until about a month before the warranty expires before sending it in for repair.
This doesn't look for the management of the company letting this problem exist threw at least two models of camera.
Jake
11-21-2011, 07:03 AM   #117
New Member




Join Date: Mar 2010
Location: Antipolo Rizal Philippines
Posts: 11
I stumbled on this thread and thought I try the contact cleaner solution on my K-7's rear e-dial. while I could work
around the problem before by rotating the dial slowly, there are times that you need to move fast and that erratic
movement is annoying.
anyway, I have a can of contact cleaner lying around so gave my k-7 a couple of squirts and it's now working fine.
btw, I did remove the batteries first though.
11-21-2011, 12:15 PM   #118
Veteran Member




Join Date: Mar 2011
Location: Eastern Kentucky
Posts: 416
Bought a can of CRC QD Electronic cleaner,sprayed the edial and shutter button,both seem to be working better.
Jake
11-21-2011, 12:42 PM   #119
Veteran Member
Philoslothical's Avatar

Join Date: May 2011
Posts: 1,723
I kinda feel like this thread should be slightly retitled and stickied in the troubleshooting forum, as this is a common issue, a proven DIY fix, and affects more models than just the K-r.
11-28-2011, 04:19 AM   #120
Finknottle
Guest




E-dial question.

Being a complete new dslr user and having just bought a new K-r, I am concerned about this possible inherent fault with the operating of the e-dial. Is it possible for someone to guide me through how to get the e-dial in operational mode and what is it supposed to do, please?
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, e-dial, k-r, kr, pentax k-r
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
E-DIAL wheel on PENTAX IST DS help please grgo12 Pentax DSLR Discussion 29 05-01-2015 02:13 PM
problemas con el e-dial pentax kr galamo78 Troubleshooting and Beginner Help 8 12-19-2011 06:52 PM
Pentax K-x mode dial decal for your laptop/macbook/ipad/netbook commo Pentax DSLR Discussion 8 09-18-2010 09:56 AM
Pentax *ist Selection Dial problem unixrevolution Pentax Film SLR Discussion 5 08-10-2010 06:00 AM
Pentax ist*DS - Bad rotary dial awjweb Pentax DSLR Discussion 13 03-20-2007 08:42 AM



All times are GMT -7. The time now is 12:12 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top