Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
04-01-2011, 06:15 PM   #1
New Member




Join Date: Apr 2011
Posts: 2
Pentax K-r E-dial

Hey guys! My K-r seems to have a problem with its E-dial, and I was wondering if anyone else had this same problem. When I turn my dial to the right, in increases the values as it should. However, when I turn it to the left, it decreases them while sometimes jumping much, much higher. (For instance dialing down from 1/100, then suddenly jumping up to 1/500).

I've already sent my K-r in to get repaired for this problem, and when I got it back the repair slip said they had replaced the electronic board, as there was a problem with it. It worked perfectly! Now, two or so months later it's experiencing the same exact problem and I've hardly even had time to use it considering I've been really busy with my work.

Does anyone have any idea about this problem? It's making me so sad .

Note: My camera has never gotten wet, and sits in my cool, dark room whenever I'm not using it. So I'm not damaging it, it just seems to fail on it's own?

04-01-2011, 06:22 PM   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 40,984
Sounds like they didn't repair it properly! I would send it in again before your warranty expires.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

04-01-2011, 09:04 PM   #3
Senior Member




Join Date: Feb 2011
Location: Chicago, IL
Photos: Gallery
Posts: 168
Mine is doing the same thing. I am about to send it out for repair. Its annoying. I have heard of a few others with this issue.
04-01-2011, 10:28 PM   #4
Site Supporter
ovim's Avatar

Join Date: Sep 2008
Location: Tre, Finland
Photos: Gallery
Posts: 1,227
Welcome Retsiger!

I had the same problem and it was repaired under warranty and haven't had any problems since. But I have seen some posts by K-7 users with the same problem and some were able to "repair" the fault by turning the e-dial constantly for a couple of minutes. I think the explanation offered was too much grease in the e-dial mechanism which caused the erratic behaviour. After the K-r launch there were some reports by users experiencing e-dial glitches and some of those problems went away after some use.

Of course the wisest thing to do would be sending the camera in to be repaired (again) under warranty.

04-02-2011, 04:58 AM   #5
Pentaxian
adwb's Avatar

Join Date: Sep 2009
Location: Bristol UK
Photos: Gallery
Posts: 1,631
I have the same problem which also shows up when used to zoom in and out on preview etc.
suppose it will have to go in as well. The repair people in England are a subcontracter to pentax and are so slow.Perhaps I should take it back to the shop I have a feeling it is the best route.
04-02-2011, 09:57 AM   #6
New Member




Join Date: Feb 2011
Location: Woodstock
Photos: Albums
Posts: 14
QuoteOriginally posted by ovim Quote
...and some were able to "repair" the fault by turning the e-dial constantly for a couple of minutes



That actually worked……..
Mine was not responding at all, was stuck at F22 and I dreaded sending the camera for repair….
After reading this post I rotated the dial both directions for good 5 minutes and….it works now just fine. Also noticed that the click sound of the dial is different now, somewhat crispier.
Ovim, a big "Thank You!" for sharing this info.

Last edited by kostadinov; 04-02-2011 at 10:03 AM.
04-02-2011, 11:59 AM   #7
Site Supporter
ovim's Avatar

Join Date: Sep 2008
Location: Tre, Finland
Photos: Gallery
Posts: 1,227
I'm glad you got it working
04-03-2011, 03:21 AM   #8
Pentaxian
adwb's Avatar

Join Date: Sep 2009
Location: Bristol UK
Photos: Gallery
Posts: 1,631
ok fixed mine I did what a cannon repair centre man told me, go buy a spray tin of electrical contact cleaner and spray a quick burst in the slot the wheel sits in spin it a few times,instant cure, it s just a spot of lube that pentax used when assembling that gets on the contacts.
it can't hurt the camera; it evaporates and if it don't fix it no one will know but you and therefore won't affect warranty if you still need to send it in.

04-03-2011, 07:48 AM   #9
Junior Member




Join Date: Dec 2008
Location: Austin, Texas
Posts: 42
I thought I "fixed" mine this way when I got my k-r last December but the problem re-occurred in a couple weeks. So returned mine for a refund. I suggest that you return or exchange yours for a new body if still possible and if not, send it for warranty repair. Considering how prevalent the problem is, I suspect it is a manufacturing defect. You may temporarily fix the problem, but it may come back again.

QuoteOriginally posted by kostadinov Quote


That actually worked……..
Mine was not responding at all, was stuck at F22 and I dreaded sending the camera for repair….
After reading this post I rotated the dial both directions for good 5 minutes and….it works now just fine. Also noticed that the click sound of the dial is different now, somewhat crispier.
Ovim, a big "Thank You!" for sharing this info.
04-03-2011, 06:35 PM   #10
Inactive Account




Join Date: Feb 2011
Location: Florianópolis
Photos: Gallery
Posts: 8
Me Too

I have the same problem. I tried turning the dial but it got worse. Now the top dial is not working either. Has anyone else had success with this technique?
04-03-2011, 09:44 PM   #11
New Member
donutman_2000's Avatar

Join Date: Dec 2010
Location: Vancouver, BC
Photos: Gallery
Posts: 23
I had the same problem too after a couple months of use. Spinning the dial for a long time fixed it temporarily, but it would just start acting up again. Finally sent it in for repair, so now I'm K-r-less for a few more weeks.

I do have a can of contact cleaner, so I'll try that if it messes up again later after my warranty is up. I was afraid it might damage something so I never tried it.
04-04-2011, 03:35 AM   #12
Senior Member




Join Date: Jan 2011
Location: Paradise, NL
Photos: Albums
Posts: 106
I had the same problem. I sent it to Pentax Service and they fixed it. I haven't had an issue with it since.

AB
04-04-2011, 04:17 AM   #13
Inactive Account




Join Date: Feb 2011
Location: Florianópolis
Photos: Gallery
Posts: 8
I'd like to solve it for myself because I live in Brazil, so in order to send it for repair, I need to post it to the USA and also need an address in the US, because they don't ship it back to other countries.
04-04-2011, 05:55 AM   #14
Senior Member




Join Date: Feb 2011
Location: Chicago, IL
Photos: Gallery
Posts: 168
Ok, I spun the dial for a few minutes either way. It now works again! Seeing as this isn't that technical of a fix, I am now wondering if I should still send it away for a 'real' fix so this doesn't happen again one day past warranty. The only issue is now that it's working , will Pentax do anything about it even if I send it? Hmmm.
04-04-2011, 11:45 AM   #15
New Member




Join Date: Apr 2011
Posts: 2
Original Poster
The temporary "spin-fix" also relieved my K-r's problems, however it did not the first time this happened. I'm a little concerned seeing as this is the second time it's happened to my K-r, and happened again AFTER I had already sent it in under warranty to get it repaired. At least the spinning worked for now though!
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, e-dial, k-r, kr, pentax k-r
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
E-DIAL wheel on PENTAX IST DS help please grgo12 Pentax DSLR Discussion 29 05-01-2015 02:13 PM
problemas con el e-dial pentax kr galamo78 Troubleshooting and Beginner Help 8 12-19-2011 06:52 PM
Pentax K-x mode dial decal for your laptop/macbook/ipad/netbook commo Pentax DSLR Discussion 8 09-18-2010 09:56 AM
Pentax *ist Selection Dial problem unixrevolution Pentax Film SLR Discussion 5 08-10-2010 06:00 AM
Pentax ist*DS - Bad rotary dial awjweb Pentax DSLR Discussion 13 03-20-2007 08:42 AM



All times are GMT -7. The time now is 04:09 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top